VMware Cloud Community
JulianBRos
Contributor
Contributor

Bad write-performance on iSCSI SAN

Hello community,

I've got a question to the following infrastructure: ESX 4.1 U1 on a HP ProLiant DL380G5 with the DLink DSN 2100 10 in iSCSI mode. The SAN is configured to present 3 LUNs to the ESX. The SAN itself has 8 x 1TB physical S-ATA disks running in RAID10 (configured by a third-party IT-Service provider). The physical connection between ESX and SAN is realised through 3x 1GBit/s with VLAN seperated Links. ESX is configured with multipathing and round robin to talk with the SAN.

Whats my problem? My problem is the write-performance of the SAN! It's incredibly low (at about 10 MegaBYTE per second, round about 100MegaBIT/s). Read performance is very good, about 100 MegaBYTE/s / 1Gigabit/s)!

It doesn't matter if I copy a file from VM to VM or just provision a new VM using vSphere Client. The write-performance is very bad!

Can someone confirm that or has any other ideas? I'm beyond my ken with this issue!

The last steps I did (it didn't worked before too): configure LACP / static Links on SAN side and on ESX, configured multi-pathing with all three available NIC's. Changed path-policy to Round-Robin. Any suggestions?

Hope you can help me.

Julian

Reply
0 Kudos
3 Replies
a_p_
Leadership
Leadership

Only a thought: Did you already check whether the battery/write cache on the storage system is active and the LUNs are configured for write-back (rather than write-through) operation?

André

JulianBRos
Contributor
Contributor

Thank you for your suggestion. As far as I can remember we had an issue with the battery. A restart of the SAN "fixed" this issue. (This was the solution provided by the third-party IT-Service)The SAN is configured for WRITE-THROUGH. I attached some screenshots, may you can help me solving this problem! Thank you so far!!

Bildschirmfoto 2013-08-01 um 14.54.20.png

Bildschirmfoto 2013-08-01 um 14.57.44.png

Reply
0 Kudos
a_p_
Leadership
Leadership

Unfortunately, I'm not familiar with this storage system. However, according to the documentation it should - by default - automatically switch to Write-Back caching if the battery is ok. It looks like you can override this setting in the "System Policy" tab, but I don't recommend doing this to avoid possible data loss!

André

Reply
0 Kudos