VMware Cloud Community
cypherx
Hot Shot
Hot Shot

Autofit Window & Fit Window Now

Ok I have an annoying occurrence with the vSphere Client. When opening a guest console the screen is never sized properly. We have Autofit Window checked, but still the console opens up real small, like 640x480 if that. So I ALWAYS have to go into View > Fit Window Now, and then it fixes it.

This is annoying. What's the purpose of Autofit Window if it doesn't work.

VMWare tools is always installed on the guest O/S.

Reply
0 Kudos
4 Replies
mrubalcaba
Contributor
Contributor

I have this problem as well, and haven't found much on it. What I had recently changed was installing the IE8 update (5 NOV 2009) and after my machine restart, my console windows all opened up to the correct "auto fit window" size (using vSphere4 client).

I'm using WinXP Pro SP3.

I'm curious as to what the cause and remedy is.

Reply
0 Kudos
FredWilliams
Contributor
Contributor

Some times happens to me as well, I just go in to the VM, and reset the screen resolution (WIndows) via the desktop, and change resolution to 1024x768 (Even if its already set to that already), this usually puts everything right on the VM consoles that are acting strange.

Fred

Reply
0 Kudos
mrubalcaba
Contributor
Contributor

I have tried that and the only thing that seems to consistently work is having to uncheck autofit window, and recheck it. Not very 'auto' if you ask me.

I have read another topic that said to check the "auto-detect video settings" box under the VMs video card.

All of my VMs are Win2k3 R2, and each has a different desktop resolution. It doesn't seem to matter what resolution I set it at, as the auto-fit not working is a random occurrence.

Reply
0 Kudos
jorgitogutierre
Contributor
Contributor

I have the same problem with vSphere 4 update 1 and ESXi.

Did anybody find a solution?

Reply
0 Kudos