JTCopy9
Contributor
Contributor

Applying post Update 1 Patches Produces HALT Error

Jump to solution

I am attempting to update my 5.0 U1 hosts with the patches : ESXi500-201204001 , ESXi500-201205001 & ESXi500-201206001.

After installing via esxcli, after the server is restarted, I get a purple Halt screen with the error message:

#PF Exception 14 in world 4739: jumpstart IP 0x7000001 addr 0x7000001

(screeen shot attached)

Any help is greatly apprecaited.

J.T.

0 Kudos
1 Solution

Accepted Solutions
glenngahnstedt
Contributor
Contributor

Hi JTCopy9,

I have/had the exact same issue and my PSOD is identical to yours apart from unrelevant entries.

I have found that if you run the command i.e "esxcli software vib update -d /vmfs/volumes/datastore1/Updates/ESXi500-201205001.zip"

Instead of:

esxcli software vib install -d /vmfs/volumes/datastore1/Updates/ESXi500-201205001.zip"

The update is sucessful and after the reboot the host will come up as it should.

However,

When running the UPDATE command -- ONLY the ESX-BASE package (on a clean installation) will be updated.

When you run the install command there is a lot more going on:

Installation Result:

   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
VIBs Installed:
VMware_bootbank_ata-pata-amd_0.3.10-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-atiixp_0.4.6-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-via_0.3.3-2vmw.500.0.0.469512, VMware_bootbank_block-cciss_3.6.14-10vmw.500.0.0.469512, VMware_bootbank_esx-base_5.0.0-1.13.702118, VMware_bootbank_esx-tboot_5.0.0-0.0.469512, VMware_bootbank_ima-qla4xxx_2.01.07-1vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.500.0.0.469512, VMware_bootbank_misc-cnic-register_1.1-1vmw.500.0.0.469512, VMware_bootbank_net-be2net_4.0.88.0-1vmw.500.0.7.515841, VMware_bootbank_net-bnx2_2.0.15g.v50.11-5vmw.500.0.0.469512, VMware_bootbank_net-bnx2x_1.61.15.v50.1-1vmw.500.0.0.469512, VMware_bootbank_net-cnic_1.10.2j.v50.7-2vmw.500.0.0.469512, VMware_bootbank_net-e1000_8.0.3.1-2vmw.500.0.7.515841, VMware_bootbank_net-enic_1.4.2.15a-1vmw.500.0.0.469512, VMware_bootbank_net-forcedeth_0.61-2vmw.500.0.0.469512, VMware_bootbank_net-igb_2.1.11.1-3vmw.500.0.0.469512, VMware_bootbank_net-ixgbe_2.0.84.8.2-10vmw.500.0.0.469512, VMware_bootbank_net-nx-nic_4.0.557-3vmw.500.1.11.623860, VMware_bootbank_net-r8168_8.013.00-3vmw.500.0.0.469512, VMware_bootbank_net-r8169_6.011.00-2vmw.500.0.0.469512, VMware_bootbank_net-s2io_2.1.4.13427-3vmw.500.0.0.469512, VMware_bootbank_net-sky2_1.20-2vmw.500.0.0.469512, VMware_bootbank_net-tg3_3.110h.v50.4-4vmw.500.0.0.469512, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-nv_3.5-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-promise_2.12-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-sil_2.3-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-svw_2.3-3vmw.500.0.0.469512, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.500.0.0.469512, VMware_bootbank_scsi-aic79xx_3.1-5vmw.500.0.0.469512, VMware_bootbank_scsi-bnx2i_1.9.1d.v50.1-3vmw.500.0.0.469512, VMware_bootbank_scsi-fnic_1.5.0.3-1vmw.500.0.0.469512, VMware_bootbank_scsi-hpsa_5.0.0-17vmw.500.0.0.469512, VMware_bootbank_scsi-ips_7.12.05-4vmw.500.0.0.469512, VMware_bootbank_scsi-lpfc820_8.2.2.1-18vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.500.0.0.469512, VMware_bootbank_scsi-mpt2sas_06.00.00.00-6vmw.500.1.11.623860, VMware_bootbank_scsi-mptsas_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-mptspi_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-qla2xxx_901.k1.1-14vmw.500.0.0.469512, VMware_bootbank_scsi-qla4xxx_5.01.03.2-3vmw.500.0.0.469512, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.500.0.0.469512
VIBs Removed:
Broadcom_bootbank_misc-cnic-register_1.70.0.v50.9-1OEM.500.0.0.472560, Broadcom_bootbank_net-bnx2_2.1.12b.v50.3-1OEM.500.0.0.472560, Broadcom_bootbank_net-bnx2x_1.70.34.v50.1-1OEM.500.0.0.472560, Broadcom_bootbank_net-cnic_1.11.18.v50.1-1OEM.500.0.0.472560, Broadcom_bootbank_net-tg3_3.120h.v50.2-1OEM.500.0.0.472560, Broadcom_bootbank_scsi-bnx2i_2.70.1k.v50.2-1OEM.500.0.0.472560, Emulex_bootbank_net-be2net_4.0.355.1-1OEM.500.0.0.406165, Emulex_bootbank_scsi-lpfc820_8.2.2.105.36-1OEM.500.0.0.406165, Hewlett-Packard_bootbank_scsi-hpsa_5.0.0-24OEM.500.0.0.406165, LSI_bootbank_scsi-mpt2sas_10.10.10.00.1vmw-1OEM.500.0.0.472560, VMware_bootbank_ata-pata-amd_0.3.10-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-atiixp_0.4.6-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-via_0.3.3-2vmw.500.1.11.623860, VMware_bootbank_block-cciss_3.6.14-10vmw.500.1.11.623860, VMware_bootbank_esx-base_5.0.0-1.11.623860, VMware_bootbank_esx-tboot_5.0.0-1.11.623860, VMware_bootbank_ima-qla4xxx_2.01.07-1vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.500.1.11.623860, VMware_bootbank_net-e1000_8.0.3.1-2vmw.500.1.11.623860, VMware_bootbank_net-enic_1.4.2.15a-1vmw.500.1.11.623860, VMware_bootbank_net-forcedeth_0.61-2vmw.500.1.11.623860, VMware_bootbank_net-igb_2.1.11.1-3vmw.500.1.11.623860, VMware_bootbank_net-ixgbe_2.0.84.8.2-10vmw.500.1.11.623860, VMware_bootbank_net-nx-nic_5.0.601-3vmw.500.0.0.406165, VMware_bootbank_net-r8168_8.013.00-3vmw.500.1.11.623860, VMware_bootbank_net-r8169_6.011.00-2vmw.500.1.11.623860, VMware_bootbank_net-s2io_2.1.4.13427-3vmw.500.1.11.623860, VMware_bootbank_net-sky2_1.20-2vmw.500.1.11.623860, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-nv_3.5-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-promise_2.12-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-sil_2.3-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-svw_2.3-3vmw.500.1.11.623860, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.500.1.11.623860, VMware_bootbank_scsi-aic79xx_3.1-5vmw.500.1.11.623860, VMware_bootbank_scsi-fnic_1.5.0.3-1vmw.500.1.11.623860, VMware_bootbank_scsi-ips_7.12.05-4vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.500.1.11.623860, VMware_bootbank_scsi-mptsas_4.23.01.00-5vmw.500.1.11.623860, VMware_bootbank_scsi-mptspi_4.23.01.00-5vmw.500.1.11.623860, VMware_bootbank_scsi-qla2xxx_911.k1.1-20.1vmw.500.0.0.472560, VMware_bootbank_scsi-qla4xxx_5.01.03.2-3vmw.500.1.11.623860, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.500.1.11.623860
VIBs Skipped:
VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.500.1.11.623860, VMware_bootbank_misc-drivers_5.0.0-1.11.623860, VMware_bootbank_net-e1000e_1.1.2-3vmw.500.1.11.623860, VMware_bootbank_sata-ahci_3.0-6vmw.500.1.11.623860, VMware_bootbank_sata-ata-piix_2.12-4vmw.500.1.11.623860, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid-sas_5.34-1vmw.500.1.11.623860, VMware_bootbank_scsi-rste_2.0.2.0088-1vmw.500.1.11.623860, VMware_locker_tools-light_5.0.0-1.12.653509
----
So I am not sure this is a valid solution/workaround or if this should be brought up with engineering.
I have logged an SR about this - I will let you know when I get back more information about this.
Best regards,
Glenn Gahnstedt

View solution in original post

0 Kudos
18 Replies
JTCopy9
Contributor
Contributor

bump

0 Kudos
JTCopy9
Contributor
Contributor

I have more information on the error:

Apparently it is only happening on my Proliant DL380 G7 boxes. I have a 3-node cluster made up of 2 DL380 G7 servers and 1 DL580 G7 server. The patch was applied successfully on the DL580 but both DL380s produce a purple fault screen as mentioned in the original post.

Any help is greatly appreciated.

J.T.

0 Kudos
BaSergey
Contributor
Contributor

I've had similar error when trying to upgrade ESXi 5 to 5u1 (link).

In my case there is broken or incompatible driver and I deside to rollback upgrade.

0 Kudos
Josh26
Virtuoso
Virtuoso

The standard answer would be to download HP's Service Pack CD and apply firmware updates relevant to the RAID card, iLO and particularly the BIOS.

Check for any updates that are more recent than the latest CD bundle too and let us know how that goes.

0 Kudos
JTCopy9
Contributor
Contributor

Downloaded and installed all of the latest firmware updates, device drivers and BIOS update. Ran all with same result.

0 Kudos
glenngahnstedt
Contributor
Contributor

Hi JTCopy9,

I have/had the exact same issue and my PSOD is identical to yours apart from unrelevant entries.

I have found that if you run the command i.e "esxcli software vib update -d /vmfs/volumes/datastore1/Updates/ESXi500-201205001.zip"

Instead of:

esxcli software vib install -d /vmfs/volumes/datastore1/Updates/ESXi500-201205001.zip"

The update is sucessful and after the reboot the host will come up as it should.

However,

When running the UPDATE command -- ONLY the ESX-BASE package (on a clean installation) will be updated.

When you run the install command there is a lot more going on:

Installation Result:

   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
VIBs Installed:
VMware_bootbank_ata-pata-amd_0.3.10-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-atiixp_0.4.6-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-via_0.3.3-2vmw.500.0.0.469512, VMware_bootbank_block-cciss_3.6.14-10vmw.500.0.0.469512, VMware_bootbank_esx-base_5.0.0-1.13.702118, VMware_bootbank_esx-tboot_5.0.0-0.0.469512, VMware_bootbank_ima-qla4xxx_2.01.07-1vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.500.0.0.469512, VMware_bootbank_misc-cnic-register_1.1-1vmw.500.0.0.469512, VMware_bootbank_net-be2net_4.0.88.0-1vmw.500.0.7.515841, VMware_bootbank_net-bnx2_2.0.15g.v50.11-5vmw.500.0.0.469512, VMware_bootbank_net-bnx2x_1.61.15.v50.1-1vmw.500.0.0.469512, VMware_bootbank_net-cnic_1.10.2j.v50.7-2vmw.500.0.0.469512, VMware_bootbank_net-e1000_8.0.3.1-2vmw.500.0.7.515841, VMware_bootbank_net-enic_1.4.2.15a-1vmw.500.0.0.469512, VMware_bootbank_net-forcedeth_0.61-2vmw.500.0.0.469512, VMware_bootbank_net-igb_2.1.11.1-3vmw.500.0.0.469512, VMware_bootbank_net-ixgbe_2.0.84.8.2-10vmw.500.0.0.469512, VMware_bootbank_net-nx-nic_4.0.557-3vmw.500.1.11.623860, VMware_bootbank_net-r8168_8.013.00-3vmw.500.0.0.469512, VMware_bootbank_net-r8169_6.011.00-2vmw.500.0.0.469512, VMware_bootbank_net-s2io_2.1.4.13427-3vmw.500.0.0.469512, VMware_bootbank_net-sky2_1.20-2vmw.500.0.0.469512, VMware_bootbank_net-tg3_3.110h.v50.4-4vmw.500.0.0.469512, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-nv_3.5-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-promise_2.12-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-sil_2.3-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-svw_2.3-3vmw.500.0.0.469512, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.500.0.0.469512, VMware_bootbank_scsi-aic79xx_3.1-5vmw.500.0.0.469512, VMware_bootbank_scsi-bnx2i_1.9.1d.v50.1-3vmw.500.0.0.469512, VMware_bootbank_scsi-fnic_1.5.0.3-1vmw.500.0.0.469512, VMware_bootbank_scsi-hpsa_5.0.0-17vmw.500.0.0.469512, VMware_bootbank_scsi-ips_7.12.05-4vmw.500.0.0.469512, VMware_bootbank_scsi-lpfc820_8.2.2.1-18vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.500.0.0.469512, VMware_bootbank_scsi-mpt2sas_06.00.00.00-6vmw.500.1.11.623860, VMware_bootbank_scsi-mptsas_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-mptspi_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-qla2xxx_901.k1.1-14vmw.500.0.0.469512, VMware_bootbank_scsi-qla4xxx_5.01.03.2-3vmw.500.0.0.469512, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.500.0.0.469512
VIBs Removed:
Broadcom_bootbank_misc-cnic-register_1.70.0.v50.9-1OEM.500.0.0.472560, Broadcom_bootbank_net-bnx2_2.1.12b.v50.3-1OEM.500.0.0.472560, Broadcom_bootbank_net-bnx2x_1.70.34.v50.1-1OEM.500.0.0.472560, Broadcom_bootbank_net-cnic_1.11.18.v50.1-1OEM.500.0.0.472560, Broadcom_bootbank_net-tg3_3.120h.v50.2-1OEM.500.0.0.472560, Broadcom_bootbank_scsi-bnx2i_2.70.1k.v50.2-1OEM.500.0.0.472560, Emulex_bootbank_net-be2net_4.0.355.1-1OEM.500.0.0.406165, Emulex_bootbank_scsi-lpfc820_8.2.2.105.36-1OEM.500.0.0.406165, Hewlett-Packard_bootbank_scsi-hpsa_5.0.0-24OEM.500.0.0.406165, LSI_bootbank_scsi-mpt2sas_10.10.10.00.1vmw-1OEM.500.0.0.472560, VMware_bootbank_ata-pata-amd_0.3.10-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-atiixp_0.4.6-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.500.1.11.623860, VMware_bootbank_ata-pata-via_0.3.3-2vmw.500.1.11.623860, VMware_bootbank_block-cciss_3.6.14-10vmw.500.1.11.623860, VMware_bootbank_esx-base_5.0.0-1.11.623860, VMware_bootbank_esx-tboot_5.0.0-1.11.623860, VMware_bootbank_ima-qla4xxx_2.01.07-1vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.500.1.11.623860, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.500.1.11.623860, VMware_bootbank_net-e1000_8.0.3.1-2vmw.500.1.11.623860, VMware_bootbank_net-enic_1.4.2.15a-1vmw.500.1.11.623860, VMware_bootbank_net-forcedeth_0.61-2vmw.500.1.11.623860, VMware_bootbank_net-igb_2.1.11.1-3vmw.500.1.11.623860, VMware_bootbank_net-ixgbe_2.0.84.8.2-10vmw.500.1.11.623860, VMware_bootbank_net-nx-nic_5.0.601-3vmw.500.0.0.406165, VMware_bootbank_net-r8168_8.013.00-3vmw.500.1.11.623860, VMware_bootbank_net-r8169_6.011.00-2vmw.500.1.11.623860, VMware_bootbank_net-s2io_2.1.4.13427-3vmw.500.1.11.623860, VMware_bootbank_net-sky2_1.20-2vmw.500.1.11.623860, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-nv_3.5-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-promise_2.12-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-sil_2.3-3vmw.500.1.11.623860, VMware_bootbank_sata-sata-svw_2.3-3vmw.500.1.11.623860, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.500.1.11.623860, VMware_bootbank_scsi-aic79xx_3.1-5vmw.500.1.11.623860, VMware_bootbank_scsi-fnic_1.5.0.3-1vmw.500.1.11.623860, VMware_bootbank_scsi-ips_7.12.05-4vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.500.1.11.623860, VMware_bootbank_scsi-mptsas_4.23.01.00-5vmw.500.1.11.623860, VMware_bootbank_scsi-mptspi_4.23.01.00-5vmw.500.1.11.623860, VMware_bootbank_scsi-qla2xxx_911.k1.1-20.1vmw.500.0.0.472560, VMware_bootbank_scsi-qla4xxx_5.01.03.2-3vmw.500.1.11.623860, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.500.1.11.623860
VIBs Skipped:
VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.500.1.11.623860, VMware_bootbank_misc-drivers_5.0.0-1.11.623860, VMware_bootbank_net-e1000e_1.1.2-3vmw.500.1.11.623860, VMware_bootbank_sata-ahci_3.0-6vmw.500.1.11.623860, VMware_bootbank_sata-ata-piix_2.12-4vmw.500.1.11.623860, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid-sas_5.34-1vmw.500.1.11.623860, VMware_bootbank_scsi-rste_2.0.2.0088-1vmw.500.1.11.623860, VMware_locker_tools-light_5.0.0-1.12.653509
----
So I am not sure this is a valid solution/workaround or if this should be brought up with engineering.
I have logged an SR about this - I will let you know when I get back more information about this.
Best regards,
Glenn Gahnstedt

View solution in original post

0 Kudos
JTCopy9
Contributor
Contributor

Thanks for the post Glenn. I attempted your "update" command and received a message that no changes have been made to the host. I have an open SR with VMWare on this, however, it is taking a while for them to get back to me.

Thanks Again.

J.T.

0 Kudos
hackenhans
Contributor
Contributor

Hi J.T.

We've got same error not with HP-Proliant but with a nearly new (03.2012) Dell PE-T610. Dell-customized build 623860 works fine but any update to a newer version causes these error.

Thanks for any solution.

Ferdi Giese

0 Kudos
Josh26
Virtuoso
Virtuoso

I have a suspicion that updating your Dell/HP plugins before updating VMware may be relevant to this.

0 Kudos
hackenhans
Contributor
Contributor

Glenn Gahnstedt's solution did it in my case. Thanks for that.

But I'm afraid, the update instead of the install command will leave old stuff in the hypervisor installation envirenment. Can anyone tell me about?

Thanks in advance

Ferdi Giese

0 Kudos
bgortemaker
Contributor
Contributor

Hi,

Were you able to get this resolved with VMware support?

I am experiencing exactly the same.

HP DL380 G7 (latest firmware updates) with HP-flavoured ESXi 5.0U1 cannot be updated with ESXi500-201204001. Results in PSOD as in your first post.

0 Kudos
JTCopy9
Contributor
Contributor

Not yet. Tech Support had to do a Webex session and record all of the screens one by one because the PSOD occurred before the disk drivers and therefore we could not get a core dump. They sent the recording to engineering. I will update this thread if any status changes and please feel free to do the same if you should make any progress.

0 Kudos
Josh26
Virtuoso
Virtuoso

I recently found on my G8, I would lose NIC and storage unless I applied the HP Smartarray and NIC driver update - AFTER the relevant patch, but BEFORE reboot.

This is despite the fact those drivers were already installed - this update seems to remove them.

0 Kudos
JTCopy9
Contributor
Contributor

I did try this during one of my attempts at installing a patch. I beleive I did both the NIC drivers and the FC drivers. I cant remember if I did any storage drivers though.

This is worth another try though. I will post the results as soon as i can.

Thanks Josh26.

0 Kudos
JTCopy9
Contributor
Contributor

No Joy Josh26...

Same error. But you have got me thinking about reloading ALL of the HP drivers before the restart. Perhaps I will get a chacne to try it out next week. As always, I willkeep this thread updated.

J.T.

0 Kudos
JTCopy9
Contributor
Contributor

Got It!!!

So we used the "update" command instead of the "install" command and installed all the updates one after another. That seemed to resolve the issue. Also, the tech support gent showed me how to configure and use "update manager" and he said that this and other issues seem to be resolved when using update manager.

Here are the commands I was using and what I am now using:

Old Command:

esxcli --server VMWareSrvr01 --username **** --password ***** software vib install -d /vmfs/volumes/datastore1/ESXi500-201204001.zip

New Command:

esxcli --server VMWareSrvr01 --username **** --password ***** software vib update -d /vmfs/volumes/datastore1/ESXi500-201204001.zip

esxcli --server VMWareSrvr01 --username **** --password ***** software vib update -d /vmfs/volumes/datastore1/ESXi500-201205001.zip

esxcli --server VMWareSrvr01 --username **** --password ***** software vib update -d /vmfs/volumes/datastore1/ESXi500-201206001.zip

Then restart.

After we resolved this, we set up Update Manager and applied the latest patch 201207001.zip along with some other misc patches and it was much much simpler.

0 Kudos
bgortemaker
Contributor
Contributor

Thanks for reporting back J.T., and glad to see that there is a way out. But...

My update scripts are using the PowerCLI Install-VMHostPatch cmd-let, and unfortunately there does not seem to be an equivalent command or switch to perform vib update using PowerCLI. I will need to fall back to making esxcli calls for this piece of the script... Yuk.

In our environment we have to work with unmanaged ESXi hosts, so Update Manager is no option here.

I hope VMware will come with a better fix for this than forcing everyone to move to Update Manager.

0 Kudos
cfresqui
Enthusiast
Enthusiast

I'd the same issue with IBM HS22 Bladecenter.. and just changing the install to update parameter solved the problem.

Tks!!!

Cesar Fresqui VCAP-DCA Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema. Thank you/Obrigado
0 Kudos