Dave_McD
Contributor
Contributor

Any vim-cmd command gets failed to login: Connection refused

I am having a problem with my ESXi 5 host being disconnected from the VC due to a problem with SRM. I know how to fix it but when I Putty on to the host and log in via SSH every vim-cmd I try gets Failed to login: Connection refused.

I never enable Lockdown mode, so that is not the problem and I have restarted the management network from the IMM, I have restarted it from SSH and restarted vpxa and hostd individually and nothing works.

Restarting the host is not an option sue to the mission critical VM's currently residing on the host.

I have 2 options from here:

1.     Fix the Connection refused problem so I can fix the SRM problem and reconnect the host to the VC.

2.    Find a way to migrate the VMs (which are showing invalid) to another host without powering them off so I can reboot the host.

Option 1 is preferred as even after the reboot in OPtion 2 the SRM problem will not be fixed and I will still have to use SSH.

Can anyone help me please? I have logged a job with VMware but the response has been less than rapid.

0 Kudos
2 Replies
Dave_McD
Contributor
Contributor

I found the fix. Spent all day looking yesterday then today found that the vpxa service was not running. Started vpxa and was able to reconnect the host.

0 Kudos
ptitchoux
Contributor
Contributor

Had the same error message and I tried the vpxa & hostd but it did not work.

I tried the services.sh restart command and it worked perfectly ! Based my self on the following VMware link VMware KB: Restarting the Management agents on an ESXi or ESX host

0 Kudos