loligator
Contributor
Contributor

Allowing access to ESXi host from other subnets

Jump to solution

Hello all,

I'm running the free edition of ESXi and it's running on the 10.32.125.x network. I've noticed that if I try connecting to the host via the vSphere Client from a different network, such as 10.32.126.x, I cannot. I cannot ping or SSH into the host either form the 10.32.126.x network. All is well if I'm on the 10.32.125.x network, which is the same network the server is running on (10.32.125.63 is the hosts IP). I can access services on the VMs fine from other networks, just not the ESXi host itself.

Any ideas to how I can allow access from networks other than the one ESXi lives on?

Thanks

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
IanTech
Enthusiast
Enthusiast

Hi,

Are you trying to access the ESXi host with your vSphere client, make sure that your DNS and Default gateway are set and correct? Is your default gateway on the ESXi host set to your router?

View solution in original post

0 Kudos
5 Replies
IanTech
Enthusiast
Enthusiast

Hi,

You need to enable ssh on the ESXi host first.

Do you have a route in place to the ESXi subnet and the default gateway of the ESXi host?

Hope this helps.

0 Kudos
AndreTheGiant
Immortal
Immortal

If you have different network you must use an external router.

It must be the default gw of your ESXi.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
loligator
Contributor
Contributor

Hi Ian

I'm not sure I understand your question 100%. On my routers, yes, I have a route in place to get from the 10.32.126 network to the 10.32.125. Computers with an IP address of 10.32.126.x can successfully access other servers on the 10.32.125 network, they just can't access the ESXi server (but can access services on VMs running on this server).

Thanks for the response.

0 Kudos
IanTech
Enthusiast
Enthusiast

Hi,

Are you trying to access the ESXi host with your vSphere client, make sure that your DNS and Default gateway are set and correct? Is your default gateway on the ESXi host set to your router?

0 Kudos
loligator
Contributor
Contributor

Hey Ian,

The issue is resolved. It was simply because the gateway wasn't configured. Duh! Not sure how I overlooked that but I did. Thanks for the help.

0 Kudos