pmsb
Enthusiast
Enthusiast

After upgrade from 5.5.0 to 6.0.0 iSCSI target missing

Hello,

after upgrading ESXi and vCenter from 5.5.0 to 6.0.0 two of my iScsi luns are gone.

In vmkernel.log there are some entries:

2015-07-27T12:33:29.839Z cpu50:33031)NMP: nmp_ThrottleLogForDevice:3178: Cmd 0x85 (0x43aa06fc1f00, 34743) to dev "naa.xx" on path "vmhba2:C0:T0:L1" Failed: H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x20 0x0. Act:NONE

2015-07-27T12:33:29.851Z cpu38:33963)<4>hpsa 0000:03:00.0: Device:C0:B0:T0:L1 Command:0x85 CC:05/20/00 Illegal Request.

2015-07-27T12:33:29.862Z cpu50:33031)ScsiDeviceIO: 2646: Cmd(0x43aa06fc1f00) 0x4d, CmdSN 0x6 from world 34743 to dev "naa.xx" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x20 0x0.

2015-07-27T12:33:29.862Z cpu50:33031)NMP: nmp_ThrottleLogForDevice:3178: Cmd 0x1a (0x43aa06fc1f00, 34743) to dev "naa.xx" on path "vmhba2:C0:T0:L1" Failed: H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0. Act:NONE

2015-07-27T12:33:29.862Z cpu50:33031)ScsiDeviceIO: 2646: Cmd(0x43aa06fc1f00) 0x1a, CmdSN 0x7 from world 34743 to dev "naa.xx" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.

2015-07-27T12:34:50.346Z cpu15:37036)ScsiScan: 836: Path vmhba33:C0:T1:L0 supports REPORT LUNS 0x11

2015-07-27T12:34:50.347Z cpu15:37036)ScsiScan: 836: Path vmhba33:C0:T2:L0 supports REPORT LUNS 0x11

2015-07-27T12:34:50.347Z cpu15:37036)ScsiScan: 836: Path vmhba33:C1:T0:L0 supports REPORT LUNS 0x11

2015-07-27T12:34:50.349Z cpu36:34747)NMP: nmp_ThrottleLogForDevice:3178: Cmd 0x12 (0x43a608a10400, 0) to dev "naa.xx" on path "vmhba2:C0:T0:L1" Failed: H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0. Act:NONE

2015-07-27T12:34:54.319Z cpu54:34808)FSS: 5327: No FS driver claimed device 'control': No filesystem on the device

2015-07-27T12:34:54.365Z cpu54:34808)VC: 3551: Device rescan time 25 msec (total number of devices 11)

Do anybody know, what the problem is?

Best regards

Tobias

2 Replies
wealvescabral
Enthusiast
Enthusiast

Hi,

It seems that you are strugling with PDL problem.

See if this KB below can help you:

VMware KB: Cannot remount a datastore after an unplanned permanent device loss (PDL)

Wellington Cabral | Mark it as helpful or correct if my suggestion is useful.
Mahiee
Enthusiast
Enthusiast

Can be checked by un-mount and re-mount of the two effected LUNs, In addition to that ultimate solution is to reboot the host and check if reboot not been done after upgrade.

Regards,