vDOG201110141
Contributor
Contributor

Adding Expansion Card with ESXi 4.1

I'm trying to use a parallel port dongle in a VM running under ESX 4.1.  My motherboard doesn't have a parallel port, so I added a Netmos PCI expansion card, but the passthrough option for the VM configuration is greyed out.  It appears that the card is being ignored.  I guess that there are no drivers installed for this card (even assuming that they exist), because the card was not present when I first installed ESXi.  Assuming that ESXi DOES have drivers for this card, would I need to install them manually, or would you expect ESXi to discover the card and install drivers when it boots ?

Tia

dog

0 Kudos
5 Replies
vmroyale
Immortal
Immortal

Hello and welcome to the forums.

Note: This discussion was moved from the Technical Resources community to the VMware ESXi 4 community.

ESXi does not support physical parallel ports, as detailed in kb 1003129.

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
vDOG201110141
Contributor
Contributor

Brian,

Sorry, I must have missed the ESXi 4.1 group.  Seems like I've been wasting my time trying to get this going on Esxi.  I suppose the port passthrough option that is always greyed our is only available with earlier versions of ESX ?  Thanks for your help; this has saved me a lot more wasted effort. If you'd like a nice new paralel port card, just drop me an email and I'll psot it to you...

Cheers,

vDog

0 Kudos
vmroyale
Immortal
Immortal

Thanks for the offer, but I'm good! :smileylaugh:

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
enricofiumana
Contributor
Contributor

But in this KB says that neither serial nor parallel working in ESXi4.1.

But i have installed ESXi4.1 with a vsphere enterprise plus license and serial now are working.

But parallel are still not working.

You know why?

Thank

    Enrico

0 Kudos
vDOG201110141
Contributor
Contributor

Enrico,

I've been following up on information that I have seen in blogs and forums, but I have not seen any that mentioned success with PARALLEL ports.  Right now, I'm suffering from "blog blindness"; I need to systematically review the material and try to work out which comments apply to esxi 4.1 and which apply to Esxi 4.0 or other VMware products.  If I find anything out, I'll report back.  I wonder if anyone has parallel port passthrough working on 4.1 ?

vDog

0 Kudos