SITAM
Contributor
Contributor

Add a second screen in 1920 * 1080

Hello

I would like to have 2 screens, in my vm hosted in an ESX version 6, with a resolution of 1920 * 1080 for each of the screens.

For the moment, I find myself limited to 1600 * 1200 on the second.

Why?

0 Kudos
9 Replies
parmarr
VMware Employee
VMware Employee

Please check out the pre-requisities whihc might be stopping you:

Verify that the latest version of VMware Tools is installed in the guest operating system.

Verify that the guest operating system in the virtual machine is Windows XP, Windows Vista, Windows 7, or Linux.

If you plan to use DirectX 9 accelerated graphics, prepare the host system. See Prepare the Host System to Use DirectX 9 Accelerated Graphics.

Procedure. For more information, see https://pubs.vmware.com/workstation-9/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-FF434E5C-2FE...

Sincerely, Rahul Parmar VMware Support Moderator
0 Kudos
Clem42
Contributor
Contributor

The vmware tools are up-to-date in version 10.0.9 build-3917699.

The guest operating system in the virtual machine is Windows 7 Professionnel.

Vmware.png

0 Kudos
Clem42
Contributor
Contributor

Hello,

​Have you tried putting 2 screens 1920 * 1080 in a vm? Does it work for you?

​Sincerely,

0 Kudos
Finikiez
Champion
Champion

Just try increase amount of video ram for a VM manually in VM's settings to the maximum available number.

0 Kudos
Clem42
Contributor
Contributor

The video memory is already at maximum, ie 512 MB.

0 Kudos
svo_idt
Contributor
Contributor

Hello SITAM​!

Did you get this solved? I have the exact same problem, that the second screens resolution is capped at 1600x1200. The 1920x1080 is not available and I tried forcing it via registry or something.

0 Kudos
Clem42
Contributor
Contributor

Unfortunately no. The only thing I managed at the moment is to set a 3840 * 1080 screen via the VMwareResolution.exe.
VMwareResolutionSet.exe 0 1 , 0 0 3840 1080
https://kb.vmware.com/s/article/2058577

svo_idt
Contributor
Contributor

Hello Clem42​!

Thank for the feedback. Thats sad. Trying this for a few days now but I cannot find a solution either.

I think we will go away from the dual screen VM settings and rather opt for Windows 7 Ultimate licenses so that RDP has multi monitor support.

0 Kudos
Clem42
Contributor
Contributor

After your message, I did a test with windows 7 ultimate ... no better...but I had an idea and it worked on windows ultimate and professional.
In the advanced settings, you have to disable the option "Hide modes that this monitor ..." 
Masquer les modes.png

Then click on the button "List All Modes" and select 1920 * 1080 and it's OK.

Sans titre.png



0 Kudos