falken76
Contributor
Contributor

Accessing ESXi (free) through https goes to a blue screen and doesn't give login prompts

Hello, I was wondering if anyone has experienced this and if there is a known solution to this?  It's very possible it is caused by my DNS provider (Cloudflare).  My ESXi host doesn't have any special SSL on it, whatever SSL it has it would have to be self signed.  I have everything behind a kemp load balancer that brings everything in through port 443 and then sends traffic to the correct VM based on the name they entered before the .domain.com.  The SSL certificate is stored on the loadbalancer.  I'm not sure if the way SSL is setup is making this happen.

I never have ESXi enabled on the loadbalancer unless I'm leaving the house and testing from a remote location.  But when it is on, I tried accessing it from a friends house.  At first it kind of worked, what happens is it goes to the blue background screen but doesn't bring up the login prompts.  If I refresh the screen constantly, sometimes it will actually load the vmware logo and if I see that, it'll give me the login prompt.  Once it does that, everything appears to function properly except for VMRC, if I try to remote into any of the VMs using VMRC (Provided I can even log into esxi), it fails saying there's an SSL error. (Maybe that's because ESXi has self signed SSL and the loadbalancer has a letsencrypt ssl)

Is this normal behavior? I.E. is it only supposed to work through a VPN?  Or is this possibly a Cloudflare issue?

One last question:  When I try to find a tutorial on how to do pretty much anything in ESXi, most of the tutorials refer to using "vsphere".  I can not really find any info that confirms weather this works on free ESXi or not because I am assuming when they refer to vsphere and esxi, they are referring to the version that enterprise would have paid for.  It seems you can do the same things on the free esxi but it has to be done through CLI instead of a GUI.  (I was able to enable sound on VMs by editing files in CLI on esxi.  The instructions using vsphere showed just clicking a few checkmarks) Based on what vsphere looks like, it seems like it would make a lot of things a lot easier in ESXi, so for this reason I get the impression it only works with the version that costs money.  Am I wrong in this assumption?

Summary:

Does ESXi not work well on regular SSL for security purposes or is this abnormal behavior?

Why does VMRC not give me an SSL issue if I am on the internal network and accessing VMs, but if it's external, it gets an SSL error.

Is Vsphere a GUI that makes most of the configuration easy but it's only available to paid versions or does Vsphere actually work with the free ESXi?

 

Thank you

0 Kudos
2 Replies
e_espinel
Virtuoso
Virtuoso

Hello.
you have to be clear about certain details:
VMware vSphere is the commercial name of the virtualization product.
ESXi is the technical name of the VMware vSphere virtualizer. It is what is installed on the Host. usually one or the other term is used.

In the VMware vSphere also has another product for the management of the ESXi host which is called vCener Server.

The ESXi free uses a free license, the software is the same that is used in a paid ESXi, but the difference is that the free has disabled some features and hardware limitations (you can learn more if you search the internet ESXi free limitations and features).

ESXi has its own self-signed SSL certificate and can also work with paid certificates (you have to configure it).
Problems with SSL on VMware vSphere are usually caused by the browser you are using, I recommend you to use another browser (like Firefox ESR, Waterfox G4) and try.

 

 

 

 

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo, VMware vSphere and Veeam Backup.
VMware VSP-SV, VTSP-SV, VTSP-HCI, VTSP 5
Please mark my comment as Correct Answer or assign Kudos if my answer was helpful to you, Thank you.
Пожалуйста, отметьте мой комментарий как Правильный ответ или поставьте Кудо, если мой ответ был вам полезен, Спасибо.
0 Kudos
falken76
Contributor
Contributor

Oh ok, I see.  I was confused because I didn't understand the naming.  It looks like the component I was interested in is Vcenter and I certainly understand that is not available on the free version.  Thank you, I assumed vsphere was Vcenter.  No wonder all those ESXi tutorials refer to vsphere.

0 Kudos