vmwareluverz
Contributor
Contributor

503 service unavailable on vsphere 4.0 access web to download client

Jump to solution

anyone know why i got this 503 service unavailable when connected to newly installed vsphere 4.0 and ask for certificates and if i click continue to ignore it it just throw that error. please help

0 Kudos
1 Solution

Accepted Solutions
eliot
Enthusiast
Enthusiast

Just had this problem, yes the service wasn't running - but still got exactly the same message even after confirming it was running. (even the full VI client gave the same message on attempting to connect)

It was caused by the fact that my network card on my machine didn't have a default gateway configured - even though the host i was accessing was on the same subnet as my PC. I've seen this before on other devices, which is what made me try it.

View solution in original post

0 Kudos
8 Replies
Troy_Clavell
Immortal
Immortal

not specifically around vSphere4, but maybe this KB will have some useful information.

http://kb.vmware.com/kb/1009291

0 Kudos
vmroyale
Immortal
Immortal

Hello. This is a known issue detailed in the release notes.

  1. Web Access service does not start after finishing ESX installation

When you use Web Access to connect to an ESX host, the following message appears:

503 Service Unavailable

The reason is that after you finish installing ESX, the Web Access service does not start automatically.

Workaround: To start the Web Access service on the ESX host, run the following command: service vmware-webAccess start

Starting the service manually works, but making the changes listed below eliminated the 503 errors (even after reboots) for my setup.

01. Use the vSphere client to connect to the ESX host.

02. Navigate to Configuration -> Software (Security Profile)

03. Click Properties for the Security Profile

04. Scroll down and find vSphere Web Access, put a check in the box and then click the Options button

05. Under the Startup Policy, change the selection to "Start and stop with host" and under the Service Commands, click the Restart button

I also noticed that it takes a while for the Web Access to become available. Sometimes the 503 errors will simply go away, if you give it a few minutes.

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
cdc1
Expert
Expert

For those who prefer using command-line, you can use the following command to make it start and stop automatically with host boot and shutdown:

# chkconfig --level 3 vmware-webAccess on

Message was edited by: cdc

eliot
Enthusiast
Enthusiast

Just had this problem, yes the service wasn't running - but still got exactly the same message even after confirming it was running. (even the full VI client gave the same message on attempting to connect)

It was caused by the fact that my network card on my machine didn't have a default gateway configured - even though the host i was accessing was on the same subnet as my PC. I've seen this before on other devices, which is what made me try it.

View solution in original post

0 Kudos
vmwareluverz
Contributor
Contributor

thanks for the replied good to know people have different solutions. good day.

0 Kudos
acspeed
Contributor
Contributor

I had the same error, after installing update manager and converter...the error went away.

0 Kudos
beovax
Enthusiast
Enthusiast

I had this problem. webAccess services is not required for the VI client. I was accessing the server using the VI cleint and by IP address. Default gateway was set and I could ping the server. Turns out I had the dns server address set wrong, this was enough to bring up that error, even when accessing via IP

Check your DNS configuration

0 Kudos
172pilotsteve
Contributor
Contributor

WOW..  Thank you so much for the hint...

I've had an ESX 4.0 machine running for quite a while, but "all of a sudden"  (I think I edited some advanced options???) it stopped responding?!  All I could do is SSH to it and ping it, but I couldn't connect to it via the vSphere client.

Reading your post about the wrong DNS, I would have bet a paycheck against, but when I checked, I had two wrong DNS servers listed in /etc/resolv.conf.

Resetting the resolv.conf file fixed it right up for me..

Thanks!

0 Kudos