UnixCommando1
Contributor
Contributor

ESXI ARM Fling vSphere HA agent for this host has an error:

Hello,

     I have ESXI ARM on a pair of Raspberry Pis, I'm getting an error vSphere HA agent for this host has an error: The vSphere HA agent is not reachable from vCenter Server.  I can't find anything wrong with the network so there must be another issue.  I've looked at the standard KBs and they're not helping.  Any suggestions?  I've tried disabling HA and re-enabling it, I've removed the hosts from the cluster and re-added them.  What else can I try?

Thanks

-Bob

Labels (1)
0 Kudos
3 Replies
cyprienlaplace
VMware Employee
VMware Employee

One of the reason I've encountered is that IPv6 is enabled on my network, and fdm wasn't handling that correctly. I had to disable IPv6 on the ESXi network interface. Try also to look into /var/log/fdm.log for more information.

0 Kudos
UnixCommando1
Contributor
Contributor

I've discovered part of my problem, there was no fdm agent on my pi esx's.  I've corrected that, but still can't connect.  In the fdm VIB is says it can use vCenter 7.0c or 7.0d, I've deployed 7.0.1.  Now the question is do I need to rollback to 7.0d to make this work?

-Bob

0 Kudos
lamw
Community Manager
Community Manager

As the documentation states, vSphere HA with ESXi-Arm is only supported with vCenter Server 7.0 and you will need to redeploy your vCenter to match one of those versions mentioned.

7.0.1 is vCenter Server 7.0 Update 1 is NOT supported

0 Kudos