Highlighted
Enthusiast
Enthusiast

"Reset Applikation to default" did not work for me

Jump to solution

Hello, I have a UEM environment 9.3 and use Horizon Ver 7.3.2 with Instant Clone and Mandatory Profiles. When a user logs on for the first time, profile data is stored properly. But if I reset an application (in my example the settings for the "Ineternet Explorer" to default) will be stored in future applications of the user no more profile data. Even if I want to import the backup from a certain point in time, they will be reset and will not be recreated in the future.

The message "Config file is marked as mandatory - skipping export" appears in the log. How and where can I pick up this mark?

Thanks for support

Andreas

1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

Hi burgerking68,

The Config file is marked as mandatory -- skipping export message appears if predefined settings of type Fully Enforced are configured for that Flex config file:

pastedImage_5.png

Could that be the reason in your case?

If not, could you post the Flex config file here so we can take a look?

View solution in original post

12 Replies
Highlighted
VMware Employee
VMware Employee

Hi burgerking68,

The Config file is marked as mandatory -- skipping export message appears if predefined settings of type Fully Enforced are configured for that Flex config file:

pastedImage_5.png

Could that be the reason in your case?

If not, could you post the Flex config file here so we can take a look?

View solution in original post

Highlighted
Enthusiast
Enthusiast

Hi,

UEMdev, thanks, thats it!Smiley Happy

0 Kudos
Highlighted
VMware Employee
VMware Employee

Great, glad to hear that!

For UEM 9.4, I've changed the log message to Config file has fully enforced predefined settings -- skipping export, which is hopefully a bit clearer. (Fully Enforced settings used to be called Mandatory settings, but the log message had not been changed to reflect that.)

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hello,

I also think that this is a clearer statement in the log. thanks again

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi There, I had the same Question with UEM 9.1 on Windows 7.

We want to deploy links:

pastedImage_0.png

pastedImage_1.png

... and we have many users who dont get the links, could this be the problem:

2018-02-01 16:27:39.573 [INFO ] Exporting profile using config file 'Bitfactory Alex Dienstplan CDK Links.INI' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links.INI)

2018-02-01 16:27:39.573 [DEBUG] Processing predefined settings definition ('Bitfactory Alex Dienstplan CDK Links')

2018-02-01 16:27:39.573 [INFO ] Config file is marked as mandatory -- skipping export.

Thanks from Austria.

Dominik

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi system32AUT,

This is a bit different than the problem from the beginning of this thread, but let's see what we can figure out.

Are there any conditions configured, either on the Bitfactory Alex Dienstplan CDK Links.INI Flex config file itself, or on the Bitfactory Alex Dienstplan CDK Links predefined settings? Can you share a FlexEngine log file (at log level DEBUG) of the full session for a user who is not receiving the shortcuts?

Highlighted
Enthusiast
Enthusiast

Hi UEMdev (quick answer, thanks)

Well... the *.ini :

[Metadata]

PredefinedSettings=<predefined><setting t="m" n="Bitfactory Alex Dienstplan CDK Links" l="Bitfactory Alex Dienstplan CDK Links" i="1" /></predefined>

ProcessCriteria=<pc ll="1" t="3" f="0"><member g="LKSDOM21\RZ-Dienste-Alex-CDK" c="u" s="S-1-5-21-removed for Data protection" /></pc>

[Information]

Title = Bitfactory Alex Dienstplan CDK Links

Description = Bitfactory Alex Dienstplan CDK Links

[Immidio Flex]

This file was created using VMware UEM Management Console version 9.1.0.175.

Use only with VMware UEM.

And yes we have Conditions but one Step before there:

pastedImage_2.png

and not in the predifined settings:

pastedImage_1.png

The full DEBUG LOG with relevant Informations about this setting for a user without links (not working) (IMPORT):

sorry, no DEBUG yet because User is on vaccation:

2018-02-01 07:15:15.207 [INFO ] Starting FlexEngine v9.1.0.175 [IFP#0fc580e1-T5>>]

2018-02-01 07:15:15.207 [INFO ] Running as Group Policy client-side extension

2018-02-01 07:15:15.957 [INFO ] Skipping UEM environment variable due to conditions ('LP_CMD_x64.xml')

2018-02-01 07:15:15.962 [INFO ] Successfully set environment variable 'LP_CMD' ('LP_CMD_x86.xml')

2018-02-01 07:15:15.965 [INFO ] Successfully set environment variable 'orbisent' ('Orbis-Version-ENT.xml')

2018-02-01 07:15:15.969 [INFO ] Successfully set environment variable 'orbiskhv' ('Orbis-Version-KHV.xml')

2018-02-01 07:15:15.972 [INFO ] Successfully set environment variable 'orbisscl' ('Orbis-Version-SCL.xml')

2018-02-01 07:15:15.975 [INFO ] Successfully set environment variable 'orbissource' ('Orbis-Version-Source.xml')

2018-02-01 07:15:15.978 [INFO ] Successfully set environment variable 'orbissst' ('Orbis-Version-SST.xml')

2018-02-01 07:15:15.981 [INFO ] Successfully set environment variable 'orbistsgop' ('Orbis-Version-TSGOP.xml')

2018-02-01 07:15:15.985 [INFO ] Successfully set environment variable 'orbistsgot' ('Orbis-Version-TSGOT.xml')

2018-02-01 07:15:15.988 [INFO ] Successfully set environment variable 'orbistst' ('Orbis-Version-TST.xml')

2018-02-01 07:15:15.991 [INFO ] Successfully set environment variable 'SAPLOGON_INI_FILE' ('SAP-Logon-Ini.xml')

2018-02-01 07:15:16.002 [INFO ] Skipping UEM drive mapping due to conditions ('Lauris.xml')

2018-02-01 07:15:16.017 [INFO ] Skipping UEM drive mapping due to conditions ('Orbis-Laufwerk-u1ru150.xml')

2018-02-01 07:15:16.031 [INFO ] Skipping UEM drive mapping due to conditions ('Swisslab.xml')

2018-02-01 07:15:16.073 [INFO ] No ADMX-based settings applied

.....................

2018-02-01 07:15:16.540 [INFO ] Importing fully enforced settings 'Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip)

2018-02-01 07:15:16.799 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SJS Links.INI' due to conditions.

2018-02-01 07:15:16.803 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan STV Links.INI' due to conditions.

2018-02-01 07:15:16.807 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SWB Links.INI' due to conditions.

2018-02-01 07:15:16.813 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Dienstplan HAL Links.INI' due to conditions.

The full DEBUG LOG with relevant Informations about this setting for a user without links (not working) (EXPORT)

2018-02-01 16:27:39.448 [DEBUG] Found 'FlexDebug.txt' - changed log level to DEBUG

2018-02-01 16:27:39.448 [INFO ] Starting FlexEngine v9.1.0.175 [IFP#128a9e38-71aa4a0>>]

2018-02-01 16:27:39.448 [DEBUG] Performing path-based export

2018-02-01 16:27:39.449 [DEBUG]    User: LKSDOM21\removed for Data protection, Computer: removed for Data protection, OS: x64-win7 (BuildNumber 7601, ServicePack 1, SuiteMask 100, ProductType 1/30, Lang 0407, IE 11.0.9600.18893, UEM 9.1.0.175, ProcInfo 1/1/4/4, UTC+01:00S), PTS: 7648/6324/1C

2018-02-01 16:27:39.449 [DEBUG]    Policy "Always wait for the network at computer startup and logon" is enabled

2018-02-01 16:27:39.449 [DEBUG]    Policy "Run logon scripts synchronously" is enabled for the computer

2018-02-01 16:27:39.449 [DEBUG]    Group Policy-related policies: Refresh interval = 330/33

2018-02-01 16:27:39.461 [DEBUG]    Redirected folders: Desktop, Favorites, Personal

2018-02-01 16:27:39.461 [DEBUG]    Policy "Maximum wait time for Group Policy scripts" is configured to 240 seconds

2018-02-01 16:27:39.461 [DEBUG]    Policy "Point and Print Restrictions" is configured for the computer (1/2)

2018-02-01 16:27:39.462 [DEBUG]    User policy last applied at 2018-02-01 14:26:52.668 (took 2.668 s)

2018-02-01 16:27:39.463 [DEBUG]    Boot time: 2018-01-29 12:56:34.633, Logon time: 2018-01-30 10:42:29.321

2018-02-01 16:27:39.466 [DEBUG]    Processing config files from path '\\UEMConfig-server\UEMConfig$'

2018-02-01 16:27:39.466 [DEBUG]    Using profile archive path 'M:\\Profil\Flex'

2018-02-01 16:27:39.466 [DEBUG]    Profile archives will be compressed

2018-02-01 16:27:39.466 [DEBUG]    Creating 2 backups (single backup per day) in path 'M:\\Profil\Flex\backups'

2018-02-01 16:27:39.466 [DEBUG]    Logging to event log for path-based import/export, asynchronous UEM, UEM refresh, DirectFlex refresh

2018-02-01 16:27:39.466 [DEBUG]    Logging to file 'M:\\Profil\Flex\UEMengine.log'

2018-02-01 16:27:39.466 [DEBUG]    Log file will be overwritten when larger than 8192 kilobytes

2018-02-01 16:27:39.466 [DEBUG]    If Flex config files path is not available at logon, log off automatically

2018-02-01 16:27:39.475 [DEBUG]    If profile archive path is not available at logon, skip import but apply user environment settings

2018-02-01 16:27:39.475 [DEBUG]    Showing progress information

2018-02-01 16:27:39.498 [DEBUG] Import status flag indicates success, so performing export

2018-02-01 16:27:39.499 [DEBUG] Clearing import status flag for next import

2018-02-01 16:27:39.515 [DEBUG] Stopped DirectFlex injection

2018-02-01 16:27:39.515 [DEBUG] Processing pre-export UEM tasks

..............................................

2018-02-01 16:27:39.573 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-CDK' = true

2018-02-01 16:27:39.573 [INFO ] Exporting profile using config file 'Bitfactory Alex Dienstplan CDK Links.INI' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links.INI)

2018-02-01 16:27:39.573 [DEBUG] Processing predefined settings definition ('Bitfactory Alex Dienstplan CDK Links')

2018-02-01 16:27:39.573 [INFO ] Config file is marked as mandatory -- skipping export.

2018-02-01 16:27:39.576 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-SJS' = false

2018-02-01 16:27:39.579 [INFO ] Skipping export for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SJS Links.INI' due to conditions.

2018-02-01 16:27:39.582 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-STV' = false

2018-02-01 16:27:39.582 [INFO ] Skipping export for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan STV Links.INI' due to conditions.

2018-02-01 16:27:39.585 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-SWB' = false

2018-02-01 16:27:39.585 [INFO ] Skipping export for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SWB Links.INI' due to conditions.

2018-02-01 16:27:39.588 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-HAL' = false

2018-02-01 16:27:39.588 [INFO ] Skipping export for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Dienstplan HAL Links.INI' due to conditions.

And for a User who is working: Import:

2018-02-02 10:55:29.043 [DEBUG] Processing predefined settings definition ('Bitfactory Alex Dienstplan CDK Links')

2018-02-02 10:55:29.045 [INFO ] Importing fully enforced settings 'Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip)

2018-02-02 10:55:29.073 [DEBUG] ImportRegistry::Import: Calling '"C:\Windows\REGEDIT.EXE" /S "C:\Users\removed for Data protection\AppData\Local\Temp\FLXD3E0.tmp"' (RPAL: l=0 (D/E), r=0)

2018-02-02 10:55:29.267 [DEBUG] Read 4 entries from profile archive (size: 5002; compressed: 2374)

And for a User who is workin: Export:

2018-02-02 10:57:00.989 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-CDK' = true

2018-02-02 10:57:00.989 [INFO ] Exporting profile using config file 'Bitfactory Alex Dienstplan CDK Links.INI' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links.INI)

2018-02-02 10:57:00.994 [DEBUG] Processing predefined settings definition ('Bitfactory Alex Dienstplan CDK Links')

2018-02-02 10:57:00.994 [INFO ] Config file is marked as mandatory -- skipping export.

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi Dominik,

Thank you for the extensive information.

OK, so only users in the LKSDOM21\RZ-Dienste-Alex-CDK group will get those settings, but from the log it's clear that that is not the issue here.

I'm afraid I have no clue at the moment... Does this always affect the same users, and – if so – does it never work for those users?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi UEMdev, well... as far as I know at the moment we have a 50/50 change that a user gets the link and the other not. We have arround 5000 users...

C:\Users\USER123\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Abteilungsübergreifende-Programme\

nothing here...

pastedImage_0.png

UEM LOG says ok, no failures. Smiley Happy

but we need this links here:

pastedImage_2.png

I tried a new user, give them right now the correct AD global security group lksdom21\RZ-Dienste-Alex-CDK and turn on the debug level and it WORKED Smiley Happy

2018-02-02 15:24:24.414 [DEBUG] Found 'FlexDebug.txt' - changed log level to DEBUG

2018-02-02 15:24:24.414 [INFO ] Starting FlexEngine v9.1.0.175 [IFP#0097a66e-T5>>]

2018-02-02 15:24:24.414 [INFO ] Running as Group Policy client-side extension

2018-02-02 15:24:24.414 [DEBUG] Performing path-based import

2018-02-02 15:24:24.414 [DEBUG]    User: LKSDOM21\data protection, Computer: C1IT006, OS: x64-win7 (BuildNumber 7601, ServicePack 1, SuiteMask 100, ProductType 1/30, Lang 0407, IE 11.0.9600.18860, UEM 9.1.0.175, ProcInfo 1/1/4/4, UTC+01:00S), PTS: 1120/7112/3CT

2018-02-02 15:24:24.414 [DEBUG]    Profile state: local (0x00000000)

2018-02-02 15:24:24.414 [DEBUG]    Processing config files from path '\\UEMConfig-server\UEMConfig$'

2018-02-02 15:24:24.414 [DEBUG]    Using profile archive path 'M:\\Profil\Flex'

2018-02-02 15:24:24.414 [DEBUG]    Last modified dates will be restored

2018-02-02 15:24:24.414 [DEBUG]    Logging to file 'M:\\Profil\Flex\UEMengine.log'

2018-02-02 15:24:24.414 [DEBUG]    Log file will be overwritten when larger than 8192 kilobytes

2018-02-02 15:24:24.414 [DEBUG]    DirectFlex notifications are displayed at application launch and exit

2018-02-02 15:24:24.414 [DEBUG] Setting import status flag

2018-02-02 15:24:24.414 [DEBUG] Deleted application blocking configuration

2018-02-02 15:24:24.414 [DEBUG] Processing pre-import UEM tasks

............

2018-02-02 15:24:25.241 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links.INI'.

2018-02-02 15:24:25.241 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-CDK' = true

2018-02-02 15:24:25.241 [DEBUG] Processing predefined settings definition ('Bitfactory Alex Dienstplan CDK Links')

2018-02-02 15:24:25.257 [INFO ] Importing fully enforced settings 'Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip' (\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip)

2018-02-02 15:24:25.257 [DEBUG] ImportRegistry::Import: Calling '"C:\Windows\REGEDIT.EXE" /S "C:\Users\data protection\AppData\Local\Temp\FLX7922.tmp"' (RPAL: l=0 (D/E), r=0)

2018-02-02 15:24:25.397 [DEBUG] Read 4 entries from profile archive (size: 5002; compressed: 2374)

2018-02-02 15:24:25.413 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SJS Links.INI'.

2018-02-02 15:24:25.413 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-SJS' = false

2018-02-02 15:24:25.413 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SJS Links.INI' due to conditions.

2018-02-02 15:24:25.413 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan STV Links.INI'.

2018-02-02 15:24:25.413 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-STV' = false

2018-02-02 15:24:25.413 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan STV Links.INI' due to conditions.

2018-02-02 15:24:25.413 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SWB Links.INI'.

2018-02-02 15:24:25.413 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-SWB' = false

2018-02-02 15:24:25.413 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan SWB Links.INI' due to conditions.

2018-02-02 15:24:25.413 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Bitfactory Dienstplan HAL Links.INI'.

2018-02-02 15:24:25.413 [DEBUG] Conditions: Check for user membership of group 'LKSDOM21\RZ-Dienste-Alex-HAL' = false

2018-02-02 15:24:25.413 [INFO ] Skipping import for config file '\\UEMConfig-server\UEMConfig$\Bitfactory Dienstplan HAL Links.INI' due to conditions.

2018-02-02 15:24:25.428 [DEBUG] Found flag file for '\\UEMConfig-server\UEMConfig$\Catbase Link.INI'.

Other Users dont get the links.... Maybe a Problem with existing Users and the "fully enforced" flag ?

Kind regards,

Dominik

0 Kudos
Highlighted
VMware Employee
VMware Employee

as far as I know at the moment we have a 50/50 change that a user gets the link and the other not. We have arround 5000 users...

But does a user who doesn't get the link never get it, and does a user who does get the link always get it? Note that I would not know what to do with the answer to that question – just curious...

Other Users dont get the links.... Maybe a Problem with existing Users and the "fully enforced" flag ?

Fully enforced basically means that we apply this always, without checking for anything (apart from the conditions, of course). Which is what makes this so weird.

Apart from the Desktop, Favorites, and Personal folders, do you have any other folders redirected?

For a user who does not get the links, could you run the following command inside that user's session?

     "C:\Program Files\Immidio\Flex Profiles\FlexEngine.exe" -r "\\UEMConfig-server\UEMConfig$\Bitfactory Alex Dienstplan CDK Links-UEM-PD-#1.zip"

After running that, do the links show up? If they don't, can you run the same command again, but now with ProcMon.exe running, to see exactly what happened to those files from the predefined settings zip?

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi Dominik,

Any news about this?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi Dev! Thanks for asking and I´m sorry for beeing late with my respond but nothing new... Nobody called me ever again, seems ok now, maybe a Fragment or artifact in an IT Environment with about 5000 users +  Smiley Happy

Thanks anyway, if something new I post it here.