Highlighted
Hot Shot
Hot Shot

"Drive mapping refers to local drive" error

I am having a nasty problem and i can't figure out what's causing it.

We use DEM to create drivemappings. One of the drivermappings isn't being created and shows an error in the flexengine.log

[ERROR] Drive mapping refers to local drive 'H' (Homedir.xml)

To me it looks like driveletter H is occupied at the moment DEM is trying to create the drivemapping.

When i do a -UemRefreshDrives after login, the mapping is created.

I have looked in the golden image and there is no H: drive in use, only C: and sometimes 😧 (cdrom)

Does anyone have some tips where to look for a solution?

0 Kudos
3 Replies
Highlighted
VMware Employee
VMware Employee

Hi SummaCollege,

You could try to investigate with a Before profile archive import Logon Task, running something like cmd.exe /c DIR H:\ >"%USERPROFILE%\H-DIR.txt". Maybe it shows something that helps find the culprit. (Be sure to configure a timeout so it does not cause your logon to hang Smiley Happy.)

If it works post-logon, you could work around this by using the Disable DEM Drive Mappings during logon policy setting from the advanced ADMX template (or the NoAD equivalent equivalent UEMActionDriveMappingDuringLogon="0") and launching a drive mapping refresh at a later stage.

0 Kudos
Highlighted
Hot Shot
Hot Shot

DEMdev​ Thanks for your tip!

I used your tip to find the culprit and when looking at the created .txt file i saw the following:

Volume in drive H is CVApps

Volume Serial Number is AEE0-8B16

Directory of H:\

04-09-2019  00:48                 0 allvolattached.bat

04-09-2019  00:48             1.355 allvolattached_shellstarted.bat

04-09-2019  00:48               320 cache.dat.initial

20-01-2020  14:19             1.472 cv_prestartup.log

20-01-2020  14:20               408 cv_prov_post.log

20-01-2020  14:20             6.225 META.ZIP

20-01-2020  14:20    <DIR>          METADATA

20-01-2020  14:19    <DIR>          OfficeTokensBefore

04-09-2019  00:48               261 prestartup.bat

04-09-2019  00:48             7.043 prov_post.bat

04-09-2019  00:48               372 shellstart.bat

20-01-2020  14:22            24.349 snapvol.cfg

04-09-2019  00:48                 0 startup.bat

04-09-2019  00:48               384 startup_postsvc.bat

28-08-2019  02:12           102.640 svoffice.exe

28-08-2019  02:09               228 svoffice.exe.config

04-09-2019  00:48            16.452 tokens.dat.initial

04-09-2019  00:49                20 version.txt

28-08-2019  02:12                87 VERSION32.txt

28-08-2019  02:17                87 VERSION64.txt

              18 File(s)        161.703 bytes

               2 Dir(s)  21.300.944.896 bytes free

To me it looks like an appstack or writable is attached before login and is using drive letter H: and a bit further in the process the driveletter is released as it is not visible afer login.

We do use Writable Volumes and Appstacks so that makes sense, but i never had any issues with driveletters before.

Do you have any idea what could be te cause of this?

These are the registry settings on HKLM\SYSTEM\CurrentControlSet\Services\svservice\Parameters

pastedImage_0.png

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi SummaCollege,

Is that H: drive maybe just hidden from File Explorer? That is, can you still DIR it from a command prompt within the session?

W.r.t. why you did not encounter this before, I guess you're better off in the App Volumes forum. I'm DEMdev, sorry Smiley Happy.

0 Kudos