NewbVMDude
Enthusiast
Enthusiast

Unable to Create Disable hardware acceleration key for Google Chrome

Jump to solution

Hi,

I'm trying to set the registry key to disable hardware acceleration in Google Chrome https://www.technipages.com/google-chrome-enable-disable-hardware-acceleration-mode  via registry entry.

I created a new User Environment Registry setting - set to apply after profile import

**********

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Immidio\Flex Profiles\ImportMarkers]
"Pre"=dword:b0dafda1

[HKEY_LOCAL_MACHINE\Software\Policies\Google\Chrome]
"HardwareAccelerationModeEnabled"=dword:00000001

[HKEY_CURRENT_USER\Software\Immidio\Flex Profiles\ImportMarkers]
"Post"=dword:7004260c

*********

Doesn't work.  In fact, anything I try to create in this hive seems to fail.

From what I've read HLLM and HKCU are supported registry hives for UEM.

Any idea what's wrong here?

Regards

Tags (2)
1 Solution

Accepted Solutions
ijdemes
Expert
Expert

You are trying to import a "HKEY_LOCAL_MACHINE" registry key, which is machine level. Most likely (by default) your user doesn't have permissions to add registry keys/values to "HKEY_LOCAL_MACHINE".

If you have to configure this settings on computer/machine level, try putting this setting in a computer GPO.

Not sure, but according the web site below it is also possible to configure it per user.

https://getadmx.com/?Category=Chrome&Policy=Google.Policies.Chrome::HardwareAccelerationModeEnabled&...

[HKEY_CURRENT_USER\Software\Policies\Google\Chrome]

"HardwareAccelerationModeEnabled"=dword:00000001

In that case you can use UEM for that, although I'm not sure if UEM can import a key/value in the \Software\Policies path.

But, the best option, I believe is using the Chrome ADMX, import this in UEM and configure the correct setting.

Set Chrome policies for devices - Chrome for enterprise Help

If you need further assistance, please let me know.


\\ Ivan
---
Twitter: @ivandemes
Blog: https://www.ivandemes.com

View solution in original post

4 Replies
admin
Immortal
Immortal

see below Lik if it  help you to resolve issue ..

https://www.itechtics.com/disable-hardware-acceleration-in-google-chrome-firefox-opera-and-vivaldi/

Regards,

Randhir

0 Kudos
ijdemes
Expert
Expert

You are trying to import a "HKEY_LOCAL_MACHINE" registry key, which is machine level. Most likely (by default) your user doesn't have permissions to add registry keys/values to "HKEY_LOCAL_MACHINE".

If you have to configure this settings on computer/machine level, try putting this setting in a computer GPO.

Not sure, but according the web site below it is also possible to configure it per user.

https://getadmx.com/?Category=Chrome&Policy=Google.Policies.Chrome::HardwareAccelerationModeEnabled&...

[HKEY_CURRENT_USER\Software\Policies\Google\Chrome]

"HardwareAccelerationModeEnabled"=dword:00000001

In that case you can use UEM for that, although I'm not sure if UEM can import a key/value in the \Software\Policies path.

But, the best option, I believe is using the Chrome ADMX, import this in UEM and configure the correct setting.

Set Chrome policies for devices - Chrome for enterprise Help

If you need further assistance, please let me know.


\\ Ivan
---
Twitter: @ivandemes
Blog: https://www.ivandemes.com
DEMdev
VMware Employee
VMware Employee

In that case you can use UEM for that, although I'm not sure if UEM can import a key/value in the \Software\Policies path.

It can't unless the user is an admin (non-admin users can't modify settings in the Policies location), in which case the original HKLM-based approach would have worked 🙂

But, the best option, I believe is using the Chrome ADMX, import this in UEM and configure the correct setting.

Exactly.

NewbVMDude
Enthusiast
Enthusiast

Thanks

That makes sense now Smiley Happy

Will try this

0 Kudos