SvenIT12
Contributor
Contributor

ThinApp doesn't work in combination with VMware UEM 9.3

Jump to solution

Hi everyone,

Since we've updated our clients to version 9.3 of the VMware User Enviorement Manager some ThinApps stopped working (Windows ErrorID 1000). The problem is likely caused by VMware UEM. If we stop the VMware Flex Engine Service in Windows the application works just fine. Once we activate it again it stops functioning. Also, if we downgrade back to version 8.7 of UEM the application also works fine. Some technical specs:

OS: Windows 8.1

ThinApp: Tested with 5.1 and 5.2.3 (both fail with UEM 9.3)

UEM: 9.3 (Doesn't work) and tested with 8.7 (Does work)

If more info is needed, please ask.

Thanks in advance!

0 Kudos
1 Solution

Accepted Solutions
techguy129
Expert
Expert

Is it just one particular application or multiple ones?

I suggest disabling directflex for the application. If that doesn't help, try adding it to blacklist.xml.

My issue with thinapp and cisco spark:

The only issue we had was we needed to blacklist the cisco spark.exe as it was crashing with directflex.

<?xml version="1.0" encoding="utf-8"?>

<userEnvironmentSettings>

<setting type="blacklist" list="ciscospark.exe|cisco spark.exe" />

</userEnvironmentSettings>

----

To create and manage the BlackList.XML file:

  1. Create a new folder called DirectFlex within the \\Server\FlexConfigShare\General\FlexRepository folder.
  2. Within the DirectFlex folder, create a text file named Blacklist.XML.
  3. Add this content to the Blacklist.XML file:

    <?xml version="1.0" encoding="utf-8"?>
    <userEnvironmentSettings>
    <setting type="blacklist" list="" />
    </userEnvironmentSettings>
  4. Save the Blacklist.XML file with UTF8 encoding.
  5. Add the processes you want to blacklist in the field list="".

    For example:

    list="notepad.exe"
    Note: Use | to specify more than one process.
  6. Restart your system for the changes to take effect.

View solution in original post

0 Kudos
2 Replies
techguy129
Expert
Expert

Is it just one particular application or multiple ones?

I suggest disabling directflex for the application. If that doesn't help, try adding it to blacklist.xml.

My issue with thinapp and cisco spark:

The only issue we had was we needed to blacklist the cisco spark.exe as it was crashing with directflex.

<?xml version="1.0" encoding="utf-8"?>

<userEnvironmentSettings>

<setting type="blacklist" list="ciscospark.exe|cisco spark.exe" />

</userEnvironmentSettings>

----

To create and manage the BlackList.XML file:

  1. Create a new folder called DirectFlex within the \\Server\FlexConfigShare\General\FlexRepository folder.
  2. Within the DirectFlex folder, create a text file named Blacklist.XML.
  3. Add this content to the Blacklist.XML file:

    <?xml version="1.0" encoding="utf-8"?>
    <userEnvironmentSettings>
    <setting type="blacklist" list="" />
    </userEnvironmentSettings>
  4. Save the Blacklist.XML file with UTF8 encoding.
  5. Add the processes you want to blacklist in the field list="".

    For example:

    list="notepad.exe"
    Note: Use | to specify more than one process.
  6. Restart your system for the changes to take effect.

View solution in original post

0 Kudos
SvenIT12
Contributor
Contributor

Thanks man, that does the trick for us (Blacklist.xml soulution)!

0 Kudos