ITJef
Enthusiast
Enthusiast

Reverse Setting?

Jump to solution

I am new to UEM.... I have a couple questions.

1. How can i reverse settings applied to a machine. For example i turned on the calculator shortcut and i disable the run menu and control panel. I then logged out and back in and it worked. However i want to reverse the settings so i disabled the policy but the calculator shortcut is still listed and the run menu and control panel is still hidden. I also tried deleting the policy that hides run menu and control panel and rebooted but i can't get the settings to reverse. How do i reverse the settings i have made?

2. With conditions it seems like if there is no condition specified then it will apply to every machine/user that the GPO applies to. Is this correct? When i first applied the GPO all of the default enabled shortcuts showed up even though alot of them had no conditions. Is there a way to configure it so that if there is no condition it doesn't apply at all?

0 Kudos
1 Solution

Accepted Solutions
DEMdev
VMware Employee
VMware Employee

Hi ITJef,

Some of the user environment settings (like shortcuts) have an explicit Undo at logoff setting, and some of them are automatically undone at logoff (like the Policy Settings). However, for those undo actions to work (and basically, for UEM to run correctly in general), UEM needs to be run at logoff as well. Did you configure a logoff script to run FlexEngine.exe at logoff? Can you maybe provide a FlexEngine log file at log level DEBUG?

Having said that, shortcuts by default do not have Undo at logoff set, so even if you have a logoff script configured, they won't automatically go away. For your test you could re-enable those shortcut settings, edit them to have Undo at logoff set (and make sure that Skip if shortcut already exists is not set), log on and log off again, and then the shortcuts should be gone.

However, given that the Run command and the control panel are still hidden, I'd recommend to also take a look at the logoff script.

Your understanding of conditions (or the lack of them) is correct: if no conditions are configured, the item applies. There is currently no way around that.

View solution in original post

0 Kudos
3 Replies
DEMdev
VMware Employee
VMware Employee

Hi ITJef,

Some of the user environment settings (like shortcuts) have an explicit Undo at logoff setting, and some of them are automatically undone at logoff (like the Policy Settings). However, for those undo actions to work (and basically, for UEM to run correctly in general), UEM needs to be run at logoff as well. Did you configure a logoff script to run FlexEngine.exe at logoff? Can you maybe provide a FlexEngine log file at log level DEBUG?

Having said that, shortcuts by default do not have Undo at logoff set, so even if you have a logoff script configured, they won't automatically go away. For your test you could re-enable those shortcut settings, edit them to have Undo at logoff set (and make sure that Skip if shortcut already exists is not set), log on and log off again, and then the shortcuts should be gone.

However, given that the Run command and the control panel are still hidden, I'd recommend to also take a look at the logoff script.

Your understanding of conditions (or the lack of them) is correct: if no conditions are configured, the item applies. There is currently no way around that.

View solution in original post

0 Kudos
ITJef
Enthusiast
Enthusiast

UEMdev Thanks for the response

No i didnt configure anything to happen at logout...i will look into that to see what step i missed. Attached is the flex engine log i have.

Should i configure the command below to run at logout?

"C:\Program Files\Immidio\Flex Profiles\flexengine.exe -UemRefresh"

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi ITJef,

OK, that would explain the behavior you're seeing.

Configure FlexEngine to Run From a Logoff Script describes how to configure the logoff script.

0 Kudos