Metapieman
Contributor
Contributor

Retain screen scaling choice in UEM

Jump to solution

Hi all

First time poster here. We're just moving away from Persona Management to UEM and we've been able to address various issues that have cropped up, but this has me stumped.

We're running Win7 desktops on Horizon 7.0.2 and we have a few users who like to manually increase their viewing scale to improve legibility.

We disabled the "Toggle Display Settings Control" setting in the View Agent GPO a long time ago to enable users to swap between 100%, 125% and 150% scaling in Control Panel > Display. Then Persona would save their choice and scale the screen appropriately at next logon.

Now we've moved to UEM the setting is lost at logoff and nothing I've tried seems to work. I tried using the DPI settings in Windows Common Settings to create a config file having read others saying that worked for them, but no luck.

If I edit my scaling I can see the value changes for LogPixels under HKCU\Control Panel\Desktop, but I've been unable to get UEM either capture or inject that setting.

I would be grateful for any advice. Many thanks.

All the best

1 Solution

Accepted Solutions
DEMdev
VMware Employee
VMware Employee

Hi Metapieman,

Welcome to the UEM forum! Thank you for the details you already provided.

The DPI settings Windows Common Setting contains that HKCU\Control Panel\Desktop@LogPixels value you mentioned:

pastedImage_3.png

For Windows 10, the built-in setting is not quite complete (we'll fix that in UEM 9.5), but the above should work fine on Windows 7. Can you post a FlexEngine log file at log level DEBUG, covering a full session from logon till logoff, so we can try and see what exactly is going on?

View solution in original post

8 Replies
DEMdev
VMware Employee
VMware Employee

Hi Metapieman,

Welcome to the UEM forum! Thank you for the details you already provided.

The DPI settings Windows Common Setting contains that HKCU\Control Panel\Desktop@LogPixels value you mentioned:

pastedImage_3.png

For Windows 10, the built-in setting is not quite complete (we'll fix that in UEM 9.5), but the above should work fine on Windows 7. Can you post a FlexEngine log file at log level DEBUG, covering a full session from logon till logoff, so we can try and see what exactly is going on?

View solution in original post

Metapieman
Contributor
Contributor

Hi UEMdev

Thank you very much for the reply. That helped me trust that the UEM settings were correct and look into other factors.

It would appear that the Windows Horizon Client is the problem. If I set the scaling to 150% and log off, then log back on from one of our Teradici zero clients, the 150% setting is applied and all is good. Using the zero client the setting is reliably retained between logons.

However as soon as I connect to the session using the Windows Horizon Client the scaling resets to 100%. If I remove the tick from the box for “Allow display scaling” I can at least reconnect to an existing session running 150%, but if I initiate a fresh logon from the Windows client it always resets to 100% regardless of the “Allow display scaling” setting being ticked or not.

I’ve tested this with our current UEM-based pools as well as older Persona-based desktops and the experience is the same for both.

All my initial testing was with the Windows client which led me to believe UEM was at fault, however UEM is definitely saving the settings between logins. And good to gear that work is underway to save the settings for Windows 10.

Many thanks.

DEMdev
VMware Employee
VMware Employee

Hi Metapieman,

Happy to hear that you've made some progress at least. I can't say I quite understand the issue at hand, but is it maybe related to this topic in the Horizon forum?

And good to gear that work is underway to save the settings for Windows 10.

In case you can't wait for the next release, manually adding

[IncludeRegistryTrees]

HKCU\Control Panel\Desktop\PerMonitorSettings

to your DPI settings Flex config file does the trick.

iamxCPx
Enthusiast
Enthusiast

Hi guys,

I'm having the same issue here.

I did add the DPI Settings per the answer recommendation but I'm not able to make it stick with the zero client nor the windows client when the user logoff.

The resolution kept going back to 100% instead of 125% like we wanted it to be.

DPI Settings.PNG

@Metapieman

Are you able to get this fixed?

How are you able the UEM to save the settings between logins?

I'm using Windows 7 Pro 64-bit with UEM 9.4 and AppVol 2.14.

Please help

Thank you.

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi iamxCPx,

Two questions:

  • Are the DPI settings correctly exported at logoff and imported at logon?
  • Do you by any chance have any "DPI sync" settings enabled in the Horizon client(s)?
iamxCPx
Enthusiast
Enthusiast

1. I believe so.

I do see the DPI Settings.zip under Archives - Windows Settings.

DPI.PNG

2. Do you mind elaborate what do you mean by that?

I'll google "DPI sync" settings on Horizon client.

Previously we were using Persona Management and it was working fine. If you meant if it's set on the horizon view GPO then yes, the setting is still there and applied to the AD OU for the computers.

I just migrated to UEM last weekend so I'm still learning. Smiley Happy

The user is currently using both the zero and os (win & mac) clients as well.

I have tried on both applications and they are not working still.

Hope that helps you help me?

0 Kudos
iamxCPx
Enthusiast
Enthusiast

I found it.

https://getadmx.com/?Category=VMware_Horizon_7&Policy=VMware.Policies.vdm_agent::DpiSync

No, the DPI sync was not enabled on my previous PCOIP GPO.

The only thing that I have configured was the Toggle Display Settings Control and it was set to disable.

Looks like this is a new GPO setting for Horizon View 7? I was on Horizon View 6 before and I don't believe this setting was needed.

Thank you for this.

I'll retry it and get back to you.  

0 Kudos
iamxCPx
Enthusiast
Enthusiast

That's it.

I just need to enable the DPI sync on the GPO.

Thank you for pointing me in that direction.