dnev
Contributor
Contributor

Please wait for the VMware DEM service.

I recently upgraded our VMware Horizon infrastructure from 7.10.3 ESB and DEM 9.9 ESB to Horizon 7.13.2 and DEM 2111. 

After the upgrade, when users log off their VDI session, Windows is stuck at "Please wait for the VMware DEM service". I can see this message from the console session of the desktop in question in vCenter and the Windows 10 screen just sits there spinning with the aforementioned message. The desktop never completes the logoff/shutdown. 

When the user tries to connect/reconnect to their entitled desktop pool they are unable to as the previous desktop is still shutting down. The Horizon console shows "Unable to launch from Pool 'desktop_pool' for user 'Domain\User': Machine 'Desktop-001' is not ready to accept connections".

Did something fundamentally change with DEM from version 9.9 to 2111 that I may have missed?

Our desktop pools are currently configured as non-persistent Linked-Clones that are delete at logoff.

Windows 10 1803, 20H2
VMware Tools 12.0.0.19345655
VMware Horizon Direct Connect Plugin 7.13.2.19438394
VMware Dynamic Environment Manager 10.4.0.1013
VMware Horizon Agent 7.13.2

 

0 Kudos
13 Replies
dnev
Contributor
Contributor

https://docs.vmware.com/en/VMware-Dynamic-Environment-Manager/2111/com.vmware.dynamic.environment.ma...

I'm wondering if this is our issue as we do have the below DEM config GPOs settings in place

  • User Policy setting - Run logon scripts synchronously
  • User Policy setting - Logoff script  C:\Program Files\Immidio\Flex Profiles\Flexengine.exe -s
  • Windows Computer Policy setting - Always wait for the network at computer startup and logon

According to VMware documentation:

  • There is no impact on the functionality of Dynamic Environment Manager if you do not clean up these settings immediately

But I have a feeling this may be causing the undesired logoff behavior.

0 Kudos
mrkasius
Hot Shot
Hot Shot

@dnev, have you followed the recommended Agent installation order?

https://kb.vmware.com/s/article/2118048

0 Kudos
kvmw2130
VMware Employee
VMware Employee

Could you please confirm if the DEM GPO was also updated with the 2111 latest one?

Run FlexEngine as  GP Extension has been replaced with Run Flex during logon and logoff

and yes, please turn off " Run logon scripts synchronously"

0 Kudos
dnev
Contributor
Contributor

@mrkasius yes, I have followed the agent VDI agent install order. 

0 Kudos
dnev
Contributor
Contributor

@mrkasius yes, I have followed the VDI agent install order in the KB that you shared

Uninstall order:

VMware DEM agent and reboot
VMware Horizon Agents and reboot
VMware Tools and reboot

Install order:

VMware Tools and reboot
VMware Horizon Agents and reboot
VMware DEM agent and reboot

 

0 Kudos
dnev
Contributor
Contributor

@kvmw2130 

Yes, I have downloaded and installed the DEM 2111 admx files. The 9.9 ESB admx files have been replaced.

https://docs.vmware.com/en/VMware-Dynamic-Environment-Manager/2111/rn/VMware-Dynamic-Environment-Man...

  • Simplified VMware Dynamic Environment Manager FlexEngine launch configuration. Removed the requirement for configuring Group Policy client-side extension to launch the FlexEngine. Also, removed the requirement of configuring logoff scripts.

https://docs.vmware.com/en/VMware-Dynamic-Environment-Manager/2103/com.vmware.dynamic.environment.ma...

  • Configure the following logoff command that will run during the logoff process:
  • "C:\Program Files\Immidio\Flex Profiles\FlexEngine.exe" -s

Remove both the logoff command as well as the "Run FlexEngine as Group Policy Extension" from the User GPO config?

0 Kudos
kvmw2130
VMware Employee
VMware Employee

Yes, please you may remove the log off-script and use only the "Configure Run FlexEngine at Logon and Logoff Setting" setting. If you still experience the issue, you may drop in the flexengine.log here for reference

0 Kudos
dnev
Contributor
Contributor

@kvmw2130 

To get our users back into useable desktops, I had to roll back our Horizon desktop pools to a previous build that includes the Horizon 7.10.3 and DEM 9.9.0.905 agents. Desktops running DEM 9.9 are still functional even though the DEM mgmt console has been upgraded to 2111 as well as the 2111 admx files.

If I change the recommended GPO settings will this cause undesired behavior to the desktops running DEM 9.9? 

0 Kudos
kvmw2130
VMware Employee
VMware Employee

I had run this last month using new 2111 GPO with DEM 9.10 it worked fine.

However only one thing we need to make sure is that flexengine shouldn't be run from more than one place.

 

 

0 Kudos
dnev
Contributor
Contributor

I opened a SR with VMware support on 3/15 and still waiting for their response... 

I have ruled out that production base image is the culprit.

  • Built a new Windows 10 VM from a ISO
    • Followed the VMware guide: Manually Creating Optimized Windows Images for VMware Horizon VMs
    • Snapshot 1 – Windows 10 21H2
    • Snapshot 2 – VMware Tools 12.0.0.19345655 + .Net Framework 3.5
    • Snapshot 3 – VMware Horizon Agent 7.13.2 + VMware Horizon Direct Connect Plugin 7.13.2.19438394
    • Snapshot 4 – VMware Dynamic Environment Manager 10.4.0.1013
    • Snapshot 5 – domain join

  • Build a new GPO – (DEM-User-Config-2111) using the DEM 2111 adml/admx files.
    • Test account is in the OU which GPO “DEM-User-Config-2111” is linked to
  • Log out is successful for the AD test account if I perform the below changes.

    • Uninstall DEM agent 10.4.0.1013
    • Reboot
    • Install DEM agent 9.9.0.905
    • Reboot
  • 9.9 works without issue, 2106 works without issue, 10.4 creates the log off issue. It's like DEM can't export the settings at log off. 

Tags (1)
0 Kudos
sjesse
Leadership
Leadership

Moderator: Removed an link that had nothing to do with this topic from the last comment

0 Kudos
ijdemes
Expert
Expert

I know I'm stepping in in the middle of the conversation, but going through the replies I can't seem to find the confirmation that when DEM 2111 including the 2111 ADMX is used, the "FlexEngine.exe -s" logoff command has been disabled or removed. Maybe there is a conflict going there.

 

Can you please confirm that "FlexEngine.exe -s" logoff command has been disabled/removed when DEM 2111 (incl. ADMX) is being used?


\\ Ivan
---
Twitter: @ivandemes
Blog: https://www.ivandemes.com
0 Kudos
dnev
Contributor
Contributor

Yes, the log off script has been removed. This was completed when I built a new user GPO policy based on the 2111 ADMX settings.

0 Kudos