Microsoft Teams

Microsoft Teams

If you want to manage Microsoft Teams with VMware Dynamic Environment Manager (DEM), here is a good working template.

Recommended is to deploy Teams using the MSI installer, which can be found here: https://docs.microsoft.com/en-us/microsoftteams/msi-deployment

This will install the MSI into the Program Files directory, and will install Teams into the Roaming AppData folder for each user that logs on to the machine.

I don't recommended enabling DirectFlex for this application, since the application will automatically launch at logon anyway.

How to implement:

Create a new DEM config file using the DEM management console and just copy-paste these lines:

===

# Microsoft Teams MSI installer

# https://docs.microsoft.com/en-us/microsoftteams/msi-deployment

[IncludeRegistryTrees]
HKCU\Software\Microsoft\Office\Teams

[IncludeFolderTrees]
<AppData>\Microsoft\Teams
<AppData>\Teams

[ExcludeFolderTrees]
<AppData>\Microsoft\Teams\Cache
<AppData>\Microsoft\Teams\Code Cache
<AppData>\Microsoft\Teams\GPUCache
<AppData>\Microsoft\Teams\Service Worker\CacheStorage

[ExcludeFiles]
old_logs_*.txt
logs.txt

===

The end result should look like this:

Teams.png

Labels (1)
Attachments
Comments

With this config the password could not be saved.

This is my very optimized version of config:

[IncludeRegistryTrees]
HKCU\Software\Microsoft\Office\Teams

[IncludeFolderTrees]
<LocalAppData>\Microsoft\IdentityCache
<LocalAppData>\Microsoft\Teams
<LocalAppData>\Microsoft\TeamsMeetingAddin
<LocalAppData>\Microsoft\TeamsPresenceAddin
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
<LocalAppData>\SquirrelTemp
<AppData>\Microsoft\Teams


[ExcludeFolderTrees]
<AppData>\Microsoft Teams\logs
<AppData>\Microsoft\Teams\media-stack
<AppData>\Microsoft\Teams\Service Worker
<AppData>\Microsoft\Teams\Application Cache
<AppData>\Microsoft\Teams\Cache
<AppData>\Microsoft\Teams\tmp
<AppData>\Microsoft\Teams\meeting-addin\Cache
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\TempState
<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AC\Temp

[ExcludeFiles]
<AppData>\Microsoft\Teams\lockfile
<AppData>\Microsoft\Teams\storage.json
<AppData>\Microsoft\Teams\*.txt
old_logs_*.txt
logs.txt

Thanks Pim, 

I noticed that code cache folder consumes a lot and excluded it also now.

Not sure i'm missing anything by only capturing user settings only? Bbut here is the configuration i've put in place : 

[IncludeFiles]
<AppData>\Microsoft\Teams\desktop-config.json
<AppData>\Microsoft\Teams\settings.json

I am finding some discrepancies with the above configuration published by @TomH201110141 , wondering if I have missed something, somewhere, somehow 🤔

When DEM runs through the export process, the following appear in the log:

<LocalAppData>\Microsoft\IdentityCache "Does not Exist"

<LocalAppData>\Microsoft\Teams "Does not Exist"

<LocalAppData>\Microsoft\TeamsMeetingAddin "Does not Exist"

<LocalAppData>\Microsoft\TeamsPresenceAddin "Does not Exist"

<LocalAppData>\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy "Does not Exist"

<LocalAppData>\SquirrelTemp "Does not Exist"

 

 

The folder <LocalAppData>\Microsoft\Teams should exist, unless you've installed Teams in a different folder. Please check.

@Pim_van_de_Vis thanks for the response.

The Folder does indeed exist in %localappdata% but its empty, it appears that the Teams Data resides, certainly for me in the App Data Roaming %Appdata%\Microsoft\Teams.Screen Shot 2022-05-16 at 10.02.12 AM.png

Screen Shot 2022-05-16 at 4.54.19 PM.png

Teams Installer was run using the following: msiexec /i "Teams MSI File" ALLUSER=1 ALLUSERS=1

Thanks for sharing this.

Hi all, 

Below is my current Teams config, which has worked fine for a while until I recently updated to Teams Version 1.5.00.11865. Now every time we log in, we get the message "To restart teams to turn on the new meeting Experience" Has anyone else run into this yet? 

[IncludeFolderTrees]
<AppData>\Teams
<AppData>\Microsoft\Teams

[IncludeRegistryTrees]
HKCU\Software\Microsoft\Office\Teams
HKCU\Software\Microsoft\Tracing\WPPMediaPerApp\Teams

[IncludeIndividualFolders]
<LocalAppData>\Microsoft\IdentityCache

[ExcludeFiles]
<AppData>\Microsoft\Teams\*.txt
<AppData>\Microsoft\Teams\lockfile
<AppData>\Microsoft\Teams\storage.json
old_logs_*.txt
logs.txt

[ExcludeFolderTrees]
<AppData>\Microsoft Teams\logs
<AppData>\Microsoft\Teams\media-stack
<AppData>\Microsoft\Teams\Service Worker
<AppData>\Microsoft\Teams\Application Cache
<AppData>\Microsoft\Teams\Cache
<AppData>\Microsoft\Teams\tmp
<AppData>\Microsoft\Teams\meeting-addin\Cache
<AppData>\Microsoft\Teams\Code Cache
<AppData>\Microsoft\Teams\GPUCache

I was able to resolve this by removing the storage.json file "<AppData>\Microsoft\Teams\storage.json", under the ExcludeFiles section. I hope this helps anyone else who runs into this. 

Hello @MikeC3964 @Pim_van_de_Vis @86rn6r05M , 

I am trying to get DEM to save information for Teams and the only thing I am getting in the Teams.zip archive folder is the Registry folder, not AppData folder.  Here is my current config for Teams.  Would someone be able to tell me what I am doing wrong? Below is a screenshot of the contents of my Microsoft Teams.zip file

rwulffenstein_0-1668464726463.png

rwulffenstein_1-1668464910733.png

Thank you!

 

 

@rwulffenstein maybe Teams is installed in <LocalAppData>\Microsoft\Teams in you case?

@Pim_van_de_Vis 

I have confirmed it is installed in the Roaming folder

If you have redirected the AppData folder, that could explain the issue.

When you use DEM, it's never recommended to redirect AppData. Just capture all relevant AppData folders with corresponding DEM config files.

Version history
Revision #:
1 of 1
Last update:
‎07-14-2021 06:03 AM
Updated by:
 
Contributors