CoreyN
Enthusiast
Enthusiast

Folder redirection works with errors in log

Jump to solution

Bit of a strange one here and I haven't been able to find someone experiencing exactly the same problem yet.  I'm using UEM for folder redirection on the desktop, documents, and pictures folders and everything is working fine except that the flexengine.log file always has the below three entries at each users' login.  Like I said, it's been working smoothly so I haven't been overly concerned, but it would be nice to make the warnings go away!  The UEM share is on a Server 2016 WSFC set up if that makes a difference.

Capture.PNG

Running on -

Horizon 7.5.1

UEM 9.6

AppVolumes 2.15

Windows 10 x64 1803

Thanks!

1 Solution

Accepted Solutions
DEMdev
VMware Employee
VMware Employee

Hi CoreyN,

That "... but initialization failed with error 0x80070005" indicates an access denied error. Can you check the permissions on those folders, and also on the (hidden) Desktop.ini file in those folders?

View solution in original post

0 Kudos
12 Replies
sjesse
Leadership
Leadership

When you test them do the redirection actual work? Do you have any GPOs applied other then the UEM ones?

0 Kudos
CoreyN
Enthusiast
Enthusiast

Yes, the redirection has been working great.  We have quite a few other GPOs that get applied.  Folder redirection was done with a combo of GP and UEM, but I removed those linked policies when they added the ability to do folder redirection with UEM to different targets.

0 Kudos
sjesse
Leadership
Leadership

Did this come up after your remove the gpos?

0 Kudos
CoreyN
Enthusiast
Enthusiast

Nope - these warnings have been consistent from the very beginning.

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi CoreyN,

That "... but initialization failed with error 0x80070005" indicates an access denied error. Can you check the permissions on those folders, and also on the (hidden) Desktop.ini file in those folders?

0 Kudos
CoreyN
Enthusiast
Enthusiast

I had triple checked my permission settings on the share before because I knew that code was for access denied but everything was set correctly from every document that I could find.  You mention the desktop.ini file though and that is something that I had completely forgotten about!  Back on a previous share that held redirected 'My Documents' folders for users at the root level we had put a file screen in place to deny that file because it would make all folders display as 'My Documents' to administrators looking at the share.  I'm sure that we're also using a similar file screen here and that's what's causing the warning.  Every user gets their own folder with sub folders for redirected folders on the new share so we shouldn't even need that old rule at this point.

I'm going to turn that screen off and I bet that the error goes away!

CoreyN
Enthusiast
Enthusiast

Yep - that was it.  Good catch UEMdev and thanks!

DEMdev
VMware Employee
VMware Employee

Hi CoreyN,

Happy to hear that we managed to root cause the problem!

Just out of curiosity: what exactly do you mean by a "file screen"?

CoreyN
Enthusiast
Enthusiast

It's a part of the Windows File Server Resource Manager (FSRM).  We use it for quotas, file screens, etc.  The screens let you block files by name, type, etc. so I had a block in for the desktop.ini file specifically.

zhornsby221
Contributor
Contributor

where is the desktop.ini? i do not see that anywhere

0 Kudos
sjesse
Leadership
Leadership

hits hidden , go to folder options and show hidden files

0 Kudos
zhornsby221
Contributor
Contributor

yep i have

0 Kudos