Dempseyy93
Enthusiast
Enthusiast

Default Web Browser not sticking

Jump to solution

We've encountered an issue in our environment where Mozilla Firefox when set as default (superseding MS Edge browser) will revert back to edge when performing the following sequence:

1. Log into non-persistent VDI session as standard user.

2. Open Firefox > Options > Check Always check if Firefox is your default browser + Make Default

3. Confirm Firefox has been set as default in Default apps settings.

4. Log off > Log on > Sign in as standard user.

5. Open Default apps > Confirm Firefox is still default web browser

6. Open Firefox from Start Menu/Desktop Shortcut

7. Witness Default apps automatically switch Firefox back to MS Edge

Any ideas why opening Firefox would trigger Edge to take precedence again?

Details:

- UEM 9.6

- AppVolumes 2.16

- Non Persistent VDI

- Firefox 31.8.0

UEM Firefox Config:

[IncludeRegistryTrees]

HKCU\software\classes\FirefoxHTML

HKCU\software\classes\FirefoxURL

HKCU\software\classes\.htm

HKCU\software\classes\.html

HKCU\software\classes\.shtml

HKCU\software\classes\.xht

HKCU\software\classes\.xhtml

HKCU\software\classes\ftp

HKCU\software\classes\http

HKCU\software\classes\https

HKCU\software\Microsoft\Windows\currentVersion\Explorer\FileExts\.htm

HKCU\software\Microsoft\Windows\currentVersion\Explorer\FileExts\.html

HKCU\software\Microsoft\Windows\currentVersion\Explorer\FileExts\.shtml

HKCU\software\Microsoft\Windows\currentVersion\Explorer\FileExts\.xht

HKCU\software\Microsoft\Windows\currentVersion\Explorer\FileExts\.xhtml

HKCU\software\Microsoft\Windows\Shell\Associations\UrlAssociations

HKCU\software\Mozilla

HKCU\software\Mozilla.org

HKCU\software\MozillaPlugins

[IncludeFolderTrees]

<AppData>\Mozilla

0 Kudos
1 Solution

Accepted Solutions
Dempseyy93
Enthusiast
Enthusiast

Turns out it was the following line that was preventing it from sticking:

HKCU\software\Microsoft\Windows\Shell\Associations\UrlAssociations

Thanks for the FTA suggestion, we've utilised it in the past.

Cheers,

Matt

View solution in original post

0 Kudos
2 Replies
ijdemes
Expert
Expert

Hi Dempseyy93​,

I have written a blog post on how to roam FTA's successfully using UEM. You can find it here:

https://www.ivandemes.com/export-import-file-type-associations-fta-successfully-using-uem/

If you still have questions after this, please let me know.


\\ Ivan
---
Twitter: @ivandemes
Blog: https://www.ivandemes.com
0 Kudos
Dempseyy93
Enthusiast
Enthusiast

Turns out it was the following line that was preventing it from sticking:

HKCU\software\Microsoft\Windows\Shell\Associations\UrlAssociations

Thanks for the FTA suggestion, we've utilised it in the past.

Cheers,

Matt

0 Kudos