SebastianK8
Enthusiast
Enthusiast

DEM 2111 Horizon Smart Policies don't work on login, only on reconnect

Jump to solution

Hi Community,

I'm testing Horizon Smart Policies (DEM 2111) for a Customer and I cant get it to work on login. The Smart Policies only apply after reconnect, even without triggered reconnect task. I wanna try the different bandwidth profiles, but every time I log into the desktop, there is no applied Setting from Smart Policies. If I disconnect and reconnect to the Desktop, the bandwith profile applies. The Smart Policies should take action on login, right? I'm trying on Windows 10 (21H2) with vGPU on Horizon 8.4.0 Build – 18964730 and App Volumes 4.5.

It seems the Policies are applied correct:
2022-02-18 13:25:33.105 [DEBUG] Conditions: Check for Horizon client property 'Launch_ID' = true ('Windows' is equal to 'Windows')
2022-02-18 13:25:33.105 [DEBUG] Collected Horizon Smart Policies settings for audio playback ('Test.xml')
2022-02-18 13:25:33.105 [DEBUG] Collected Horizon Smart Policies settings for bandwidth profile ('Test.xml')
2022-02-18 13:25:33.107 [INFO ] Applied Horizon Smart Policies settings:
2022-02-18 13:25:33.107 [INFO ] Bandwidth profile is set to 'Extremely low-speed connection'
2022-02-18 13:25:33.107 [INFO ] Audio playback is disabled

I cant get it to work on first login 😞

Some years ago, there was the same question without a solution -> https://communities.vmware.com/t5/Dynamic-Environment-Manager/Smart-Policies-Bandwith-Profile-not-wo...

Any hints for me?

Kind regards
Sebastian

0 Kudos
1 Solution

Accepted Solutions
mrkasius
Hot Shot
Hot Shot

Hi @SebastianK8,

The issue you are facing is described in this official KB.

View solution in original post

0 Kudos
6 Replies
kvmw2130
VMware Employee
VMware Employee

Hello Sebastian,

 

This could be a timing issue, please create a shortcut to run on startup as follows:

kvmw2130_0-1646087685197.png

 

0 Kudos
SebastianK8
Enthusiast
Enthusiast

Hi @kvmw2130 

thanks for your reply, I started thinking nobody is using Smart Policies because of no answer 🙂

Unfortunately the shortcut doesn't change the behaviour, the Smart Policies doesn't apply on login, only on reconnect though I don't have any triggered task for reconnection.

As I said, I'm using vGPU and App Volumes, could that cause this issue? It's just a test environment for customer, but i would like to get it working.

Kind Regards
Sebastian

0 Kudos
kvmw2130
VMware Employee
VMware Employee

Hello Sebastian,

Definitely, Smart policies are used by many users 🙂 It gives great control on Horizon peripheral management

Could you please let me know if there is any particular setting on smart policy you are working on here? [ USB oR Client Drive redirection ]

Basically what DEM doing here is toggling the features ON or OFF at "HKCU\Software\Policies\VMware Inc\FeatureName\"

You can review if the DEM is toggling this reg key and if flexengine.log can be uploaded here after reconnect instance we can check whats happening

0 Kudos
SebastianK8
Enthusiast
Enthusiast

Hi @kvmw2130 

thanks for your reply and sorry for the delay. I wanna try bandwidth options from Smart Policies, especially the low Internet Option. So I've created the following Policy:

 

smart policy.png

After the user login, it seems the network profile doesn't work correctly. I can still see a high bandwidth, FPS over 30 and a good Video Quality:

performance original.png

The registry keys are set, audio disable works so far.

regedit.png

But the user, or the session, is still consuming a lot of bandwidth with high quality. If I disconnect and reconnect to the same desktop, the quality is much lower and the bandwidth consumption too, also the FPS:

performance after reconnect.png

Maybe I just have a wrong understanding about Smart Policies, but I thought I can configure a Bandwidth Profile and the DEM changes some settings for the user session (qualitiy, FPS etc.) to lower the consumed Bandwidth? Please let me know if I'm wrong. In my case it only works after reconnect. 

Kind regards
Sebastian

0 Kudos
kvmw2130
VMware Employee
VMware Employee

Hello Sebastian,

Thanks for clarifying it. Definitely, we can do that through DEM and if it's not happening at first logon, then we will have to see the if you have configured the similar settings from GPO which takes precedence as it applies on Computer Context. When reconnect the user context is overwrite the computer context. 

0 Kudos
mrkasius
Hot Shot
Hot Shot

Hi @SebastianK8,

The issue you are facing is described in this official KB.

0 Kudos