TomH201110141
Enthusiast
Enthusiast

Computer Environment settings do not work

Jump to solution

I'am struggeling with the possibility to use the ADMX-based settings in the Computer Environment tab.

Each setting I do get's ignored. ADMX-setings in User Environment works very well.

I have installed the DEM agent without the COMPENVCONFIGFILEPATH property because I use a GPO to set the "ConfigFilePath". Are there any other requirements - I didn't find the VMware Docs?

0 Kudos
2 Solutions

Accepted Solutions
AndreZuercher
Contributor
Contributor

Do you set enabled as well?

Set Enabled (REG_DWORD) to 1.
Set ConfigFilePath (REG_EXPAND_SZ)

Installing and Configuring VMware Dynamic Environment Manager - VMware Dynamic Environment Manager 2...

around page 52

View solution in original post

DEMdev
VMware Employee
VMware Employee

Hi @TomH201110141,

Those registry settings really need to be in the master image. Computer settings are applied at boot, so using a user GPO (or even a computer GPO for that matter) is too late.

View solution in original post

7 Replies
AndreZuercher
Contributor
Contributor

Do you set enabled as well?

Set Enabled (REG_DWORD) to 1.
Set ConfigFilePath (REG_EXPAND_SZ)

Installing and Configuring VMware Dynamic Environment Manager - VMware Dynamic Environment Manager 2...

around page 52

View solution in original post

TomH201110141
Enthusiast
Enthusiast

I did this via a User-GPO or is it mandatory do set in Master-VM with a reg-key?

TomH201110141_0-1619603733612.png

The screenshot is from a deployed Instant-Clone VM.

 

I'm a little confused about this since we use the GPO to make the DEM work at all. At least I thought this GPO is mandatory for it?

Is it the recommended way to set this already in the master?

0 Kudos
pbastiaans
Enthusiast
Enthusiast

Have you given 'Domain Computers' rights to access the General folder?

pbastiaans_0-1619622858786.png

 

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi @TomH201110141,

Those registry settings really need to be in the master image. Computer settings are applied at boot, so using a user GPO (or even a computer GPO for that matter) is too late.

View solution in original post

TomH201110141
Enthusiast
Enthusiast

@pbastiaans  Yes, DomainComputers have Read-Permissions.

@DEMdev : I will give it a try to set this in the Master-Image and disable the GPO.

I will report tomorrow.

TomH201110141
Enthusiast
Enthusiast

I have set the reg-key now in the Master-Image and it works like expected - fantastic!.

First I was confused because in registry you see the Key "Computer Configuration" now twice.

Just one hint: for me it has to be a REG_SZ value - REG_EXPAND_SZ seems not work.

 

Thanks at all for the great help!

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi @TomH201110141,

Happy to hear it works now.

Just one hint: for me it has to be a REG_SZ value - REG_EXPAND_SZ seems not work.

REG_EXPAND_SZ should definitely work, but any env vars you reference should be system variables that are available early during boot.

0 Kudos