DEMdev
VMware Employee
VMware Employee

Bug in DEM 2111 (10.4) Self-Support Tool

I'm sorry to report that there's a bug in the DEM 2111 (10.4) Self-Support Tool: looks like we focused so much on adding support for OneDrive for Business integration that we broke support for SMB file shares... 😞

This will be fixed in the next release, and has now been documented as a known issue in the 2111 release notes.

Fortunately, the workaround is pretty straightforward: just use the Self-Support Tool from 2103 or 2106 (which contains the 2103 agent bits, including the Self-Support Tool.)
You can overwrite the executable in the installation folder, or copy the old version (together with its .exe.config file) into another folder and have your users launch it from there. Given that it's just a few hundred kB, you could even consider doing the latter via a DEM Files and Folders setting.

Apologies for the inconvenience.

5 Replies
popvm
Enthusiast
Enthusiast

Thanks for the heads up @DEMdev

system32AUT
Enthusiast
Enthusiast

Thank you 🙂 We find out 1 day later, thankfully we didnt push the update on our 6000 client environment  😉

Update when? Maybe 10.4.1 very soon ? 

cheers,

Dominik

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi Dominik,

We're not currently planning to release a 10.4.1 for this issue, as the workaround of using an older version is pretty straightforward. 

0 Kudos
system32AUT
Enthusiast
Enthusiast

🤔☹️ Too bad, I wanted to use the latest DEM version for our Windows 10 Ent. 21H2 and also install all GI with it.

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi Dominik,

Just to be clear, I meant "an older version of the Self-Support Tool", so installing/upgrading to DEM 2111 but overwriting the Self-Support Tool with the DEM 2106 version (or, alternatively, "deploying" the 2106 Self-Support Tool via a DEM Files and Folders setting (as the binary is just a few hundred kB) and a corresponding shortcut setting.)

0 Kudos