VMware Horizon Community
deep184
Enthusiast
Enthusiast

Bandwidth

Hello,

What alternative options are available to set bandwidth limitations based on user accounts? I know that the bandwith settings available under smart policies does not allow for customization. Also, when using the smart policy to set bandwidth profile how would I be able to confirm on the local deaktop that the settings were actually set? Is there a location I could look for in the registry?

Thanks in advance!

12 Replies
pchapman
Hot Shot
Hot Shot

You can do it the old fashioned way using the provided ADMX files for Blast/PCoIP in the Horizon Extras bundle.  They will be fixed settings based on whatever security filtering you setup in a group policy rather than the dynamic nature of the smart policies.

Reply
0 Kudos
deep184
Enthusiast
Enthusiast

Thanks!

have you or anyone tried importing the admx templates into UEM?

Reply
0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi deep184​,

I just tested this by importing the templates and configuring the maximum session bandwidth:

pastedImage_0.png

However, even though the setting applied correctly (I checked the corresponding registry setting after logging on), it doesn't look like it took effect: checking the PCoIP counters in PerfMon, the bandwidth limit is still shown as 900,000.

I'm afraid that's a question for one of the Horizon forums – from the UEM side I can only say that the policy setting has been applied correctly...

deep184
Enthusiast
Enthusiast

Thank you for testing this out and letting me know!

Which registry key setting were you looking into?

Thank you!

Reply
0 Kudos
DEMdev
VMware Employee
VMware Employee

I checked the location referenced in the ADMX template: HKCU\Software\Policies\Teradici\PCoIP\pcoip_admin@pcoip.max_link_rate.

Reply
0 Kudos
deep184
Enthusiast
Enthusiast

Thanks again, I will look into this tomorrow.

I have been looking under HKLM based on this document Configuring PCoIP session variables (1014686) | VMware KB.

Reply
0 Kudos
DEMdev
VMware Employee
VMware Employee

I'm pretty sure HKLM settings would work – it's just that you won't be able to set those through UEM 🙂

Update: I actually just tested this, by configuring the computer equivalent of the user setting I showed a screenshot of previously, via local group policy, and that does indeed work. That is, I see my policy value reflected in Performance Monitor (and I think I also got a "choppier" UI experience because of me limiting the bandwidth to 250kbps).

Ittybit
Contributor
Contributor

Hello,

I’m trying to enable and test this policies in my test environment and I’m noticing that the policies are not reflected in the perfmon. Any suggestions on what could be causing this? I’m using UEM 9.2.

Thanks

Reply
0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi Ittybit,

Can you provide a bit more detail? Which policies are you using, and how do you apply them?

Reply
0 Kudos
Ittybit
Contributor
Contributor

Hey,

Created Horizon smart policy for bandwidth profile, set it to Broadband WAN and used a security group as a condition. I also tried going the GPO route with the user settings and it doesn’t seem to work but when using the computer settings (HKLM) it does work but I really need this to work based on user groups. Does anyone have this working ?

Thanks

Reply
0 Kudos
DEMdev
VMware Employee
VMware Employee

If it doesn't work when you're using GPOs, I suggest asking in the Horizon forum, as UEM is not in the picture in that case.

If you're using Horizon Smart Policies: can you provide a UEM log file at level DEBUG, covering a full session from logon to logoff?

Also, triggered by your post in another topic: if you applied the HorizonLogic=0 workaround, Smart Policies most probably won't work. That is, UEM will still apply the necessary settings, but the Horizon components that are controlled by those settings generally won't pick them up.

Reply
0 Kudos
Ittybit
Contributor
Contributor

Thanks for the feedback I will post on the horizon forum and see if I get anything.

I had tested this prior to setting the workaround.

Reply
0 Kudos