manymore
Contributor
Contributor

error - insufficient permissions to connect to 'computername'

I am attempting to convert a physical machine to virtual image. Currently running VMware server 2.0.1 on a Windows 2008 server, and VMware Converter standalone is installed on this machine. I enter all the correct information on the MachineType screen (within Converter), click next and the WMware vCenter COnverter Standalone Agent deployment window pops up. I clicked "Automatically uninstall" and then click YES. It then responds with Insufficient permissions to conneect to "computername". The physical machine being converted is Windows XP Pro SP2. The username entered on the previous screen has administrator rights. Any suggestions?

4 Replies
Erikm_Project
Contributor
Contributor

i try with ADMIN$ on the source machine

in my issue the problem was in the ADMIN$ (in my example the machine ip was 10.1.2.4 for lab testing)

after i solve the access denied problem ... all working

try to see error in the log file in Document and Setting\All Users\Application Data\ VMWare vCenter Converter Standalone\

you must try with command

"net use of machine\ADMIN$ /user:"administrator user" to see if there's problem of access denied

this was my "vmware-converter-server-3.log" file tell me

#2] 2009-04-09 13:20:38.046 'App' 3896 verbose Cached agent connection is for a different source, recreating connection

2009-04-09 13:20:38.046 'App' 3896 verbose Creating SOAP stub adapter for host 10.1.2.4:9089

2009-04-09 13:20:42.156 'App' 5484 info Install Agent on 10.1.2.4

2009-04-09 13:20:42.156 'App' 5484 info Connect to ADMIN$ on 10.1.2.4 as 10.1.2.4\utente 2009-04-09 13:22:00.218 'App' 5484 info SMB manager: Error connecting to share http://\\10.1.2.4\ADMIN$: 64 [#2] 2009-04-09 13:22:00.218 'App' 5484 error Deployment on 10.1.2.4 failed: Unspecified error in remote execution mechanism

2009-04-09 13:22:00.218 'App' 5484 error Install of Agent failed on 10.1.2.4

2009-04-09 13:22:00.218 'App' 5484 error Install Agent failed: converter.fault.AgentDeploymentFault

2009-04-09 13:22:00.218 'wizardController' 5484 verbose AgentManagerProxy::InstallAgent: Agent deployment status: 4.

0 Kudos
andybrucecsc
Contributor
Contributor

Erik's response was correct, but did not provide details on how to solve the Access Denied issue.

This problem's solution has three required actions for me with a W2K8R2 box:

1. Disable Windows Firewall or create exclusion rules. Ports include 137,138 (UDP) and 445,139,9089,9090 (TCP).

2. Disable Simple File Sharing. For W2K8R2, goto Explorer -> Tools -> View tab. Scroll to bottom and uncheck "Use File Sharing Wizard (recommended). Server 2008 calls same option "Use Simple File Sharing" but the meaning is the same.

3. If you have UAC enabled as we do in our hardened environment, you must disable UAC for network access. See http://www.tomsitpro.com/articles/windows_8-file_sharing-windows_administrative_shares,2-195.html which is summarized as:

  • HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  • Create a QWORD (64-bit) called LocalAccountTokenFilterPolicy, that worked for me when the DWORD would not allow access to my 64-bit machine. Set to 1 (number one).
  • Reboot system

Performing these steps allowed me to get past the network error *and* allow the deployment wizard to deploy

jfnoriega
Contributor
Contributor

Thank you both for the answers, I was able to start my first Physical to Virtual conversion after troubleshooting the ports issues. 

Regards

0 Kudos
LockonComputer
Contributor
Contributor

Likewise - thank you to the two follow-up posts.  In my case "Simple File Sharing" was mysteriously turned on (it's the first thing I turn off on every PC).

OP, please change status to "answered" or "solved".

Thanks

0 Kudos