a disk read error occurred

Converter 4.0.1

WinXP SP3 Physical -> ESXi 4.0

After successful conversion (no obvious errors in the logs) I'm getting the "a disk read error occured press ctrl - alt - del"

Booted from XP CD and did the fixboot & fixmbr to no avail. ran chkdsk

Created new VM and used exisiting vmdk

checked startup order, tried boot menu

XP boot floppy DOES work (ntldr, ntdetect, boot.ini on floppy image) - but this isn't really ideal.

Any ideas?

0 Kudos
3 Replies

Run a chkdsk on the source disk. If there are errors then chkdsk /f on the source and re run converter.

You should also check to see that you don't have errors on the ESXi datastore. Try ALT + F12 from the ESXi console as you start the VM

Also look through the vmware.log files for the VM.

-- David -- VMware Communities Moderator
0 Kudos

to add on to this ...

What controller did you select ?

I guess the original machine used IDE ?

If you configure the VM to use IDE you may get this result.

VMware can only handle BUSLOGIC (vmscsi) for XP source machines.

The IDE and LSIlogic options are a bluff.

This error may also mean that the partition is not activated - or that you try to boot from a non-bootable floppy image


VMX-parameters- Workstation FAQ -[ MOA-liveCD|http://sanbarrow.com/moa241.html] - VM-Sickbay

Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos

I had the same problem converting an XP image from ESX4 to another ESX4. As DSTAVERT mentioned, when I converted using Buslogic SCSI controller vs. "same as source" (IDE), it worked fine!


0 Kudos