VMware Cloud Community
desadi10
Enthusiast
Enthusiast
Jump to solution

VMware vCenter Converter Standalone fails at 97% with the error: Error installing GRUB Command

I want to virtualize a linux physical machine (Ubuntu server) in a virtual machine.

I followed the steps of this guide: https://www.joe0.com/2017/01/12/how-to-convert-a-remote-physical-linux-server-to-a-virtual-machine-v...

All was well until I tried to convert physical machine with VMware vCenter Converter Standalone tool, so that, I had an error before to end the task:

1 — imgbb.com

 

I looked for information about this issue and I found an article in the knowledge base of VMware: https://kb.vmware.com/s/article/2052628

 

1. Mount the original Linux distribution DVD on the virtual machine and boot from DVD à OK

2 — imgbb.com

 

2. Select the rescue option from the boot menu à OK

https://ibb.co/ciNSOH

 

3. Identify the disk containing the root file system à I have a doubt

If I select, the first option, I have this issue:

https://ibb.co/fUXNqx

https://ibb.co/dCCcOH

 

So, I select the next option:

https://ibb.co/eV7Yxc

 

4. But, when I select the step 4: Select the option to initiate a shell.

https://ibb.co/cSRRHc

 

5. And I try to do the step 5: Fix the BIOS boot partition.

In the example says:

https://ibb.co/bRU2qx

 

But, when I execute these commands, I don´t have a similar screen:

https://ibb.co/eeC0cc

 

I want to know if by not having this screen I am not able to install or to repair GRUB to be able to launch the virtualized virtual machine.

Thanks so much.

 

P.D. Sorry to put the URL instead of the images, but, when I add the picture to upload, I receive this error message “That image type is forbidden” and I can’t upload them.

Moderator note by wila: Moved from VMware Workstation discussions for vCenter Converter Standalone discussions

Reply
0 Kudos
1 Solution

Accepted Solutions
desadi10
Enthusiast
Enthusiast
Jump to solution

Finally, I managed to solve the problem.

I booted from the CD-ROM Drive, I entered in the rescue mode, I identified the disk containing the root file system, I selected the option to initialise the shell and I ran these commands:

  1. root@debian:~# grub-install /dev/sda
  2. root@debian:~# update-grub
  3. root@debian:~# reboot

View solution in original post

Reply
0 Kudos
5 Replies
parmarr
VMware Employee
VMware Employee
Jump to solution

Hello,

Please see if the KB article below helps: https://kb.vmware.com/s/article/2052628

Sincerely, Rahul Parmar VMware Support Moderator
Reply
0 Kudos
desadi10
Enthusiast
Enthusiast
Jump to solution

Hi parmarr,

Thanks to help me, but i followed this guide and i had the problemas which i explained in my post.

Thanks so much.

Reply
0 Kudos
desadi10
Enthusiast
Enthusiast
Jump to solution

Finally, I managed to solve the problem.

I booted from the CD-ROM Drive, I entered in the rescue mode, I identified the disk containing the root file system, I selected the option to initialise the shell and I ran these commands:

  1. root@debian:~# grub-install /dev/sda
  2. root@debian:~# update-grub
  3. root@debian:~# reboot
Reply
0 Kudos
Ern1
Contributor
Contributor
Jump to solution

Hello,

This message just to confirm that the same issue is still present with Ubuntu 18.04LTS converting from Ovirt.

Maybe some VMware VCenter update has passed under the radar -we’re quite reticent on modification to vcenter / vsphere

since most of our dev daily activity and large part of our SaaS are hosted (flawlessly) on that cluster.

the remote option that an update for grub could stop the revenue stream and start an outgoing money stream for remote support is a real nightmare for any startupper.

Reply
0 Kudos
BizMac
Contributor
Contributor
Jump to solution

 

 

Thanks I followed your steps

Ubuntu 20.04 running nicely ....  🙂 

I booted from the CD-ROM Drive, I entered in the rescue mode, I identified the disk containing the root file system, I selected the option to initialise the shell and I ran these commands:

 

  1. root@debian:~# grub-install /dev/sda
  2. root@debian:~# update-grub
  3. root@debian:~# reboot
------ 
 
but in addition I had to edit /etc/fstab  and change the disk UUID 
 
steps Run 
 
 
1. blkid   provided the new UUiD
 
2. vi /etc/fstab
 
3. change the line /dev/sdXY with the UUID provide from step 1
 
4 update-grub
 
5. reboot
 
its up and running 
 
 
Reply
0 Kudos