rwh23
Enthusiast
Enthusiast

Unable to obtain hardware information for the selected machine

I'm trying to move some servers off of ESXi 4 to my local machine.

I've been able to Convert WHS, Linux VM, XP VM with no hassle.

Anytime I try to pick a Win7 VM (have 2 of them on the ESXi) I get the following message:

"Unable to obtain hardware information for the selected machine"

Am I missing something here? I haven't been able to find any info in regards to this.

0 Kudos
19 Replies
AndreTheGiant
Immortal
Immortal

Are you using the last converter (4.0.1)?

Are the VMs powered off?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
rwh23
Enthusiast
Enthusiast

Yes I am using the latest build (first thing I checked). 4.0.1 build 161434.

The VM's are off. This is for both 32 and 64 bit of Win 7. Just tried doing it to my 64bit FreeNAS and that didn't work either for some reason (same message).

0 Kudos
AndreTheGiant
Immortal
Immortal

Are you pointing the converter directly to the VM files or are you pointing to the ESX?

I suggest to point to the ESXi (choose vSpere source).

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
rwh23
Enthusiast
Enthusiast

I point it to the ESXi, put in the IP/user/pass and then it pulls up the Inventor list.

Then I click on the powered off VM and hit next. Thats when I get the message.

0 Kudos
AndreTheGiant
Immortal
Immortal

Very strange problem.

As a workaround, export the VM as a OVF template.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
rwh23
Enthusiast
Enthusiast

I'm not seeing this option in the converter. The Source type "VMware Infrastructure Virtual machine" is the only option I have that will connect to ESXi server.

0 Kudos
AndreTheGiant
Immortal
Immortal

This is a option of your vSphere Client when you are connected to the ESXi.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
rwh23
Enthusiast
Enthusiast

Ok thanks. Its pulling it off ESXi now. If I need to restore it to ESXi I can just the converter correct?

0 Kudos
AndreTheGiant
Immortal
Immortal

An OVF can be imported also without Converter (from the vSphere Client).

Is just a portable and open format.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
rwh23
Enthusiast
Enthusiast

Thank you sir for all the help.

0 Kudos
wildblue
Contributor
Contributor

Similar problem here - Windows 7 VM, converter gives the "Unable to obtain hardware information for the selected machine"

Log shows (I'm assuming this is the important part)

error 'ManagedMachineDataConnectionLogger'] Cannot query source HW info: vmodl.fault.SystemError

Export Wizard through VI Client gives 'Unable to determine Guest Operating System'

Changing the VM's settings and making the Operating System something other than Win 7 seems to work. Export to OVF works too. Guess those are your work arounds until the next verion of converter.

0 Kudos
DSeaman
Enthusiast
Enthusiast

Same problem here. I have a Server 2008 R2 VM on ESX 4.0 U1 and converter barfs with the unable to obtain hardware information error. I change the VM type to server 2003 R2 x64 and the error disappears. Clearly this is a converter bug.

Derek Seaman
0 Kudos
crazystic
Contributor
Contributor

Any idea on when this might get a fix? Are there any downsides to changing the OS and changing it back once converted?

Thanks.

0 Kudos
continuum
Immortal
Immortal

Are there any downsides to changing the OS and changing it back once converted?

No - don't worry




___________________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
spamthet
Contributor
Contributor

ESXi 4 Update 1

VMware Converter 4.01 build 161434

I have server 2008 R2 as an iso, so naturally I choose the machine type 2008 R2. INstalled the os, updated. I'm making a template so I want to then copy this and config for different purposes (sql, fs, etc). Next step, copy off and sysprep.

I go to converter (latest) and get the error. Works for my 2003 x86, 2003 x64 and xp sp3.

On a hunch, I changed the machine type to 2008 (not 2008 R2). Bingo.

Converter passed fine. I guess that even though I have a R2 DVD the converter is reading the os as regular 2008.

I'm suggesting that if you are having this prob and nothing else works, switch up the machine type (I'm not saying list 2003 as 2008, but just within the OS, try the options).

EDIT:

HOW TO: power the vm down in vsphere. Choose Edit settings. Options tab. Dropdown on bottom right. Switch it there

After you convert it, you will need to put it back to the original OS, cause it'll just fail to unknown OS which breaks the network drivers. Set back, reboot, install vmware tools, reboot. All set

0 Kudos
serinfbco
Enthusiast
Enthusiast

We had the same issue with vCenter Converter 4.3.0 build 292238.

After looking in the log, the problem was the name of the virtual disk that Converter was looking for. The converter was looking for "serveurdc4-000001.vmdk" and the real disk name is "scsi0-0-0-serveurdc4.vmdk". The problem was gone after rename it in the .VMX file by "scsi0-0-0-serveurdc4.vmdk".

0 Kudos
continuum
Immortal
Immortal

by changing the vmx you lost the contents of a snapshot - so one problem solved - a new one appeared 😉




_________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
rrader
Contributor
Contributor

Okay, I have it solved... Finally. If you haven't taken a snapshot of the machine you are trying to convert, do it. Then, you will be able to convert it. I don't know why but I didn't have to change the OS version or anything either.

Simple solution but annoying.

0 Kudos
ArbitraryY
Contributor
Contributor

Chaning the OS type didn't work for me, but creating a snapshot worked like a charm!  Thanks for sharing this info

0 Kudos