rickyxt
Contributor
Contributor

Ubuntu 10.04 V2V fails at 99%

Hello

I'm trying to convert a powered on virtual Ubuntu 10.04 machine from VMware server into vSphere 5.0. The process fails at 99% with the following error:

FAILED: An error occurred during the conversion: 'GrubInstaller::InstallGrub: /usr/lib/vmware-converter/installGrub.sh failed with return code: 1, and message: Installing GRUB2 on (hd0)... /usr/sbin/grub-setup: error:
no mapping exists for `hd0'. Error installing GRUB Error running vmware-updateGrub.sh through chroot into /mnt/p2v-src-root '

I've looked through the forums and seen this workaround

if [ $# -eq 1 -a "$1" = "-v" ] ; then

  echo "grub-install (GNU GRUB 1.99-12ubuntu5)"

  exit 0

fi


of editing the grub-installer.sh file. I tried this which didnt work but I dont think this is applicable to my issue as grub-install -v passes the correct format to converter:

grub-install (GNU GRUB 1.98-1ubuntu9)

I converted a Debian 5.0.8 VM from the same machine running VMware server without any issues. This VM seems to be using GRUB 1:

grub-install (GNU GRUB 0.97).

If I used the workaround using the above string would this work (or have any detrimental effect on the system)? So

if [ $# -eq 1 -a "$1" = "-v" ] ; then

  echo "grub-install (GNU GRUB 0.97)"

  exit 0

fi


I've also attached the log files from the failed job if any one has ideas. The issue is starting to drive me crazy!

Thanks in advance,

Richard

0 Kudos
6 Replies
rickyxt
Contributor
Contributor

I forgot to add that I'm using the Standalone converter 5.0.0 build 470252

0 Kudos
patanassov
VMware Employee
VMware Employee

Hello

The error in the log is:
2012-10-24T10:40:06.729Z [B2FC6B90 error 'task-1'] Reconfig failed with error GrubInstaller::InstallGrub: /usr/lib/vmware-converter/installGrub.sh failed with return code: 1, and message:
--> Installing GRUB2 on (hd0)...
--> /usr/sbin/grub-setup: error: no mapping exists for `hd0'.
--> Error installing GRUB

This is a GRUB error. I've found this googling for "no mapping exists":

http://uhowto.urbylog.info/post/10742342088/troubleshooting-grub2-no-mapping-exist-error

HTH

Plamen

0 Kudos
rickyxt
Contributor
Contributor

Hi Plamen

I tried that command with with no success, thanks for your suggestion.

As this VM is coming from Server 2.0 I'm going to power it off and use Converter to import it into ESXi

Hopefully this will work!

0 Kudos
ivivanov
VMware Employee
VMware Employee

Hm, Converter 5.0 had some issues with Server 2.0 sources :-(. If you cannot open the source VM you can try using Converter 4.3...

0 Kudos
rickyxt
Contributor
Contributor

Okay thanks for the heads up, failing all this i can use vmkfstools to import the vmdks from Server 2.0

0 Kudos
rickyxt
Contributor
Contributor

Okay just an update, i tried to cold convert the Server 2.0 files using Standalone 5.0 & 4.3 but the process failed straight away.

I ended up copying the VM files to a datastore, cloning the disk using vmkfstools -i command and then creating a new VM and attaching the disk.

Thanks for all your comments.

0 Kudos