Zanon
Contributor
Contributor

Missing "Select volumes to copy" in VMware vCenter Converter Standalone

Jump to solution

Missing Select volumes to copy for any Linux VM in VMware vCenter Converter Standalone.

I am trying to create compact copy of VM for template using VMware vCenter Converter Standalone.

  1. For Windows VM everything is ok.
  2. For any Linux machine, in drop down  "Data to copy type", only available option is "Copy all disks and maintain layout". Option   "Select volumes to copy" is missing.

Additional information:

  1. I am using trial vCenter 6.7 with trial esxi 6.7u2 .
  2. I don.t have any snapshots.
  3. I have tried with different VM HW versions 10-14 .
  4. In addition i have tried with VMworkstatin 15 pro.

Any idea ?

Regards ,

Zaro 

0 Kudos
1 Solution

Accepted Solutions
patanassov
VMware Employee
VMware Employee

Hi

Yes, this is a limitation by design

Only disk-based cloning is supported for Linux guest operating systems.

(Conversion Limitations for Virtual Machines)

The reason is that, under Windows, Converter mounts the volumes in order to get the necessary information about them. However Linux file systems are unknown to Converter (running under Windows) and it can't mount them.

A workaround might be to power on the VM and do a P2V conversion.

Regards,

Plamen

View solution in original post

0 Kudos
2 Replies
patanassov
VMware Employee
VMware Employee

Hi

Yes, this is a limitation by design

Only disk-based cloning is supported for Linux guest operating systems.

(Conversion Limitations for Virtual Machines)

The reason is that, under Windows, Converter mounts the volumes in order to get the necessary information about them. However Linux file systems are unknown to Converter (running under Windows) and it can't mount them.

A workaround might be to power on the VM and do a P2V conversion.

Regards,

Plamen

0 Kudos
Zanon
Contributor
Contributor

Aaaaaahhhh I see.

Missed this one.

VMWare is rich ecosystem and I was planning to use it as a base for my image bakery, Unfortunately this is limiting my options to pack down images. 

Ok i will look around for another solution.

Thank you

Zaro

0 Kudos