swdee
Contributor
Contributor

Linux conversion fails: Error: Unable to clone the volume mounted on '/boot' from '(Local IP)'.

Full error: FAILED: An error occurred during the conversion: 'Permission denied (publickey,gssapi-keyex,gssapi-with-mic). /bin/tar_1.28: This does not look like a tar archive /bin/tar_1.28:
Exiting with failure status due to previous errors /usr/lib/vmware-converter/bin/ssh -z -F /usr/lib/vmware-converter/ssh.conf root@172.16.0.14 -i /usr/lib/vmware-converter/helper.pem -p 22 " tar --one-file-system --sparse -C '/boot' -cf - ." | /bin/tar_1.28 --numeric-owner --delay-directory-restore -C '/mnt/p2v-src-root/boot' -y -xf - (return code 2)'

Converting from Centos 7 to VMware. Can someone help please thanks

0 Kudos
4 Replies
patanassov
VMware Employee
VMware Employee

This looks like some misconfiguration of SSH connectivity on the source machine. Google for "publickey,gssapi-keyex,gssapi-with-mic" there are more than one result that looks promising.

HTH,

Plamen

0 Kudos
swdee
Contributor
Contributor

Thanks but it looks like Converter has a problem with logging in using a public key. This method kept stopping at 3% with the above message.

Setting up a root password, allowing passwordAuthentication (which I normaly don't want to do), and logging in with that works now, but now it's stuck at 92% "Starting to clone /var/log".

That folder is only 54MB, but it's been stuck at that for half an hour now, "brilliant" :S

I thought this soiftware is supposed to make this task easier

0 Kudos
swdee
Contributor
Contributor

I had to unselect the offending folder "/var/log", and it completed successsfully, then I re-created the /var/log directories/files manually.

Bizzare!

0 Kudos
patanassov
VMware Employee
VMware Employee

It's good it worked.

Converter uses 'tar' for file transfer (you can see the exact syntax in the error message). There is something peculiar in the /var/log directory that interferes with tar. I vaguely remember similar issues have occurred before but don't remember what it was exactly.

0 Kudos