VMware Employee
VMware Employee

Increasing the cloning performance

There have been many complaints about transfer rate degradation in Converter 5.0.

Converter uses NFC (a proprietary VMware protocol) for cloning to managed destination. Security has been enhanced in Converter 5.0 by encrypting the data transfer. Unfortunately this has caused a more severe performance degradation than expected.
Switching off SSL encryption is a way to work around this issue. Here is how it is done:

  1. Open the converter-worker.xml configuration file. It is located in "%ALLUSERSPROFILE%\VMware\VMware vCenter Converter Standalone" folder for Windows Vista or newer or in "%ALLUSERSPROFILE%\Application Data\VMware\VMware vCenter Converter Standalone" for older Windows versions.
  2. Set the key Config/nfc/useSsl to false and save the configuration file.
  3. Restart "VMware vCenter Converter Standalone Worker" service.

I.e. it should look like:

    ...
    <nfc>
       <readTimeoutMs>120000</readTimeoutMs>
       <useSsl>false</useSsl>
    ...

75 Replies
Virtuoso
Virtuoso

Thanks for sharing. BTW, how fast we can expect when we disabled SSL?

http://www.no-x.org
0 Kudos
VMware Employee
VMware Employee

A performance increase of 2 to 5 times has been reported, sometimes even more.

0 Kudos
Contributor
Contributor

Great infoSmiley Happy

Blog: www.vperformance.org
0 Kudos
Contributor
Contributor

Dear all

I'm running Converter 5 under Windows XP and there is no converter-worker.xml

configuration file. I'm confused now.

Regards, Rainer

0 Kudos
VMware Employee
VMware Employee

It should be under %ALLUSERSPROFILE%\Application Data\VMware\VMware vCenter Converter Standalone directory on the machine where Converter server is installed. If you paste this path in "Run" dialog box it should open at the right location.

0 Kudos
Contributor
Contributor

This cut my convert time from 6 hrs, 28 minutes to 1 hr, 36 minutes!

0 Kudos
Contributor
Contributor

Thank you for this tip.  I was trying to convert a 500GB system, and it was predicting over 26 days to complete.  After 3 days it only moved to 3%.  Since I made this change and started over,  the estimated time went down to just over 10 hours, and I am already at 45% since this morning.

0 Kudos
Contributor
Contributor

I'm using Converter 5 and noticed the same problem. Disabling ssl didn't help me much, the problem I noticed was file vs.block transfer for the disks. If you're having slow transfer speeds, make sure you aren't doing file transfers for the disks. I had a server with C: and 😧 disks, I wanted to change the size of the disks during P2V, but when you do that Converter changes the transfer from block to file and it takes FOREVER to finish. My compromise was to change only the C: during P2V (thereby changing from block to file) and leave my larger 😧 alone (leaving it as block). This worked great - the P2V took only a few hours instead of a few days. I will be resizing the 😧 after P2V is completed.

-Mike

Hot Shot
Hot Shot

I agree that disabling SSL does actually seem to help considerably, thank you patanassov!

I also try to guide folks to this helpful discussion over here as well:

http://tinkertry.com/vmwareconverterspeedup

12-16-2011 11-11-10 AM.png

TinkerTry.com
0 Kudos
Contributor
Contributor

Amazing. Thanks a ton for this information. My mysteriously slow conversion performance was estimating over 20 hours, now down to under 2 hours. Yikes... VMware, are you listening?

0 Kudos
Enthusiast
Enthusiast

Improved performance considerably. I used XML Notepad 2007 (http://www.microsoft.com/download/en/details.aspx?id=7973) to edit the XML file.

0 Kudos
Immortal
Immortal

after this modification Converter 5 will no longer start on my 2k3 host - reverting the xml to original does not help either

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
VMware Employee
VMware Employee

Really? Is there a chance that by mistake you have created a malformed XML while editing the file? This option is ignored until the actual data transfer connection is established, so I would be very surprised if it breaks converter startup. It is even more strange that reverting back to the original file doesn't fix things.

0 Kudos
Immortal
Immortal

I am as surprised as you are.
I made copies of the original file and put the originals back when I noticed the problem.
The services and the vmware-converter.exe start but no GUI appears.
Next I uninstalled and re-installed version 5 ... no luck.

Thanks god I can use Converter as well from another host so I dont need it on this one.

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
VMware Employee
VMware Employee

Do you have converter.exe process? This should be the GUI. If it is running, you can try to kill it and start it again. It has a logic for not allowing a second instance of the GUI to be started, but just activate the old one. If it is hanging for some reason, you cannot run another instance.

0 Kudos
VMware Employee
VMware Employee

One more thing - do you think for some reason there is a chance that GUI is initially displayed off the screen? I mean at some weird position which makes it invisible...

0 Kudos
Immortal
Immortal

in taskmanager I see converter.exe under the processes tab - but not under applications - so I doubt that it is displayed off-screen ?

could I reset that similar to settings in pereferences.ini for Workstation

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
VMware Employee
VMware Employee

Most likely it is not off-screen if it is not visible under applications. What if you just terminate converter.exe and restart it? Is it entering the same mode again? Otherwise there should be a converter-client.ini file which holds the UI settings under %USERPROFILE%\Local Settings\Application Data\VMware\VMware vCenter Converter Standalone Client - you can just delete it and it would reset the client to default values.

0 Kudos
Immortal
Immortal

Bingo !
that was it - deleting the settings.ini made the GUI re-appear.
I attach it in case it is helpful

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos