HyperV VM Conversion Issues

Hey all,

So I'm having a slight issue that I've not seen or experienced before with the converter tool.

I've made sure I've disabled UAC and made the appropriate GPO and updated the host file to make sure there's no DNS issues.

I'm using local Administrator account on the HyperV Host and the administrator@vsphere.local for the vCenter cluster.

A little more info on the topology


2019 HyperV Cluster using CSV storage


Esxi 7.0d and vCenter Server 7.0b

Essentially I can create the job OK and it creates the VM on the VMware and then sits at 1% for around ~5mins and then fails with a "A file I/O error occurred while accessing"

I can SMB to the HyperV host and then into the Clustered CSV folder and copy the VM's VHD at around 800MBps from the server with vCenter Converter installed on it..

I just can't put my finger on the issue.

Thanks again


0 Kudos
3 Replies

hey. hope you are doing fine

Are your running converter from the Hyper-V VM?

Have you tried logging in to vCenter and accepting certificates?
Also, have you checked this:

VMware Knowledge Base

0 Kudos

Hi thanks for the the reply..

As per that document I had already put in all the IP/Host-names into hosts file of the server running vCenter Converter.

Also, I'm running the converter off a separate machine.

Just to clarify, what do you mean specifically around "Have you tried logging in to vCenter and accepting certificates?"

I've logged into the vCenter many times and I cant find any issues with the certificate configuration...

0 Kudos

Hey QuazzieM​,

The last lines shows the next:

--> The remote host certificate has these problems:


--> * A certificate in the host's chain is based on an untrusted root.


--> * self signed certificate in certificate chain)

And this certificate issue is related with the vCenter one. So to not get involved in certificate you can just download all the certificates and their certificate chain including the CRL files and imported in the Trusted Root Certificate Authorities of the Windows Server where you have the Converter Standalone installed.

  1. From a client system Web browser, go to the base URL of the vCenter Server system or the vCenter Server Virtual Appliance without appending port numbers or 'vsphere-client' extension.

    For example:

    Note: Direct URL to download the Certificate is https://vCenter_FQDN/certs/download.zip (Example - https://vcenter.domain.com/certs/download.zip). From Linux machines, wget command can be used to download the Certificates, Example - "wget https://vcenter.domain.com/certs/download.zip". Screenshots of both methods available in Related Information section of this KB.
  2. Click the Download trusted root CA certificates link at the bottom of the grey box on the right and download the file.
  3. Change the extension of the file to .zip.
    The file is a ZIP file of all root certificates and all CRLs in the VMware Endpoint Certificate Store (VECS).
  4. Extract the contents of the ZIP file.
    The result is a .certs folder that contains two types of files. Files with a number as the extension (.0, .1, and so on) are root certificates. Files with an extension that starts with an r (.r0,. r1, and so on) are CRL files associated with a certificate.

This is the KB if you want to know more insight: VMware Knowledge Base

Let us know if that works for you.

0 Kudos