dbunch2008
Contributor
Contributor

FAILED: Unable to create a VSS snapshot of the source volume(s). Error code: 2147754754 (0x80042302).

I am trying to convert a Windows 2008 R2 Server to a n ESX 4.0 server.

I have also tried converting it to my ESXi test server.

Using Vmware converter 4.01 build - 161434

Everytime, I get the following error:

FAILED: Unable to create a VSS snapshot of the source volume(s). Error code:

2147754754 (0x80042302).

0 Kudos
5 Replies
dbunch2008
Contributor
Contributor

Anyone...

Is 2008 R2 even supported yet...

0 Kudos
joeymartin
Contributor
Contributor

We have the same issue. I have been tearing my hair out as to what it could be. I have tried the following in addition to the Converter.

Converted the server with Symantec System Recover, then converted the symantec image with Vmware Converter. This resulted in a useable image but could not boot. Windows 2008 R2 creates a 100mb partition for Bitlocker at the beginning of the drive during installation which i thought was creating the issue. I removed the partition and then made the main C:\ bootable. I could get Windows 2008 startup screen but it ultimately freezes at bluescreen and keeps rebooting. I thought this may have to do with the work I did did on removing the bitlocker partition but no...I built another Win2k8 R2 server in test and removed the 100 mb partition and recreated my bootfiles and Win2k8 booted fine.

Can anyone chime in if they have had success p2v with Win2k8r2? I have not tried a cold p2v yet, just hot.

Joe

0 Kudos
grafsolutions
Contributor
Contributor

I've run into this with Converter 4.1 converting a phisical Server2008X64-R2 into ESXi 4.0 U1. The event viewer logs Event IDs 22 and 8193 on the source machine.

EventID 22:

Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and Name IVssCoordinatorEx2 is 0x80040154, Class not registered.

Operation: Instantiating VSS server

Which leads me to

(summary: check that COM+ Event is started and test System Restore and manual shadow copy test)

Event ID 8193:

Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80040154, Class not registered.

Operation: Instantiating VSS server

leads me to

(summary: check that Volume Shadow Copy Service is set to Manual)

Both recommended checks work fine with no errors in the Event Log. My suspicion is a 32-bit component of Converter is trying to run VSS on x64, but I don't have anything to back it up. I'm going to keep digging, just wanted to let people know this happens with Server 2008 R2 x64 in addition to Windows 7.

Posted this message:

http://communities.vmware.com/message/1522094

http://communities.vmware.com/message/1396780

EDIT:

potential workaround here, it worked for me:

http://communities.vmware.com/message/1522094

Message was edited by: grafsolutions

0 Kudos
anh2lua
Enthusiast
Enthusiast

I am able to convert a Server 2008 R2 (R2 is 64-bit Only) Standard to a different VM (this is V2V) using Converter 4.2.

This packages comes with the vSphere 4.1 VirtualCenter. The folder is under Converter, with three files. I installed VMware-Converter.exe (dated 5/14/2010) on the VIRTUALCENTER Server and the VMware-Converter-Client.exe on my PC where vSphere Client is installed.

I shut down the source VM.

Right click on the DataCenter in vSphere Client and select Import Machine. I went through the wizard and it converted the virtual machine to another virtual machine just fine.

The reason I am doing this today is because the virtual machine was created with a wrong name so I converted to get the correct name in VMware and the correct folder name for the VMDK files.

If you are still having problems converting Server 2008 R2 Server, you can use this method. It supports Server 2008 R2.

0 Kudos
ibitebcareful
Contributor
Contributor

I know this is a really old post; however, I still ran into this issue many years later and have found a solution.  I was converting a 32 bit Windows 7 machine that was already a VM - I simply wanted to reduce the system volume's size.  It was too big and was making cloning take longer than it should.

The solution that worked for me is not my work.  I take no credit for it, nor do I take any responsibility for what it does.  I blindly followed these instructions and it worked perfectly for me.  I will provide a link to the original web site AND a copy of the instructions in case that website no longer exists one day.

I only followed these steps thru part 6.  I did not need to go any further after that.

Good Luck.  Hope this helps someone as it helped me.

I'd like to say Thank you to: STC-KevinH who appears to be the original author.

The website as of 12-19-2014 can be found here: http://www.storagecraft.com/support/kb/article/32

Below here is the information copied directly from the website I just listed above.

Problem:

This article details how to troubleshoot VSS errors.

Cause:

Backups may be failing due to Microsoft's VSS framework being in a bad state. This could be caused by clashes between ShadowProtect and other programs trying to use VSS at the same time. Only one writer can use VSS at any given time (See article on "Understanding VSS and ShadowProtect"). Another possible cause for VSS errors is that the necessary system services may have been mistakenly disabled.

Resolution:

If Microsoft's VSS framework and/or some of the VSS writers are in a bad state, you need to clean the system up before your backups will work.

Part 1:

    • Cancel any running backup jobs
    • End the ShadowProtectSVC process if necessary. (See Part 2, #3)

Part 2:Go to Start | Run and enter "services.msc" - Click OK.

    1. Navigate to MS Software Shadow Copy Provider. Startup Type should be set to "Manual" if it is not already.
    2. Navigate to Volume Shadow Copy. Startup Type should be set to "Manual"
    3. Navigate to ShadowProtect Service. Startup Type should be set to "Automatic"
    4. Navigate to StorageCraft Shadow Copy Provider. Startup type should be set to "Automatic"

Part 3:Next, you need to delete all greyed-out devices (non-present "Storage Volume shadow copies" devices) possibly left over from previous snapshots.

    1. Run the command prompt as Administrator
    2. Run vssadmin delete shadows /all and select yes to delete all
    3. Run Set devmgr_show_nonpresent_devices=1
    4. Run devmgmt.msc this will open the device manager with the option to show non-present devices
    5. From "Device Manager" select "View | Show hidden devices"
    6. Scroll down until you see "Storage volume shadow copies" in the list. If it is not listed go to step 5.  Under "Storage volume shadow copies" a listing called "Generic volume shadow copies" will be shown. The icon next to them will be greyed-out.

NOTE:

These can only be removed one at a time.  Select one from the list, right click, and then choose uninstall.  Repeat this process until all greyed-out devices are removed.  If there are devices still listed which are not greyed-out then the vssadmin delete shadows /all did not work properly. Try running it again.Part 4:Do not delete any of the Storage Volumes.Part 5:

    1. Go to Start | Run.. and enter "cmd" - Click OK.
    2. From the command line run the following command: vssadmin list writers. This will show you the state of any VSS-aware applications.
    3. If any of the VSS-Aware applications are in an unstable state you need to troubleshoot the individual writer and error,ORFor Server 2003 or Earlier ONLY: Manually reset the state of the VSS Writers. - These steps are at the bottom of the page.

Part 6:Reboot.Part 7:After you finish rebooting:

    1. Click Start | Run and type "cmd"
    2. At the C:\ prompt type vssadmin list writers (note: these services should all be in a Stable state)
    3. If you run the vssadmin list shadows command, no existing shadow copies should be shown.

ConclusionFollowing the steps listed above should clean the system up enough for you to start using ShadowProtect. Proper VSS interaction is very complex and many backup products leave various components (especially VSS writers) in bad states. This can cause problems for other backup products. If you are using any other backup products, it's very likely that they will corrupt the states of various VSS components.  You must always ensure that ShadowProtect does not run at the same time as other backup software such as Backup Exec, Acronis, etc.

Additional Information:

Related articles:Understanding VSS and ShadowProtect - gives more basic information on what VSS is, how it works and which Operating Systems and applications are VSS aware.
Reregistering VSS steps for Server 2003: (Also referenced in the article labled: VSS Backups fail with a VSS error of 0x8000FFFF)

Warning From Microsoft in reference to the information below:

MS VSS WarningTo attempt to reregister/reset VSS follow Microsoft's  support knowledge base article listed at:

Error message when you run the "vssadmin list writers" command on a Windows Server 2003-based comput...

Scroll down to the section labled:

"Let me fix it myself"

Follow this section of Microsoft's document.  .

NOTE:

    • On 64bit system's the path to some DLL's will need to be entered differently because they reside in the SysWOW64 section of the WINDOWS directory.  e.g.
Net stop vss
Net stop swprv
regsvr32.exe /i %windir%\system32\eventcls.dll
regsvr32.exe /i %windir%\system32\swprv.dll
regsvr32.exe %windir%\system32\vssui.dll
regsvr32.exe %windir%\SysWOW64\vss_ps.dll
regsvr32.exe %windir%\SysWOW64\msxml.dll
regsvr32.exe %windir%\SysWOW64\msxml2.dll
regsvr32.exe %windir%\SysWOW64\msxml3.dll
regsvr32.exe %windir%\SysWOW64\msxml4.dll
regsvr32.exe %windir%\SysWOW64\ole32.dll
regsvr32.exe %windir%\SysWOW64\oleaut32.dll
regsvr32.exe %windir%\SysWOW64\es.dll
regsvr32.exe %windir%\SysWOW64\comsvcs.dll
vssvc /register
    • You may not have the msxml4.dll installed.  Though they are not required, If you are missing msxml4.dll or msxml4r.dll (they should be in your system32 directory) and want to have them installed, then you can Windows Update and update Explorer. and then rerun the command for these DLLs after they are in your system32 directory.
    • After reboot you should run the following command and check if all the VSS writers states are good/stable:
"C:\> vssadmin list writers"
    • And this command should show no existing shadow copies:
"C:\> vssadmin list shadows"
    • At this point things should be cleaned up enough for you to start using ShadowProtect. Proper VSS interaction is a very complex affair and many backup products (including,Microsoft's own backup softwares) can leave various components, especially VSS writers, in bad states.  This can cause problems for other backup products. So if you are using any other backup products, it's very possible that they may continue to damage the states of various VSS components.
0 Kudos