Zack_nut
Contributor
Contributor

FAILED: An Error occurred during the conversion: 'Platform-specific error 2338'

I'm trying to P2V a Windows 2003 Server into my vCenter 5.5 enviroment.

Using Converter Standalone version 5.1.0

Conversion stop at 1 % and error show :

FAILED: An Error occurred during the conversion: 'Platform-specific error 2338'

below log from worker :

2015-03-12T17:34:26.084+08:00 [00852 info 'ThreadPool'] Thread delisted

2015-03-12T17:34:26.084+08:00 [04008 info 'ThreadPool'] Thread enlisted

2015-03-12T17:34:26.084+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.084+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.084+08:00 [01396 info 'Default'] MNTAPI: Mounted volume \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.099+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.115+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.115+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.115+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.131+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.131+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.131+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.131+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.146+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.146+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\ FS:<>

2015-03-12T17:34:26.146+08:00 [01396 warning 'Default'] ERROR 1005 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.146+08:00 [01396 warning 'Default'] ERROR 50 while call FSCTL_QUERY_FILE_SYSTEM_RECOGNITION for \\.\vstor2-mntapi20-shared-99F750C4000010000000000012000000\

2015-03-12T17:34:26.146+08:00 [01396 warning 'Default'] ERROR 0 while call GetVolumeInformation for \\.\vstor2-mntapi20-shared-99

Appreciate your help!

8 Replies
POCEH
VMware Employee
VMware Employee

Could you upload log-bundle? These are expected 'errors' and they are not linked to your problem.

From the other hand stop at 1% for Windows conversions means that your *source* machine do not have a connection to ESX at port 902 - check this first.

Zack_nut
Contributor
Contributor

Hi Poceh,

What kind of log bundle you need? i can't share too much thing as company privacy , but i will try my best to get whatever you need.

Thank.:smileylaugh:

0 Kudos
patanassov
VMware Employee
VMware Employee

Hello

If you are running converter on the machine you want to convert (i.e. 'this local machine' conversion), then the worker log is the place to look. It would be best if you can paste all the lines relevant to that conversion; if not - look for other 'error' and 'warning' level lines. The ones you provide are only warnings (... [01396 warning 'Default'] ...)

If OTOH, you are converting a remote machine, the relevant log is the agent's one. It can be found on the source machine.

HTH

Zack_nut
Contributor
Contributor

Dear Plamen,

I have export out the Job, Inside there were 3 type of file :

1) Conveter-gui-20.log.gz    (20-28)

2) vmware-converter-server-1.log.gz  (1-8)

3) worker -diagnostics-task-3-gon.zip

Which one you would like me to post here?

Thank.

Zack

0 Kudos
patanassov
VMware Employee
VMware Employee

Hi Zack

The last one, worker-diagnostics-task-3-gon.zip, is the right one.

Regards

Plamen

0 Kudos
Zack_nut
Contributor
Contributor

Hi Plamen,

I am not allow to update log file into here as it will violate the company security policy , thank and appreciate for your help so far.

Zack

0 Kudos
patanassov
VMware Employee
VMware Employee

Alternatives are:

- send it in a private message

- open it on your own and post error and warning lines that are relevant based on time of failure

HTH

Plamen

0 Kudos
Zack_nut
Contributor
Contributor

Hi Plamen,

Finally the problem solved after changed the IP for VMkernel, i am not sure what wrong with that IP , suspect something block it from connect to Conveter, now i am able to telnet VMkernal from my Physical server for port 443 and 902.

Thanks for your help so far and really appreciate it.

Zack

0 Kudos