Phaethar
Contributor
Contributor

Conversion starts, then fails at 3% with network unreachable error.

As the subject notes, I'm trying to test out converting some physical systems to VMWare using Converter 5.5 Standalone. Running it on a Windows 7 system, and I'm attempting to convert a Linux system that's running CentOS6. The wizard goes through smooth, and the source information is pulls down all looks correct. The conversion starts, connects to the helper, and starts formatting the destination. Then, at 3%, the conversion fails with this error:

FAILED: A general system error occurred: connect (`192.168.8.232'): Network is unreachable connect (`192.168.8.232'): Network is unreachable connect (`192.168.8.232'):

Network is unreachable Network error. Host 192.168.8.232 key can't be retrieved. (return code 2)

192.168.8.232 in this case is the source system. It's up and running just fine, and I maintain a SSH connection the entire time, but for some reason this error keeps coming up and I'm not sure why.

The conversion prompts for the key initially when the process starts, so I'm not sure if the "key can't be retrieved" error is as result of the "network unrechable" error, or if the key error comes first before the network error. Either way, network connectivity is fine, and I'm stumped as to why it keeps failing at this point. Any thoughts?

0 Kudos
4 Replies
ivivanov
VMware Employee
VMware Employee

You can try using Converter 5.5.1. There was a problem with SSH keys when the SSH server was configured to use DSA keys - Converter 5.5 was working correctly only with RSA keys. You can look at Re: converter error "Host <ip> key can't be retrieved.for more information. Or you can reconfigure your SSH server to use RSA keys.

Another possible reason is the network connectivity - you should be able to connect to the source server *both* from the Converter Server machine *and* from the destination VM. If the destination machine cannot connect to the source because of some networking issues (e. g. hosts.allow/deny, firewalls) then this message is displayed (not very intuitive, I admit).

__________
It is worse!
0 Kudos
fourg
Contributor
Contributor

I ran into this issue with the latest 5.5.2 vConverter and after confirming my SSH config was using default settings and had both a DSA and RSA key, I found that the issue was DNS related.  When I entered the IP address of the source host rather than the FQDN it then worked.  Checking the DNS settings on the ESXi host I was targeting the conversion to I found it was missing a DNS server to use.

0 Kudos
MattiasN81
Hot Shot
Hot Shot

Little late but i had the exact same problem.

Tried all other solutions with host.allow, disable firewall etc, etc

My solution was to disable IPv6 in converter helper and set IP address to static.

VMware Certified Professional 6 - DCV VMware VTSP Software Defined Storage Dell Blade Server Solutions - EMEA Certified Dell PowerEdge Server Solutions - EMEA Certfied Dell Certified Storage Deployment Professional Dell EMC Proven Professional If you found my answers useful please consider marking them as Helpful or Correct
0 Kudos
RahulVmware1985
Enthusiast
Enthusiast

See if this helps you

P2V Percentages:

1%VSS, Remove multiple   VSS-providers from registry (Link)
1%Unable to start the   change tracking driver, User Account Control (Link)
2%Network issue, Set   speed/duplex auto/auto (Link)
2-96%Multiple,   IP/DNS/Hardware (Link   Link   Link)
3%DNS issue, set DNS   suffix (Link)
3-92%Reducing disk volume   size, Checkdisk (Link)
95-99%Fails at reconfiguration,   Missing files or drivers(Link)
96%Unable to find the   system volume, Windows Boot manager (Link   Link)
97%No Active   Partitions, Break software mirror (Link)
97-99%Inaccessible_boot_device,   Driver issue (Link   Link)
98%Unable to create,   3GB switch boot.ini (Link)
99%Unable to determine   guest OS, boot.ini (Link)
CommonLink

Regards

Rahul

0 Kudos