jpotter2
Contributor
Contributor

Cannot Convert MS2K3R2 Std. Svr. when selecting more than one drive

I am using VMWare Converter 3.0.0 build 39557 (starter) on a Dell 2650 Dual CPU server running MS 2003 R2 SP2 Std. server, and can successfully hot clone the server if I select only the C: drive. The server also has an F: drive and a G: drive (the Dell hidden partiton has never been selected).

When I select C: and F: (the F: drive is a BASIC drive, partitioned on the same physical drive with the C: drive), the converter completes Step 1, and Step2, but while in Step 3 (Preparing target virtual machine) after running for about 18 min, it wil fail with: "Unkown error returned by MVware Converter Agent".

In the vmware-converter-0.log file, its lists serveral failures/errors:

\[#1] \[2007-04-10 11:24:18.677 'App' 440 info] Impersonating user Administrator in session 3CA04CA0-7B67-4C7F-91B5-43C0BDA85DC9

\[#1] \[2007-04-10 11:24:18.677 'Vmsvc' 440 info] VMServices Plugin initializing

\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] Msg_Reset:

\[#1] \[msg.dictionary.load.statFailed] Unable to get information about file "C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\config.ini": The system cannot find the file specified.

\[#1] \----


\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] PREF Optional preferences file not found at C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\config.ini. Using default values.

\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] Msg_Reset:

\[#1] \[msg.dictionary.load.statFailed] Unable to get information about file "C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\settings.ini": The system cannot find the file specified.

\[#1] \----


\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] PREF Optional preferences file not found at C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\settings.ini. Using default values.

\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] Msg_Reset:

\[#1] \[msg.dictionary.load.statFailed] Unable to get information about file "C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\config.ini": The system cannot find the file specified.

\[#1] \----


\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] PREF Optional preferences file not found at C:\Documents and Settings\All Users\Application Data\VMware\VMware Converter\config.ini. Using default values.

\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] Msg_Reset:

\[#1] \[msg.dictionary.load.statFailed] Unable to get information about file "C:\Documents and Settings\Administrator\Application Data\VMware\config.ini": The system cannot find the file specified.

\[#1] \----


\[#1] \[2007-04-10 11:24:18.693 'App' 440 info] \[,0] PREF Optional preferences file not found at C:\Documents and Settings\Administrator\Application Data\VMware\config.ini. Using default values.

\[#1] \[2007-04-10 11:24:18.724 'App' 440 info] \[,0] Msg_Reset:

\[#1] \[msg.dictionary.load.statFailed] Unable to get information about file "C:\Documents and Settings\Administrator\Application Data\VMware\preferences.ini": The system cannot find the file specified.

\[#1] \----


\[#1] \[2007-04-10 11:24:18.724 'App' 440 info] \[,0] PREF Failed to load user preferences.

\[#1] \[2007-04-10 11:24:18.724 'App' 440 info] \[,0] Using system libcrypto, version 90709F

\[#1] \[2007-04-10 11:24:18.834 'App' 440 warning] \[,0] VMHS: Failed to load vmnetMgr.dll

\[#1] \[2007-04-10 11:24:18.834 'VmMisc' 440 info] Max supported virtual machines: 1200

\[??] \[2007-04-10 11:24:18.834 'App' 744 info] \[,0] HOSTINFO 585222674394 @ 2192940000Hz -> 0 @ 1000000Hz

\[??] \[2007-04-10 11:24:18.834 'App' 744 info] \[,0] HOSTINFO ((x * 4011096072) >> 43) + -266866706

\[#1] \[2007-04-10 11:24:18.865 'App' 636 info] \[vmImporter,133] Entering UFAD at QuerySourceInfo

\[#1] \[2007-04-10 11:24:18.865 'App' 636 verbose] \[vmImporter,134] source:

\[??] \[2007-04-10 11:24:18.897 'App' 152 info] \[stub,42] HostDeviceInfo: Failed to enumerate host parallel ports via the registry. Could not open device map parallel port registry key.

\[??] \[2007-04-10 11:24:20.072 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:24:20.072 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ Volume's disk number

\[??] \[2007-04-10 11:24:20.072 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumePartitionInfo] StartingOffset.QuadPart of volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not equal to the disk extent's

\[#1] \[2007-04-10 11:24:20.072 'App' 568 info] \[attachedComputerWin32,159] \[GetVolumeInfo] Cannot get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ volume's legacy partition info. The partition number is 36288858

\[??] \[2007-04-10 11:24:20.072 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:24:20.072 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ Volume's disk number

\[??] \[2007-04-10 11:24:20.276 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:24:20.276 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ Volume's disk number

\[??] \[2007-04-10 11:24:20.276 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumePartitionInfo] StartingOffset.QuadPart of volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not equal to the disk extent's

\[#1] \[2007-04-10 11:24:20.276 'App' 636 info] \[attachedComputerWin32,159] \[GetVolumeInfo] Cannot get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ volume's legacy partition info. The partition number is 36288858

\[??] \[2007-04-10 11:24:20.276 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:24:20.276 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ Volume's disk number

\[??] \[2007-04-10 11:24:20.339 'App' 152 info] \[stub,42] HostDeviceInfo: Failed to enumerate host parallel ports via the registry. Could not open device map parallel port registry key.

\[??] \[2007-04-10 11:25:12.387 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:12.387 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ Volume's disk number

\[??] \[2007-04-10 11:25:12.387 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumePartitionInfo] StartingOffset.QuadPart of volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not equal to the disk extent's

\[#1] \[2007-04-10 11:25:12.387 'App' 828 info] \[attachedComputerWin32,159] \[GetVolumeInfo] Cannot get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ volume's legacy partition info. The partition number is 36288858

\[??] \[2007-04-10 11:25:12.387 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:12.387 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ Volume's disk number

\[??] \[2007-04-10 11:25:21.888 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:21.888 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ Volume's disk number

\[??] \[2007-04-10 11:25:21.888 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumePartitionInfo] StartingOffset.QuadPart of volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not equal to the disk extent's

\[#1] \[2007-04-10 11:25:21.888 'App' 188 info] \[attachedComputerWin32,159] \[GetVolumeInfo] Cannot get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ volume's legacy partition info. The partition number is 36288858

\[??] \[2007-04-10 11:25:21.888 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:21.888 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ Volume's disk number

\[#1] \[2007-04-10 11:25:21.888 'App' 188 verbose] \[diskSet,196] 4 volumes found

\[??] \[2007-04-10 11:25:33.630 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:33.630 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{6d05520a-4afa-11db-a443-806e6f6e6963}\ Volume's disk number

\[??] \[2007-04-10 11:25:33.630 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumePartitionInfo] StartingOffset.QuadPart of volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not equal to the disk extent's

\[#2] \[2007-04-10 11:25:33.630 'App' 148 info] \[attachedComputerWin32,159] \[GetVolumeInfo] Cannot get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ volume's legacy partition info. The partition number is 36288858

\[??] \[2007-04-10 11:25:33.630 'App' 152 info] \[stub,42] Info\[Windisk_GetVolumeDeviceNumber]: IOCTL_GET_STORAGE_DEVICE_NUMBER for volume
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ is not supported .... Trying NT method.

\[??] \[2007-04-10 11:25:33.630 'App' 152 info] \[stub,42] Error\[Windisk_GetVolumeDeviceNumber]:Failed to get
?\Volume\{3e655813-edd9-4f1c-ba18-0b70002bd9b8}\ Volume's disk number

\[#2] \[2007-04-10 11:25:33.630 'App' 148 verbose] \[diskSet,196] 4 volumes found

\[#2] \[2007-04-10 11:25:52.458 'App' 828 info] \[volumeMappingInfoBuilder,168] Source Volume 2 has no partition information set

\[#2] \[2007-04-10 11:25:52.458 'App' 828 info] \[volumeMappingInfoBuilder,178] Failed to get Windows unique ID

\[#2] \[2007-04-10 11:43:59.420 'App' 828 verbose] \[volumeProxy,53] Successfully connected to remote volume.

\[#2] \[2007-04-10 11:43:59.624 'App' 828 error] \[reconfigurationTransaction,82] Can't create undo folder

\[#2] \[2007-04-10 11:43:59.624 'App' 828 info] \[utils,153] Cleaning up temp directory C:\WINDOWS\TEMP\vmware-temp\vmware-SYSTEM\sysReconfig ...

\[#2] \[2007-04-10 11:43:59.624 'App' 828 error] \[imageProcessingTaskImpl,552] UfaSysReconfig::task\{1}::task\{9}: Image processing task has failed with MethodFault::Exception: sysimage.fault.FileCreateError

\[#2] \[2007-04-10 11:43:59.624 'App' 828 verbose] \[imageProcessingTaskImpl,154] UfaSysReconfig::task\{1}::task\{9}: SetState to error

\[#2] \[2007-04-10 11:43:59.624 'App' 828 verbose] \[imageProcessingTaskWrapper,886] Remote task UfaSysReconfig::task\{1}::task\{9} completed

\[#2] \[2007-04-10 11:43:59.624 'App' 828 verbose] \[imageProcessingTaskImpl,123] UfaSysReconfig::task\{1}::task\{9} being destroyed

\[#2] \[2007-04-10 11:43:59.624 'App' 636 error] \[imageProcessingTaskStep,425] VmiReconfigTask::task\{8} step "Reconfigure VM" failed

\[#2] \[2007-04-10 11:43:59.624 'App' 636 verbose] \[imageProcessingTaskWrapper,1117] Reporting image processing task failure for task UfaSysReconfig::task\{1}::task\{9}

\[#2] \[2007-04-10 11:43:59.624 'App' 636 error] \[imageProcessingTaskWrapper,1124] ImageProcessingTask FAILED. Fault name: sysimage.fault.FileCreateError

\[#2] \[2007-04-10 11:43:59.624 'managedImportSource' 636 verbose] Shutting down VMDB service...

\[#2] \[2007-04-10 11:44:00.108 'App' 636 error] \[vmiReconfigTask,136] Reconfiguration failed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 verbose] \[imageProcessingTaskStep,307] VmiReconfigTask::task\{8} step "Reconfigure VM" 100% completed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 info] \[imageProcessingTaskStep,196] VmiReconfigTask::task\{8} step "Reconfigure VM" destroyed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 error] \[imageProcessingTaskImpl,552] VmiReconfigTask::task\{8}: Image processing task has failed with MethodFault::Exception: sysimage.fault.ReconfigFault

\[#2] \[2007-04-10 11:44:00.124 'App' 636 verbose] \[imageProcessingTaskImpl,154] VmiReconfigTask::task\{8}: SetState to error

\[#2] \[2007-04-10 11:44:00.186 'App' 828 verbose] \[disposable,121] object explicitly disposed: VmiReconfigTask::task\{8}

\[#2] \[2007-04-10 11:44:00.186 'App' 828 verbose] \[imageProcessingTaskImpl,123] VmiReconfigTask::task\{8} being destroyed

\[2007-04-10 13:09:26.648 'VmdbSvc' 636 verbose] IVmdbPipe2Impl operation completed with error: The pipe has been ended.

\[2007-04-10 13:09:26.648 'App' 900 verbose] CloseSession called for session id=4BC470E0-F2A0-445E-A8DE-95311B93D237

\[2007-04-10 13:09:26.648 'VmdbAdapter' 900 verbose] Removed vmdb connection /db/connection/#2/\[#2] \[2007-04-10 11:44:00.108 'App' 636 error] \[vmiReconfigTask,136] Reconfiguration failed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 verbose] \[imageProcessingTaskStep,307] VmiReconfigTask::task\{8} step "Reconfigure VM" 100% completed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 info] \[imageProcessingTaskStep,196] VmiReconfigTask::task\{8} step "Reconfigure VM" destroyed

\[#2] \[2007-04-10 11:44:00.124 'App' 636 error] \[imageProcessingTaskImpl,552] VmiReconfigTask::task\{8}: Image processing task has failed with MethodFault::Exception: sysimage.fault.ReconfigFault

\[#2] \[2007-04-10 11:44:00.124 'App' 636 verbose] \[imageProcessingTaskImpl,154] VmiReconfigTask::task\{8}: SetState to error

\[#2] \[2007-04-10 11:44:00.186 'App' 828 verbose] \[disposable,121] object explicitly disposed: VmiReconfigTask::task\{8}

\[#2] \[2007-04-10 11:44:00.186 'App' 828 verbose] \[imageProcessingTaskImpl,123] VmiReconfigTask::task\{8} being destroyed

\[2007-04-10 13:09:26.648 'VmdbSvc' 636 verbose] IVmdbPipe2Impl operation completed with error: The pipe has been ended.

\[2007-04-10 13:09:26.648 'App' 900 verbose] CloseSession called for session id=4BC470E0-F2A0-445E-A8DE-95311B93D237

\[2007-04-10 13:09:26.648 'VmdbAdapter' 900 verbose] Removed vmdb connection /db/connection/#2/

The converter does create a virtual server on the ESX 3.0.1 target machine. But the VM does not boot into windows due to the error: missing or corrupt file: \system32\ntoskml.exe

I have removed the VMware converter and reinstalled it while at the server console and logged on as Administrator, but the results are the same. The C: and F: drive are on a RAID1 internal controler. and the G: dirve is on a battery backup RAID5 controller (the G: drive is Dynamic).

I am currently at a loss on what to try next. I have serveral of these servers I would like to convert them to my ESX host.

Any suggestions would be welcomed.

0 Kudos
3 Replies
esiebert7625
Immortal
Immortal

There seems to be a known issue with dynamic drives on servers that have utility partitions. Many people have had the same problems. Maybe if you used Converter on the C drive and then just copied the data manually from the other drives using Robocopy.

http://www.vmware.com/community/thread.jspa?messageID=573359&#573359

http://www.vmware.com/community/thread.jspa?messageID=588253&#588253

http://www.vmware.com/community/thread.jspa?messageID=603642

http://blog.scottlowe.org/2007/02/21/vmware-converter/

0 Kudos
jpotter2
Contributor
Contributor

Thank-you for the links. I have not used Robocopy, but will look into it. I have also run into another problem, when I select just the C: drive, the converter runs without errors, but when I startup the newly converted VM on the ESX server, I get a: Windows will not boot due to disk hardware problems, cannot read boot drive. I need to look into the converter logs more on this new problem.

0 Kudos
esiebert7625
Immortal
Immortal

You might try running Chkdsk on your source computer to make sure it has no problems. Also make sure you are using the LSI SCSI controller with Win2003, Buslogic is for Win2000.

0 Kudos