IsmaelRodrigues
Contributor
Contributor

Virtual Machines disconnected

Boa tarde Srs.

Estou enfrentando problemas com algumas maquina virtuais, as maquinas perde a comunicação com rede, o ping se torna inacessível.

Ao acessar a console a maquina está operacional, ao editar as console, network adapter desabilitar o box connected e habilitar novamente a maquina fica acessível.

Alguém já passou por um caso parecido?

Host Esxi 5.5, 1331820

Obrigado,

Ismael

0 Kudos
6 Replies
xflavio
Contributor
Contributor

Em Configuration > Networking.

Você já configurou os vSwitch?

Abraços.

0 Kudos
IsmaelRodrigues
Contributor
Contributor

Olá Flavio.

Sim, o vswitch está criado com duas placas de rede físicas

0 Kudos
xflavio
Contributor
Contributor

É difícil responder alguma coisa por que não conheço sua infraestrutura.

Mas você pode fazer alguns testes como:

- Você consegue pingar o IP da Lâmina?

- Você utiliza VLANs? Está configurada?

- Você já testou nas 2 placas de Rede Físicas?

- Os Leds da Placa de Rede estão acessos?

Enfins.. são alguns testes básicos que eu posso ajudar....

0 Kudos
IsmaelRodrigues
Contributor
Contributor

- Você consegue pingar o IP da Lâmina?

  Sim.

- Você utiliza VLANs? Está configurada?

  Sim, está configurado, porém não existe nenhuma maquina virtual machine utilizando

- Você já testou nas 2 placas de Rede Físicas?

   Tenho 7 virtual machines neste vswitch, estranho que o problema é aleatório, ou seja, não para todas maquinas virtuais.

- Os Leds da Placa de Rede estão acessos?

   Irei ao datacenter certificar o cabeamento.

Obrigado pela força.

0 Kudos
Ivanildo_GalvÃ_
Enthusiast
Enthusiast

Senhores,

Percebo que este é um problema que está acontecendo em alguns clientes, em alguns casos o problema só é resolvido quando a interface de rede é removida da máquina virtual e adicionada novamente.

Estou pesquisando sobre este assunto, até agora não achei nada claro que explique, acredito que seja um bug de leve, peguei o mesmo caso em 3 empresas diferentes, todas usam a versão 5.5 e um dos clientes disse que não tinha estes problemas quando usava a versão 5.0.

Sds a todos !

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
wealvescabral
Enthusiast
Enthusiast

Ivanildo,

Tive o mesmo problema em meu ambiente, em VM Windows. No meu caso o meu problema era um conjunto de fatores:

Durante o processo boot do SO, o computador mesmo possuindo as configurações de IP estático configuradas na placa de rede detectavam conflito de IP e assumiam a configuração na placa com endereço APIPA (169.254.X.X) e exibe a mensagem de erro "Duplicate IP Address 0.0.0.0"

O problema tem carácter aleatório e acontece em situações específicas difíceis de serem reproduzidas em laboratório.

A causa raiz vem de um método de detecção de endereços lógicos duplicados baseado na RCF 5227 que utiliza o pacote chamado ARP Probe. Este pacote contém o endereço físico da placa de rede (MAC Address) seguido do endereço lógico IP 0.0.0.0 que visa não poluir as tabelas arp dos outros hosts no mesmo domínio de broadcast, conforme descrito na seção 2.1.1 da RFC referida.

A Microsoft a partir do Windows Vista / Windows 2008 Server começou a utilizar a RCF 5227 como método padrão de detecção de endereços duplicados na camada de SO. O problema ocorre pois o Cisco IOS a partir da versões 15.0(1)SE dos switches série 2900, 3500 e 3700 também começou a utilizar o ARP Probe para detecção de IPs duplicados.

O Switch envia um pacote ARP Probe para manter seus dados atualizados sempre que uma de suas interfaces muda de status (UP/DOWN). Caso o sistema operacional Windows esteja em fase de detecção de IPs duplicados enviando mesmo tipo de pacote ARP Probe com o IP 0.0.0.0 ocorre a detecção de conflito de endereços, pois ambos os pacotes possuem o endereço lógico iguais ( No caso 0.0.0.0)


Para resolver o problema existem várias abordagens documentadas pelos fabricantes:


Do ponto de vista da rede física, existe documentação da Cisco de como resolver:

Duplicate IP Address 0.0.0.0 Error Message Troubleshoot - Cisco


A VMware também tem KB documentando o problema e como contorna-lo na camada de SO Windows

VMware KB: Virtual machine is assigned an invalid IP address after a reboot


No nosso caso escolhemos a abordagem de desabilitar essa camada de controle no Windows. Caso o seu problema se encaixe no que eu descrevi acima, você pode tomar a decisão junto com o cliente, mas o ideal (apesar de complicado devido ao fator aleatório) seria testar esta solução no ambiente.

Wellington Cabral | Mark it as helpful or correct if my suggestion is useful.
0 Kudos