IgorNM
Enthusiast
Enthusiast

VMServer 2, Não desliga VMs ao Desligar o Host

Jump to solution

Olá a todos,

estou com um problema sério.

Tenho alguns servidores ligados a no-breaks gerenciavies e em caso de falta de luz, o servidor (host) recebe sinal para desligar. O host desliga corretamente, porém, quando vou acessar as VMs, aparece a mensagem do win2008 informando que o servidor foi desligado incorretamente. Isso é, ele não recebe o sinal para desligar (guests).

No VMServer, está configurado para iniciar as VMs automaticamente, uma após outra, após 20 segundos. Para desligar, 0 segundos, metodo 'Power off'. Em todas tenho o VMTools instalado.

Era para funcionar, correto? Devo fazer algo mais? O host não leva nem 1 minuto para desligar.... Com certesa não dá tempo para as VMs desligarem.... Como saber se está funcionando?

0 Kudos
1 Solution

Accepted Solutions
RafaNovo
Enthusiast
Enthusiast

Você tem que trocar o método de "power off" por "shutdown".

No "power off" ele vai simplesmente desligar a VM, como se você tivesse "tirado o cabo de força da vm".

No "shutdown" ele vai iniciar o processo de shutdown correto do guest

Espero que a resposta  ainda seja útil.

View solution in original post

0 Kudos
3 Replies
IgorNM
Enthusiast
Enthusiast

Alguma sujestão?

Devo ter que alterar algo no host?

0 Kudos
RafaNovo
Enthusiast
Enthusiast

Você tem que trocar o método de "power off" por "shutdown".

No "power off" ele vai simplesmente desligar a VM, como se você tivesse "tirado o cabo de força da vm".

No "shutdown" ele vai iniciar o processo de shutdown correto do guest

Espero que a resposta  ainda seja útil.

View solution in original post

0 Kudos
IgorNM
Enthusiast
Enthusiast

Era isso mesmo.

Obrigado!

0 Kudos