Fborin
Contributor
Contributor

Erro ao acesso ESXI pelo PUTTY

Jump to solution

olá pessoal, recentemente instalei meu primeiro servidor esxi e nao estou conseguindo acessa-lo atraves de SSH, os procedimento seguifos foram o do artigo:  http://www.thomasmaurer.ch/2010/07/activated-ssh-on-esxi-4-1

para habilitar o ssh no servidor porem agora quando tento acessar pelo putty ocorre o seguinte erro:

1805795.png

a porta 22 esta respondendo pq se dou um telnet no servidor na porta 22 consigo a resposta:

1805795_1.png

print dos serviços sendo executados:

1805795_2.png

alguem já passou por uma situação dessas?

obrigado.

0 Kudos
1 Solution

Accepted Solutions
ncaio
Enthusiast
Enthusiast

Rapaz, é o seguinte, c:\

1 - você tá tentando logar no ssh por troca de chaves (priv / pub) ? Veja aí se tá marcado isso no seu putty.

2 - Você já acessou uma máquina com o mesmo ip por ssh e talvez tenha problemas com o fingerprint.

View solution in original post

0 Kudos
8 Replies
ncaio
Enthusiast
Enthusiast

Rapaz, é o seguinte, c:\

1 - você tá tentando logar no ssh por troca de chaves (priv / pub) ? Veja aí se tá marcado isso no seu putty.

2 - Você já acessou uma máquina com o mesmo ip por ssh e talvez tenha problemas com o fingerprint.

0 Kudos
RohitVCP7
Enthusiast
Enthusiast
0 Kudos
Fborin
Contributor
Contributor

Opa,

A unica configuração que uso no putty é informar o endereço ip do servidor esxi e escolher o protocolo SSH, e nao uso a troca de chaves (pelo menos nao configuro pra fazer isso).

E nao usei esse endereço ip em outra maquina, tanto que já tentei o acesso de varios outros locais e dá o mesmo erro.

0 Kudos
Fborin
Contributor
Contributor

Amigo esse link que voce informou fala sobre reiniciar os serviços, porem esse caminho /etc/init.d nao tem o sshd para ser reiniciado (muito estranho) e o ssh esta respondendo, consigo reiniciar o gerenciamento de serviços (management service) mas assim mesmo nao consigo o acesso.

0 Kudos
MauroBonder
Leadership
Leadership

É algum problema de certificado no Putty pelo jeito. Tenta reinstalar o putty.

Por favor, não esqueça de atribuir os pontos para resposta "helpful" e ou "correta".

Se a sua pergunta foi respondida, marque como "Answered" para fechar o tópico.

Mauro Bonder - Moderator

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
Fborin
Contributor
Contributor

PessoALL,

depois das respostas de voces acabei testando outro software (SSH Secure Shell) e consigo o acesso ao servidor esxi o que realmente implica que o erro está no meu putty, de qualquer forma vou utilizar esse novo software para acesso a este servidor.

Agradeço a todos pela ajuda.

0 Kudos
ncaio
Enthusiast
Enthusiast

2 - Você já acessou uma máquina com o mesmo ip por ssh e talvez tenha problemas com o fingerprint.

pegue o exec do seu putty e coloque em outra pasta e teste

0 Kudos
Fborin
Contributor
Contributor

Sugestao executada sem sucesso.

0 Kudos