Fernando_Matias
Contributor
Contributor

Debian Woody e VMware ESXI

Jump to solution

Olá. Bom dia.

Precisamos rodar um Debian Woody kernel 2.4 e seu LVM em um hypervisor. Era um ambiente físico antigo, que os discos danificaram e acabamos de recuperar os dados em um lugar especializado. 

Por isso quero instalar todo sistema em um guest e importar os dados do LVM.

A empresa que recuperou a LVM usou VMware em uma parte do processo deles, mas não deram muitos detalhes. 

Gostaria de saber qual versão do Esx suporta esse sistema e se tem algum guia para Linux com kernel 2.4.

Qualquer ajuda é valida.

 

 

0 Kudos
1 Solution

Accepted Solutions
MarcoCesar
Contributor
Contributor

Fernando, eu conheci a Hosco por um analista da IBM da Tutoia. Eles sao antigos nessa área de recuperação de dados. Se não me engano o CTO deles é certificado VMware.

Voltando no Debian, verifiquei que VMware 6.0 tem suporte para Debian 4 e para Linux kernel 2.4. Bem provável conseguir instalar o woody com um desses templates. Estranho que o VMware Compatibility Guide não inclui eles:

vm1.png


É só testar. Informe os resultados para gente. Boa sorte!

View solution in original post

6 Replies
diegodco31
Leadership
Leadership

Ola Fernando

Eu não conheco essa versão do Debian, mas no link abaixo voce pode encontrar todas as versões do debian suportados vs a versão do esxi.

https://www.vmware.com/resources/compatibility/search.php?deviceCategory=software&details=1&partner=...

 

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
MarcoCesar
Contributor
Contributor

Boa noite.

Esse debian usa kernel 2.4, por isso apenas versões antigas do Esx podem suportar esse guest. O problema é descobrir qual. De repente é mais fácil tentar falar com esse analista que recuperou suas vms.

0 Kudos
Fernando_Matias
Contributor
Contributor

Olá Diego.

Essa versão mais nova de ESXi não aceita kernel 2.4.

Mas vou tentar a recomendação do MarcoCesar.

Muito obrigado.

0 Kudos
Fernando_Matias
Contributor
Contributor

Ola Marco,

Já estava pensando nisso; falei com a empresa hoje. O analista que me atendeu acha que foi ESXI 6.0, mas vai me confirmar na segunda-feira. Ele me sugeriu tentar com template linux padrão 2.6, mas eu tentei e não funcionou.

Por sinal a empresa é a Hosco. Alem de bons profissionais sao muito atenciosos. 

Assim que eu tiver a informação eu disponibilizo para ajudar quem tiver a mesma dúvida. Vejo muitas outras empresas com ambientes antigos rodando máquinas físicas por falta de suporte de hypervisor.

obrigado e até logo.

MarcoCesar
Contributor
Contributor

Fernando, eu conheci a Hosco por um analista da IBM da Tutoia. Eles sao antigos nessa área de recuperação de dados. Se não me engano o CTO deles é certificado VMware.

Voltando no Debian, verifiquei que VMware 6.0 tem suporte para Debian 4 e para Linux kernel 2.4. Bem provável conseguir instalar o woody com um desses templates. Estranho que o VMware Compatibility Guide não inclui eles:

vm1.png


É só testar. Informe os resultados para gente. Boa sorte!

View solution in original post

Fernando_Matias
Contributor
Contributor

Ola,

Ja tinha visto sua resposta e testado a solução mas só agora consegui logar. Funcionou para mim.

Obrigado Marco e Diego.

0 Kudos