VMware Cloud Community
bergerpjr
Contributor
Contributor

vdr - cannot login to advanced mode - normal mode works fine.?

colleagues -- I'm testing VDR v1.2.0.1131 in our vSphere 4.1 Update 1 environment and am testing File Level Restores. When I launch the "vmwarerestoreclient.exe" file and login to my VDR appliance using normal mode -- all works just fine.

however... if I check off the "advanced mode" option and try to login it fails. I've tried all possible privledged accounts to no avail.

Here's the screen-shot of the error:

flr_error.PNG

and here's the capture of the "RestoreClient_0.log":

03/14/2011 12:24:15 PM > Using 32-bit driver
03/14/2011 12:24:17 PM > Vix Info:  VixDiskLib: config options: libdir 'DisklibPlugin', tmpDir 'C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\vmware-Administrator'.
03/14/2011 12:24:17 PM > Vix Info:  VixDiskLib: Advanced transport plugin was successfully loaded into vixDiskLib. Accelerated transport modes available.
03/14/2011 12:24:17 PM > Vix Info:  VixDiskLib: Cannot find transport switch implementation in library DisklibPlugin\plugins\disklibplugin.dll.
03/14/2011 12:24:17 PM > Vix Info:  VMware VixDiskLib (1.1) Release build-207031
03/14/2011 12:24:17 PM > Vix Info:  Using system libcrypto, version 90809F
03/14/2011 12:24:17 PM > Vix Info:  Mntapi_Init Asked - 1.0 Served - 1.0 was successful,TempDirectory: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\vmware-Administrator-500.
03/14/2011 12:24:32 PM > Vix Warn:  VdrGetNfcTicket: Failed to connect to "10.16.20.18" as "root", error 1104
03/14/2011 12:28:26 PM > Exception: "Connect::BeginSession: failed to authenticate"
                       >    at VmCommon.BackupAppliance.ConnectInternal(String password)
03/14/2011 12:29:11 PM > Vix Warn:  VdrGetNfcTicket: Failed to connect to "10.16.20.18" as "root", error 1104

I've triped IP address; DNS name; I've rebooted the VDR appliance and vCenter too. Smiley Sad

tips/tricks/suggestions, etc?

thanks...

Reply
0 Kudos
10 Replies
alefestaedist
Hot Shot
Hot Shot

Hi there, I know it sound stupid to ask but did you check the credential are correct and that from there you may login through th vpshere client aswell?

Alex

Reply
0 Kudos
bergerpjr
Contributor
Contributor

yes -- I've made sure that my "ADM", the "root" and "service-vdr" passwords that I've tried are all correct; not locked out and can access/login to ESXi from the vClient.

Also -- I forgot to mention -- there are no firewalls between these devices and no software (Windows Firewall) firewalls, etc. that would block ports, etc.

thanks...

Reply
0 Kudos
alefestaedist
Hot Shot
Hot Shot

can you check that if you loing into the vdr you may ping the virtual center correctly and/or reslove it's dns name? On the other hand I would check that the vcenter can ping back the vdr and can eventually do an ssh connection.

Alex

Reply
0 Kudos
ThomasMc
Enthusiast
Enthusiast

Maybe I'm not following properly(been a long day:)) but why are you loging in as root?

03/14/2011 12:29:11 PM > Vix Warn:  VdrGetNfcTicket: Failed to connect to "10.16.20.18" as "root", error 1104

Thomas McConnell vPadawan
Reply
0 Kudos
bergerpjr
Contributor
Contributor

ThomasMc -- the VMware Data Recovery Administration guide says ""Under vCenter Server, in User name enter the name of a user with vCenter administrative privleges".

I'm logged into vClient as "drexelmed\pbadm" which is a member of the "ESXAdmins" AD group. This is the account I use for all my vCenter duties. But since "advanced login" to VDR failed with this account I tried "root"; "service-vdr" (the account the VDR appliance uses); "administrator" and any other combination of local/domain users/credentials I could think of. They all failed for "advanced login".

Logging into normal mode and using File Level Recovery works just fine though.

odd -- eh. thanks...

Reply
0 Kudos
ThomasMc
Enthusiast
Enthusiast

I see, thanks for the info, I'll have a mess in the lab and see if I can replicate it as it seems to work as expected in my lab with the domain admin account

DRA

IP :192.168.x.x

vCenter

Name:vCenter01

User :domin\administrator

Pass: something

Thomas McConnell vPadawan
Reply
0 Kudos
ThomasMc
Enthusiast
Enthusiast

Removed this bit for now

Thomas McConnell vPadawan
Reply
0 Kudos
bergerpjr
Contributor
Contributor

All -- I resolved the issue. I un-mounted the VDR's backup LUN; formatted it; and started all backups from scratch (I've been doing alot of testing). Once the initial Datacenter backup completed I re-tested. I was able to login with normal AND advanced modes to VDR!? Weird.

thanks for all your help and suggestions.

Reply
0 Kudos
KWBS
Contributor
Contributor

Hi,

same issue here after upgrade to 1.2.1. I don't want to format the LUNS, don't want to lose my recovery points from last year. Any other idea?

Error:

Exception: "Connect::BeginSession: failed to authenticate"
                       >    bei VmCommon.BackupAppliance.ConnectInternal(String password)

Greetings

Reply
0 Kudos
KWBS
Contributor
Contributor

we resolved our issue, by adding all the esx server to /etc/hosts on the appliance .

Reply
0 Kudos