VMware Cloud Community
kdon
Contributor
Contributor
Jump to solution

VDR appliances load slow after connecting - 100% cpu on client machine

Whenever i connect to any of my vdr appliances(5 of them), it will connect, but takes a good 5-10 minutes for all of the events/failures to load. As this is happening, it makes the cpu on my workstation peg up to 100% constantly during the time it is taking to load all of the events etc.

Version of VDR is 1.2.

Any thoughts or suggestions?

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
slmpptc
Enthusiast
Enthusiast
Jump to solution

On the Reports tab of the VDR appliance console, select the events you want to purge, right-click and then click on delete.

Sean

View solution in original post

Reply
0 Kudos
10 Replies
RParker
Immortal
Immortal
Jump to solution

it makes the cpu on my workstation peg up to 100% constantly

Where are the VDR running? Your CPU should not spike, the appliance is doing the work not your client / agent. The fact that it's slow tells me that the host doesn't have enough CPU to run these appliances. Or the pool / priority is not set right.

Or another idea is VDR disks (repository) is slow or highly utilized. I tried the same scenario, but the VDR is trying to get the data from the backup set, this still indicates your VDR disks or CPU is a problem

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

Ok sorry for not including any specs.

I do not think it is pool or reservation issues as i do not utilize resource pools. I have 5 esx hosts, 4-way quad cores. Total utilization of my cluster cpu combined is about 25,000 MHz out of 191,000 and my memory utilization is at 125gb consistently out of 320gb.

The VDR appliances all have 4 cpu's and 4gb of ram, and when i log in to them i do not see the appliances really doing anything. I think the second thought you have about the dedupe share could possibly be it. I am using cifs shares for the dedupe store. At the same time, it is simply loading all the events and so forth right? It should definitely not peg my workstation cpu, and i agree with you on that.

The process that is using the cpu is the vsphere client(VpxClient.exe) when i connect to each appliance. It only happens when i connect to vdr, and normal every day use with the client is fine. It hovers around 150mb usage as well, but the cpu just gets chewed up!

Thanks for the fast reply RParker!

Added - I forgot as well, the vdr appliances are running on any of the esx hosts. I have vmotioned one to see if that would make a difference and nothing.

Message was edited by: kdon

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

bump... anyone?

Reply
0 Kudos
bstrignano
Enthusiast
Enthusiast
Jump to solution

Try to exclude the vpxClient from local antivirus scanning.

Brent

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

Thank you for the quick reply Brent. I have completely disabled a/v on my computer and still the same Smiley Sad

I thought you might of had something!

Thanks again!

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

bump.. I really can't believe nobody else is seeing this behaviour when they connect to the vdr appliances.

I am using CIFS shares as well, and am leaning on that as the culprit, but seriously, all the appliance is doing is listing all the events, and taking a really really long time and consuming 100% cpu on my workstation.

Anyone?

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

End of the week BUMP!

Still nothing everyone? Other people have got to be having this issue Smiley Happy Speak up!

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

Ok how about this. Is there a way to clear the events? It seems events totaling over 3000 really makes it chug. When I redeployed an appliance and started from scratch it is normal. I imagine when it gets a lot more events, it will act as the others.

How can events be cleared? I dont care about historic events > 30 days honestly.

30 vm's a day x 7 days = 210 events + integ events and reclaims x 4 = about 1000 events. It only gets to be slow after 3000 events.

Please someone help.

Reply
0 Kudos
slmpptc
Enthusiast
Enthusiast
Jump to solution

On the Reports tab of the VDR appliance console, select the events you want to purge, right-click and then click on delete.

Sean

Reply
0 Kudos
kdon
Contributor
Contributor
Jump to solution

WOW - blam it was that easy. I never tried right clicking on events. Thank you so much, this makes it much faster!!!

You are the man!

Reply
0 Kudos