anthonypoh
Enthusiast
Enthusiast

VDP Proxy errors

Has anyone encountered this error before:

vdp: Failed to initiate a backup or restore for a virtual machine because no proxy was found to service the virtual machine

A new update to vdp came out last week and I upgraded the appliance following the admin guide. Upgrade went fine, vdp appliance shows it's running v5.1.10, couldn't see any errors in the log..... However, I then rebooted the appliance and now no backup jobs can run and they all error out saying that there are no proxies available to service the backup job. vdp-config page says it's all running fine, although it now doesn't allow me to download the log bundle so I can't even check if there area any problems.....

Now if I remember correctly vdp/vcenter has 8 proxies which services backup jobs....... what I don't understand is why it was all working prior to the upgrade and now it has stopped working.....

I've tried searching around the community and the web for information, but there doesn't seem to be many articles about this error..... =(

Any help appreciated....

http://thevirtualunknown.co.uk/
Tags (1)
0 Kudos
2 Replies
snekkalapudi
VMware Employee
VMware Employee

The issue seems to be intermitent. I would try restarting the appliance.

-Suresh
0 Kudos
anthonypoh
Enthusiast
Enthusiast

Have tried that numerous times.....

In the end I rebooted the vCenter Server..... and that cleared up some stuff and allowed VDP to generate a different error which explained what was causing the problem.

It seems one of my colleagues had 'unmounted' a datastore from one of the hosts and VDP was kicking up an error similar to the one in this KB: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=203700...

Jumped onto my storage array and unpresented the LUN from the host and VDP kicked into life......

Man.... this product really needs a revamp!

http://thevirtualunknown.co.uk/
0 Kudos