Czernobog
Expert
Expert

VDP Appliance configuration - registering with vCenter fails. Possible to connect with remote vCenter?

Hi,

I want to deploy a VDP Appliance and connect it to a remote vCenter, that is, not the one on which the appliance is deployed. Say I have deployed the ova template in vCenter1, but during the configuration I want to connect it to vCenter2. The reason behind this is, that the whole environment managed by vCenter2 is very small and I don't want to deploy a 1TB+ appliance there. Both vCenters run in the same DC, so there are no communication or latency issues, also - the VM that vCenter2 is running on is registered with the vCenter1.

During the configuration i get the "VDP not found in vCenter inventory" error (not using english browser version so this might be slightly different). From what I understand, during configuration the appliance wants to discover itself within the vCenter1 inventory, altohugh I have provided it with connection info for the vCenter2. An error is reported in the vami-ovf.log:

2014-04-24 05:03:28,486 INFO  [http-nio-8543-exec-10]-services.VcenterConnectionTestService: Testing VDP connection to vCenter at: [vCenter2] port: [443] and SSO at

: [vCenter2] port: [7444]

2014-04-24 05:03:28,658 INFO  [http-nio-8543-exec-10]-reconfig.VcenterConfigurationImpl: Validating permissions for vCenter user: [domain\userWithAdminRightsOnVCenter]

2014-04-24 05:03:28,659 INFO  [http-nio-8543-exec-10]-vi.VIAccess: Attempting to obtain AVE VM with IP Address: [10.x.x.x]

2014-04-24 05:03:28,666 INFO  [http-nio-8543-exec-10]-vi.VIAccess: Local Client not found

2014-04-24 05:03:28,667 ERROR [http-nio-8543-exec-10]-reconfig.VcenterConfigurationImpl: Failed to obtain either Authorization Manager from service instance or VDP VirtualMach

ine.

2014-04-24 05:03:28,667 INFO  [http-nio-8543-exec-10]-vi.VIAccess: Attempting to obtain AVE VM with IP Address: [10.x.x.x]

2014-04-24 05:03:28,674 INFO  [http-nio-8543-exec-10]-vi.VIAccess: Local Client not found

2014-04-24 05:03:28,689 INFO  [http-nio-8543-exec-10]-service.AdapterUtils: MCS Web Services URL: https://localhost:9443/services/mcService  MCUserId="MCUser"  MCUserPswd="***

**************************"

2014-04-24 05:03:28,704 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: I/O exception (java.net.ConnectException) caught when processing request: Connection refus

ed

2014-04-24 05:03:28,704 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: Retrying request

2014-04-24 05:03:28,706 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: I/O exception (java.net.ConnectException) caught when processing request: Connection refus

ed

2014-04-24 05:03:28,706 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: Retrying request

2014-04-24 05:03:28,708 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: I/O exception (java.net.ConnectException) caught when processing request: Connection refus

ed

2014-04-24 05:03:28,708 INFO  [http-nio-8543-exec-10]-httpclient.HttpMethodDirector: Retrying request

2014-04-24 05:03:28,710 INFO  [http-nio-8543-exec-10]-http.HTTPSender: Unable to sendViaPost to url[https://localhost:9443/services/mcsdk10]

java.net.ConnectException: Connection refused

DNS lookup zones are configured, as are the firewall ports.

Is it at all possible to connect VDP to a remote vCenter?

0 Kudos
3 Replies
DanielOprea
Hot Shot
Hot Shot

Hi,

Please, look this KB  and this KB

PLEASE CONSIDER AWARDING any HELPFUL or CORRECT answer. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA. ¡¡Muchas gracias!! Blogs: http://danieloprea.blogspot.com.es/ https://communities.vmware.com/blogs/doprea
snekkalapudi
VMware Employee
VMware Employee

You cannot connect VDP to a a remote vCenter. It is not supported. You cannot get past the configuration.

VDP should be deployed with in the vCenter and can be connected only to the vCenter

-Suresh
Czernobog
Expert
Expert

Yeah, I've read the KB's and jsut thought that maybe there is a way. Too bad.

0 Kudos