VMware Cloud Community

VDP 6.1 Backup Failures


I've recently inherited a vCenter environment where a small number of the VMs are being backed up using VDP 6.1. The backups are currently failing and I'm not really getting anywhere with troubleshooting as I'm struggling to get the logs.

The job fails immediately, from inside the vSphere client I recieve;

Reason: VDP: An unexpected error occurred with the following error code: 30983.

Log file retrieved is empty.

When trying to download the client logs from the appliance website I receive the following error:

Download failed: I/O error.

Possible cause could be insufficient disk space. Please check available space on the download location.

Definitely sufficient space. I've connected to the appliance and check the client job logs manually and there doesn't seem to be any there.

There is 8TB of storage available so we've not run out there.

Not to sure where to go from here.


Tags (1)
6 Replies

Hi, did you see this:

Code         : 30983
Summary      : The server could not find an appropriate proxy to service the job.
Description  : The server was not able to find a proxy based on your proxy selection preference and the proxy setup to service a job. Please review the setup for the proxies and the MCS preference for the proxy selection algorithm.

0 Kudos

I'm in the same situation.  I am getting the same error[s] as well.  It all started for me after applying the latest vcsa updates to my external PSC and VCSA.  For me the proxy is the same system, so it seems odd that it cannot find itself.

0 Kudos

Same issue here as my VDP backups were failing after upgrading vCenter Server to 6.0 U2a on Tuesday.  I was able to resolve it by upgrading VDP to 6.1.3.  The VMware compatibility matrix shows that VDP 6.1.2 is compatible with vCenter Server 6.0 U2 but there must be something in the vCenter 6.0 U2a upgrade that's incompatible with 6.1.2.

There's also a slight change to the VDP upgrade process that I noticed in the vSphere Data Protection 6.1.3 Release Notes:

Upgrade Changes

  • vSphere Data Protection 6.1.3 supports in-place upgrade, that is, upgrade from 6.1.x to 6.1.3. Note: In-place upgrade is supported from vSphere Data Protection 6.1.
  • vCenter Server 6.5 is supported with vSphere Data Protection 6.1.3 only. To upgrade vCenter Server to 6.5, first upgrade vSphere Data Protection to 6.1.3, and then upgrade vCenter Server.
  • Change in the upgrade process:
    1. The vSphere Data Protection configuration utility logs out after 86% of the upgrade completes. You cannot see the progress further.
    2. After the upgrade completes, when vSphere Data Protection configuration utility shuts down, a message that states that the maintenance services are not running appears.
    3. Ignore the message, and start the vSphere Data Protection appliance without deleting the snapshot, and making the vSphere Data Protection disks independent.
    4. Verify whether all the services are running on the vSphere Data Protection configuration utility, and all the jobs correctly appear in the vSphere Data Protection GUI.
    5. Shut down vSphere Data Protection.
    6. Delete the snapshot, and make the vSphere Data Protection disks independent. The vSphere Data Protection Administration Guide provides information.
0 Kudos

I'm not sure why VMware think this issue is constrained to the VCSA.

A colleague resolved this and sent me the following info - thanks Sandeep.

As suspected – found to be a compatibility issue with Java/jSAFE library versions used in VDP 6.1.2 and in vCenter Server 6.0 U2a. For now a work around is applied as per the kb to get them working and tested successful backups, however as this issue is fixed in VDP v6.1.3  it is recommended to upgrade the VDPs to 6.1.3 sooner.

Here is the KB article documented for this https://support.emc.com/kb/487555.

0 Kudos

I had the same problem after updating VDP 6.1.3 to 6.1.4.

Below post helped me resolve the issue and get it working again:

Failed To Start Internal Proxy In VDP 6.x ~ virtuallyPeculiar

-- Stefan

Thank you smr222​ worked also for me. We had the same problem when upgrading from 6.1.2 to 6.1.4

0 Kudos