Highlighted
Enthusiast
Enthusiast

Error trying to perform backup. Failed to open VDDK disk

I've been working for two days on a problem, but no solution. Using Veeam Backup & Replication 9.5, Update 03.
The same can not back up virtual machines, apparently for error of permission, but I have done everything or almost everything, according to articles I found on the internet.
The error is this:

Processing Apolo Error: Failed to open VDDK disk [[VMDATA02] Apolo / Apolo.vmdk] (is read-only mode - [true]) Logon attempt with parameters [VC / ESX: [calcario.vlb.local]; Port: 443 VMware Spec: [moref = vm-49]; Snapshot mor: [snapshot-146]; Transports: [nbd]; Read Only: [true]] failed because of the following errors : Failed to open disk for read. Failed to upload disk. Agent failed to process method {DataTransfer.SyncDisk}.

The error happens with all virtual machines.
vCenter is VCSA 6.0, ESXi 6.0 hosts, Dell storage SAS type Compellent.
I have already removed vCenter from Veeam and added again, using administrator@vsphere.local , the Veeam server, hosts and vCenter are on the same network segment. The Veeam is a physical server, Dell with 48GB of RAM and two processors.
I already rebooted vCenter and also the hosts in order to restart the services, but it did not work.
We opened call with Veeam, the only response Veeam sent was that it was a permission error, nothing more.

Anyone have an idea how to solve this?

Thanks !
Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
13 Replies
Highlighted
Immortal
Immortal

Could it then be a permissions error? Do you get the same error if you add the vCenter in Veeam with an AD account granted administrative permissions? This would probably be something better to post on the Veeam forums rather than here.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Even though using an administrative AD account, the error persists, vCenter is integrated with AD, the hosts are not.
But I tested the hosts individually in Veeam, using the root user, then I try to perform a direct backup of the host, the error persists.
I put it on the Veeam forum, but so far no response.

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
Highlighted
Immortal
Immortal

What account exactly are you using? And can you show a screenshot inside vCenter where it lists its permission?

0 Kudos
Highlighted
Enthusiast
Enthusiast

As I said before. I am using the account administrator@vsphere.local, vCenter was added in Veeam with this account.
Right at the beginning, I created a Veeam account with Administrator permission, it did not work, so I started to use the account administrator@vsphere.local
I am sending the image with users and feeds permissions.

I wait and thanks !

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
Highlighted
Enthusiast
Enthusiast

vsphere_permission.png

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
Highlighted
Immortal
Immortal

If you login to vCenter with administrator@vsphere.local, can you take a snapshot of any VM? See also this post. Also look at this post that discusses free space on the datastore where the Veeam proxy resides in comparison to the disk to be processed.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Yes, the snapshot occurs normally, there is also enough space in the Veeam Repository, Veeam Backup and Veeam Proxy are on the same machine, it is a Dell physical server with 48GB of RAM.

I am sending two more images with a test I just made, trying to backup a single virtual machine.

backup_test_error.pngbackup_test_error_report.png

Thanks for your avalaiable

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
Highlighted
Immortal
Immortal

I'd recommend opening a support case with Veeam for this issue. After some research, there are various conditions which can produce this result and without logs and analysis it's impossible to tell. Their support is very good and should be able to help you out. If/when you log a SR, put the number in your post on the Veeam forums.

Highlighted
Enthusiast
Enthusiast

Okay, I'll do it again.

Thank you !

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
0 Kudos
Highlighted
Enthusiast
Enthusiast

Problem solved. Following the guidelines of Veeam support, I installed the Microsoft Visual C ++ 2008 Redistributable Package (x64), then I performed a backup and it worked.

Greetings !

Ivanildo Galvão Consultor de TI e Segurança da Informação www.ivanildogalvao.com.br www.esolutionti.com.br
Highlighted
Contributor
Contributor

Hello Ivanildo, did it need to be specifically 2008?  On our backup server we already have Microsoft Visual C++ 2005, 2010, and 2013 Redistributable Packages installed and our backups started failing with this error this week.

0 Kudos
Highlighted
Contributor
Contributor

amigo , estou com mesmo problema para restaurar um backup do instant recovery.

Você apenas instalou o Microsoft Visual C ++ 2008 Redistributable Package (x64) ?

fico grato se responder.

0 Kudos
Highlighted
Contributor
Contributor

I had the same error. Changing the parameter Config.Defaults.security.host.ruissl to true helped me (Host --> Configure --> System --> Advanced System Settings):

pastedImage_0.png

0 Kudos