kot99
Contributor
Contributor

Cannot create a quiesced snapshot because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine.

Then i try to backup VM using VDR the following error occured:

Create virtual machine snapshot

Cannot create a quiesced snapshot because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine.

How can i fix this issue ?

Please help...thanks.

0 Kudos
37 Replies
habibalby
Hot Shot
Hot Shot

I have tried uninstalling the FileSystem Sync Drive but unable to uninstall it as the VSS driver already installed and the only solution i have for those VMs which are effected with error mentioned is to;

  1. Shutdown the VM

  2. Run vDR Backup on it. This method works fine with MSCS clusters becasue it's in Active/Passive.

For those VMs that are not under cluster, I can't do because I can't shuting them down.

Best Regards,

Hussain Al Sayed

Revisit your posts and award points for "correct" or "helpful".

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
0 Kudos
ncsmithii
Contributor
Contributor

I found my issue to be COM + System Application and its dependent COM+ Event System not set to Automatic and started WHEN VMware Tools is installed. To correct my issue, I set both to Automatic / Started and did a Repair on VMware Tools. After a reboot, the VCB completed successfully.

0 Kudos
Farooqjilani
Contributor
Contributor

Good news is I found a KB which describes this issue and provides a fix! Can you have a look at it and implement the fix, let me know if it doesn't work or if you've questions?

KB Article: 1019848

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=101984...

Farooq Jilani

0 Kudos
sebdelyon
Contributor
Contributor

mistake

this post must be deleted

0 Kudos
nanev
Enthusiast
Enthusiast

Dear kot99,

I had the same problem with only 1 VM Linux (CentOS). I checked carefully VMTools, but everything was OK. The problem was found to be at store level. The first virtual disk was at store which was formated with 1 MB block (support max 256GB file). You know that all config data except virtual disk is placed together with it. This VM has two additional disks which are placed on different stores according each other and first virtual disk. Third disk (400GB) is placed on store which was formated with 2 MB blocks (support max 512GB file). So if you want to make snapshot fr this VM, it tries to do this operation where is placed config files (first store wich is formated to support 256GB file). The problem is that is impossible to make snapshot of virtual disk with size 400GB (placed on third store) to first store wich can support max 256GB file.

Before few updates when I try to make manual snapshot I get the same error

"Cannot create a quiesced snapshot because the create snapshot operation exceeded the time limit for holding off I/O in the frozen virtual machine."

But now (with all updates) I get more oriented error

File <unspecified filename> is larger than the maximum size supported by datastore '<unspecified datastore>

Solution is to move first disk with config files to store wich was formated with block size larger or equal to greatest block size of stores used by disks of this VM.

Now you can create manual or VDR snapshots without errors.

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

VSP4, VTSP4, VCP4

ITIL v.3 Intermediate Level

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!! VSP3, VSP4 , VTSP4 , VCP4, VSP5 , VTSP5 , VCP5 , … Cisco DCUCI Microsoft SBS, MSS Virtualization ITIL v.3 Intermediate Level ITIL v.3 Instructor NetApp NASP , … LSI Logic Authorized System Builder Promise Storage Specialist
0 Kudos
Mick64
Contributor
Contributor

I ran into this issue as well, on an exchange 2007 server with windows 2008 x64. Ran vssadmin list writers and found that the forefront writer was generating the error.

Uninstalled forefront and rebooted and was able to take a snapshot that completed without error.

The backup has just ticked over to 1% so presumably it is now fixed.

The odd thing is forefront is installed on our edge server and is not causing any problem so it may have corrupted and just need to be reinstalled.

0 Kudos
SimonCoz
Contributor
Contributor

Hi,

My problem was also with Windows2008 R2 x64 - "Virtual Center" and DataRecovery 1.2 and I solve it with solution below.

The clear Windows2008R2 created from the same template, but without any instalation(virtual center, or SQL DB or....) work fine with DR1.2

Solution:

To enable Windows 2008 Virtual Machine Application Consistent Quiescing:

1. Open the VMware vSphere Client, and log in to a vCenter Server.

2. Select Virtual Machines and Templates and click the Virtual Machines tab.

3. Locate the Windows 2008 virtual machine for which you are enabling the disk UUID attribute and shut down the guest, or power off the virtual machine.

4. After power-off, right‐click on the virtual machine, and select Edit Settings.

5. Click the Options tab, and select the General entry in the settings column.

6. Select Configuration Parameters.

7. Click Add Row.

8. In the Name column, enter disk.EnableUUID.

9. In the Value column, enter TRUE.

10. Click OK and click Save.

11. Power on the virtual machine.

0 Kudos
regnor
Contributor
Contributor

I had the same problem with some of our VMs. The odd thing was that a manual quiesced snapshot worked, but when I tried to creat such a snapshot via Netapp SMVI I got the error. In the Eventlog the VSS-Service had an error each time a snapshot was to be created.

I deleted the registry key like AlbertWT wrote, and then the error disappeared. The next problem was that the "COM"-services couldn't start because of the missing key, so I had to restore the key. And now both the services and the snapshot work...I dont get it :smileyblush:

0 Kudos
mhartmann
Enthusiast
Enthusiast

Ich bin ab dem 05.12.2010 wieder erreichbar.

Ihre Mail wird nicht weitergeleitet und kann erst nach meiner Rückkehr bearbeitet werden.

Dringende Anfragen zum Thema SAP bitte an r3.zentral@siemens.com weiterleiten.

Dringende Anfragen zum Non-SAP Themen bitte an it-bim.it-solutions@siemens.com weiterleiten.

Bei Fragen zum Thema Adminarea wenden Sie sich bitte an meinen Kollegen Stefan Spönla stefan.spoenla@siemens.com

With best regards,

Michael Hartmann

Siemens IT Solutions and Services GmbH

SIS GER SOL RCC SUED RZIT

Otto-Hahn-Ring 6

81739 Munich, Germany

Tel.: +49 (89) 636-54472

Mobile: +49 (162) 2391070

mailto:hartmann@siemens.com

Siemens IT Solutions and Services GmbH: Managing Directors: Christian Oecking, Martin Bentler, Rainer-Christian Koppitz, Thomas Zimmermann; Registered Office: Munich, Germany; Commercial Register: Munich, HRB 184933

0 Kudos
BigT201110141
Contributor
Contributor

This solution worked for me also. It solve the same issue with Vcenter & VDR failing to quiesce.

The issue is documented in VM KB 1031298

"Cannot take a quiesced snapshot of Windows 2008 R2 virtual machine running vCenter Server 4.1"

0 Kudos
jpuskar
Contributor
Contributor

After repeated support calls and a week of trying different variables, I was able to narrow down the cause of this error on my systems.

  1. Independent Disks
  2. iSCSI connections from within the VM
  3. not running the latest minor build of vmware tools
  4. "missing" disks.

For more info, see my blog post.

0 Kudos
VCSLI
Contributor
Contributor

Dave Convery's solution dows work. Uninstall the VSS provider installed with Tools and the backups work as they should.

If only there was a way to easily do th is from command line versus having to log into each of the affected boxes.

0 Kudos
mdgunther
Contributor
Contributor

FYI, the snapshot problem was fixed in 4.1U1 and is working for me now.

0 Kudos
SimonCoz
Contributor
Contributor

Odsoten bom do 29.04.2011. Med tem časom bom imel omejen dostop do e-pošte in tudi ne bom dosegljiv na GSM. Vaše sporočilo se ne bo samodejno posredovalo, zato se v tem času prosim obrnite na moje sodelavce. Lep pozdrav, Simon Čož

I will be out of the office till April 29th, 2011. Your e-mail is not automatically forwarded so throughout this period please contact my colleagues, who will take care about you. In time of absence I will have limited email and GSM access . Regards, Simon Čož

0 Kudos
geo1717
Contributor
Contributor

I ran into this issue today after I noticed that VMware VDR 2 was not backing up my VM's. I found the issue related to a GPO change that pushed setting the VIrtual Disk service (vds.exe) to disabled. It is set to manual by default. Once I set it back to manual I was able to create a quiesce snapshot. As stated earlier, snapshots without quiesce selected works just fine. However VDR is setup to select this option.

This issue was only observed on Windows 2008 64 bit systems. On Windows 2003 32 bit, setting the service to disabled did not prevent a quiesced snapshot. We are only running 2008 64 bit and 2003 32 bit in our environment.

After changing the GPO, you will need to push the changes to the systems, or do it manually on the server with a gpupdate /force if you do not want to go to the service and set it to manual.

0 Kudos
retrojit
Contributor
Contributor

Hi All,

I'm also facing same issue with few of 2008 R2 based virtual machines. I'm able to take manual snapshot from vCenter but when I run the scheduled backup job for the same it fails with the same error every time.

I've tried so far -

  • checked vssadmin, it is fine with no errors.
  • checked all the services as par KB 1007696.
  • repaired vmware tools and rebooted the vm, no success.
  • vMotioned VMs to other hosts but no improvmenet.
  • completely removed and reinstalled the vmware tools and still same error.

Generally backup issues used to slove with either restarting vmware tools service or repairing them. But few of these 2008 R2 machines, I'm not able to fix the issue. There's no independent disks are configured for these machines.

We're using Tivoli TSM for VE.

Thanks in advance

Cheers

Jit

0 Kudos
CaDVM
Contributor
Contributor

Same problem here with two Win2k8 R2 x64 servers and also TSM for VE.

TSM for VE is taking a snapshot with the memory option 0 and the quiesce option 1.

I bet you can't take a manual snapshot of that vm with unchecking the memory option and checking the quiesce option.

I couldn't find a solution for that.

Any idea why the snapshot works when memory option in checked and quiesce is checked too, but it doesn't work with memory 0 and quiesce 1?

0 Kudos
ACTNetAdmin
Contributor
Contributor

I ran into this post by accident but wanted to respond because i had this problem before and solved the issue.  I found that the name used in vCenter was the cuplrit. For example....

I have a network server named SQL01    However, in vCenter i renamed it SQL01-2008  so i could distinguish the version of SQL it used from other servers.

When i used a backup program like EMC networker to create a vmdk image of the server it wanted the server name. Of course i chose SQL01 but that right there was the issue.  You actually need to use the name you have in vCENTER.  Not the FQDN.   Once i did that all my "cannot create a quiesced snapshot" issues were resolved.

I hope this helps someone. I know i spent days trying to figure it out.  Smiley Sad

Cheers,

SB

0 Kudos