VMware Cloud Community
peterrinder
Contributor
Contributor

Can not register VDP to vcenter

Hallo,

i try to register the vdp to vcenter 5.1. I use the embedde SSO. The settings seems to be OK. But after the connection test, i get an error message box without text. If i change the settings to other values, i get a messages that my settings are incorrect. Have anyone a idea where here the problem is?

Best regards

Peter

22 Replies
ericwilliams
Contributor
Contributor

I went through what appears to be the same issue.  The way I was able to proceed was to not use username@domainname.com - but domainname\username. 

Reply
0 Kudos
peterrinder
Contributor
Contributor

I try it with domainname\username but the same error occurs. Do you use vcenter with SSO embedded on Linux? Which VDP Package do you use?

Reply
0 Kudos
ericwilliams
Contributor
Contributor

No, I have a dedicated vCenter server and a dedicated SQL server for the VCDB and other databases (VUM and SSO).  When you mentioned 'embedded' I was thinking of the simple install.  The simple install isn't the best design, but is just that - simple.  In my lab everything is on one VM, and was as simple as pre-5.1.

The vDP appliance I'm using is the 500 GB version.  Something else to note is that I needed to deploy the OVA from the web client. 

Reply
0 Kudos
brunomm
Contributor
Contributor

Hi,

i had the same issue.

just try and deploy the appliance all over again.

Also first try to create the dns entry in the dns server

thanks

Reply
0 Kudos
china69
Contributor
Contributor

I have the same problem

My environment is VC linux appliance standalone (without Windos domain)

VC event log says

User SYSTEM-DOMAIN\admin@ logged out (login time: , number of API invocations: , user agent: ) info 20.9.2012 13:04:33 SYSTEM-DOMAIN\admin

User SYSTEM-DOMAIN\admin@10.22.72.107 logged in as info 20.9.2012 13:04:33 SYSTEM-DOMAIN\admin

User admin has assigned Administrator role on vCenter object.

Message from VDP is

Specified user either is not a dedicated VDP user or does not have sufficient vCenter privileges to administer VDP.  Please update your user role and try again.

Reply
0 Kudos
china69
Contributor
Contributor

I tried to register VDP 5.1 to the vC 5.0 installed as services in Windos and registration also doesn't work .

Probably are some "hidden" undocumented requirements.

Reply
0 Kudos
FL0G
Enthusiast
Enthusiast

@china69:

You need vCenter 5.1 to use VDP:

"VDP requires VMware vCenter Server 5.1 or higher." (From the documentation: http://pubs.vmware.com/vsphere-51/topic/com.vmware.ICbase/PDF/vmware-data-protection-administration-...)

Reply
0 Kudos
krismcewan
Enthusiast
Enthusiast

there is a fix for some issues with VDP released in a KB last week

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=204099...

this may help some of you although not relevant to the issues i have/

Vmware have escalated my VDP call to EMC

A VMware Consultant in Scotland for Taupo Consulting http://www.taupoconsulting.co.uk If you think I'm right or helpful award me some points please
Reply
0 Kudos
DanV42
Contributor
Contributor

The fix is to create a local user on the Windows server running vCenter, then grant admin permissions to it in vCenter (not Windows.)  See "user account configuration" on page 14 in the VDP 5.1 admin guide:  http://pubs.vmware.com/vsphere-51/topic/com.vmware.ICbase/PDF/vmware-data-protection-administration-...

Reply
0 Kudos
BillysGruff
Contributor
Contributor

This SSO bullsh1t just needs to go.  Everyone that I've talked to that has upgraded to 5.1 is still authenticating against AD.  No one gives a sh!t!!!!!  Just make it simple.  I cant stand it when people think its a good idea to re-invent the wheel.

Reply
0 Kudos
emm60
Contributor
Contributor

Hi,

I have a problem with vdp:

Could not connect to the requested VDP appliance,

I have Vcenter appliance and sso enbedded, i try with this articule but the mesage is the same.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=204099...

any idea?

Thanks all

Reply
0 Kudos
krismcewan
Enthusiast
Enthusiast

Emm60

Is this when you deploy the OVF, Set it up. Connects to VCenter then in the Vcenter Web Client clikc on VDP and then connect it wont connect?

A VMware Consultant in Scotland for Taupo Consulting http://www.taupoconsulting.co.uk If you think I'm right or helpful award me some points please
Reply
0 Kudos
emm60
Contributor
Contributor

Yes, i deploy ok and configuration it is ok, but when i try connect with the vdp i received this error

Could not connect to the requested VDP appliance

Reply
0 Kudos
krismcewan
Enthusiast
Enthusiast

this is the issue I have had since beginning of December.

It has been Escalated all the way up to the head of VDP engineering and they are stumped.

They have now pushed it back to Vmware as they are sayign its an SSO error.

Strange as we have Vshield, View, Update Manager and View Composer all plugged into SSo and they all work fine.

interestignly in that article you posted it mentions SSL.  We have put in internal SSL Certs accross the estate and VDP is the only thing we cant put our SSL into and tell it to accept our Cert Server.

I suggest you log a call with Support to highlight the issue so they can put more resource into fixing it.

A VMware Consultant in Scotland for Taupo Consulting http://www.taupoconsulting.co.uk If you think I'm right or helpful award me some points please
Reply
0 Kudos
BillysGruff
Contributor
Contributor

I was able to authenticate finally with my AD username.  I had to add my specific username to the Permissions tab on the vCenter server from within the web client.  I have a group setup and added in this same spot, but apparently that isnt feasible.

Reply
0 Kudos
krismcewan
Enthusiast
Enthusiast

We have a Service account as local and Domain admin as well as VC admin and SSO admin.

still nothing

A VMware Consultant in Scotland for Taupo Consulting http://www.taupoconsulting.co.uk If you think I'm right or helpful award me some points please
Reply
0 Kudos
FroStar
Contributor
Contributor

BillysGruff, that helped us.

For anyone else that it might help, specifically what I did (and I think BillysGruff did) is:

1.  Log in to web client

2.  Choose vCenter under the Home icon on the navigator.

3.  Choose vCenter Servers under the Inventory Lists

4.  Under vCenter Servers, click your desired server

5.  Choose the Manage tab

6.  Choose the Permissions tab

7.  Choose the green + to add a permission

8.  On the left side, choose the desired user using the Add button near the bottom

9.  On the right side, set the assigned role to Administrator using the drop down box near the center.

10.  I chose the propagate option, not sure that is required

11.  Choose OK

kellino
Enthusiast
Enthusiast

I've tried everything thing is this thread from:

1)  pre-populating DNS

2)  Using user@domain instead of domain/user

3)  explicitly adding each user tested to vCenter VM (in vCenter) as an administrator

4)  Using both the FQDN and IP of vCenter server

5)  Creating a local (non-domain) account

6)  Delete VCP appliance and deploy new

Any combination of the above resulted in the following:

Specified user either is not a dedicated VDP user or does not have sufficient vCenter privileges to administer VDP

How in the world does one get this product to actually work?

Reply
0 Kudos
Moto110
Contributor
Contributor

Here is what I did to get this to work.

On the Windows server running vCenter.

1. I created a local account named vdp  (Set password to does not expire and I didn't even make this account an administrator on the local machine)

2. Make sure the password you set for this account does not have any special characters.  (VDP doesn't like this)

Now....

1.  Log in to web client

2.  Choose vCenter under the Home icon on the navigator.

3.  Choose vCenter Servers under the Inventory Lists  (I made the mistake of over looking this part and trying to set these permission on the Windows VM running my vCenter server.  That does not work you HAVE to set the account permissions within the vCenter software NOT  the VM Host.  See attached image for the proper location and permissions to get this working.

vCenter_Permissions.png

4.  Under vCenter Servers, click your desired server

5.  Choose the Manage tab

6.  Choose the Permissions tab

7.  Choose the green + to add a permission

8.  On the left side, choose the desired user using the Add button near the bottom

9.  On the right side, set the assigned role to Administrator using the drop down box near the center.

10.  I chose the propagate option, not sure that is required

11.  Choose OK